Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Matrix/ INDEX/ Sortierung/ SUMME
#1
Hallo Excel Freunde,

Mit der Teil- Funktion lassen sich Elemente einer beliebigen Stelle in einer Zelle Ausgeben TEIL(A1;1;2).
Wie wendet man dies auf eine ganze Zeile an?
TEIL(1:1;1;2) funktioniert leider nicht. Eigentliche geht es Mir darum Eine INDEX/ VERGLEICH Sortierung in Kombination einer SUMME je nach String einer Zelle.

Das ganze soll so aussehen, dass ich Himelsrichtungen Fensterflächen zuweise, um dann die gleichen zu Addieren und in einer seperaten Tabelle auszugeben.
Mein Hauptproblem ist, dass die Anzahl der Fenster, also die Anzahl der Spalten ab D:D variabel ist (1-20). Die Sortierung würde ich gerne mit der Nummer hinter FF und R bewerkstelligen.

Gruß,
Hannes.


Angehängte Dateien
.xlsx   Fenster_Forum.xlsx (Größe: 10,78 KB / Downloads: 9)
Antwortento top
#2
Hallo,

wie flexibel bist du bzgl. des Aufbaus der Tabelle? Im Anhang mein Lösungsvorschlag.


Angehängte Dateien
.xlsx   Fenster_Forum.xlsx (Größe: 13,26 KB / Downloads: 3)
Viele Grüße,
Matthias

-------------------------------------------------------------------------------------------

Man muß nicht alles wissen, man muß nur wissen, wie man die Lösung findet.
[-] Folgende(r) 1 Benutzer sagt Danke an Matthias84 für diesen Beitrag:
  • hanso686
Antwortento top
#3
Hallo Matthias;

Danke für deinen Lösungsvorschlag.
Bei der ersten Tabelle handelt es sich um eine Output Datei, deswegen muss ich mich beim Aufbau der Spalten ziemlich genau dran halten.
Die Zeile dieser Tabelle stellt immer einen ganzen Raum dar. Der Raum mit den meisten Fenstern gibt dabei die Spaltenzahl auch für alle anderen Räume vor.
Zeile 1+FF1 = Raum1+Fläche des 1.Fensters.
Ich habe schon überlegt mit einem Hilfstabellenblatt eine VERKETTUNG anzulegen, um die Daten dann besser sortieren zu können.
ich dachte nur vielleicht gibt es auch eine elegantere Lösung eventuell Blush
Antwortento top
#4
Hi

Wie wäre es damit?
____|___C__|__D_|__E__|__F__|__G__|__H_|__I__|__J__|__K__|__L__|__M__|
   1|      |    |     |     |     |    |     |     |     |     |     |
   2|      |FF1 |FF2  |FF3  |FF4  |FF5 |R1   |R2   |R3   |R4   |R5   |
   3|Raum1 | 2,2|  7,5|     |     |    |West |Ost  |     |     |     |
   4|Raum2 | 9,4|  5,6|  4,8|     |    |Ost  |West |West |     |     |
   5|Raum3 | 3,1|  1,7|  4,2|  7,9|    |Süd  |Ost  |Ost  |Nord |     |
   6|Raum4 | 2,4|  6,6|  8,1|  3,8| 9,5|Nord |Süd  |Süd  |Süd  |West |
   7|      |    |     |     |     |    |     |     |     |     |     |
   8|      |Ost |West |Süd  |Nord |    |     |     |     |     |     |
   9|Raum1 | 7,5|  2,2|    0|    0|    |     |     |     |     |     |
  10|Raum2 | 9,4| 10,4|    0|    0|    |     |     |     |     |     |
  11|Raum3 | 5,9|    0|  3,1|  7,9|    |     |     |     |     |     |
  12|Raum4 |   0|  9,5| 18,5|  2,4|    |     |     |     |     |     |

D9    =SUMMEWENN($I3:$M3;D$8;$D3:$H3)  'nach rechts und unten kopieren

Gruß Elex
[-] Folgende(r) 1 Benutzer sagt Danke an Elex für diesen Beitrag:
  • hanso686
Antwortento top
#5
Hallo Elex,

Das Problem ist das die Fensteranzahl sehr variabel ist (FF1-FF5 oder FF1-FF20), dementsprechend ist die Spaltenanzahl variabel.
Mein Lösungsansatz wäre dann schon in Richtung INDEX und VERGLEICH gegangen - nur hab ich dann das Problem mit der Identifizierung der Fensternummer, da ich mit TEIL nur einzelne Zellen ansteuern kann.

Aber ansonsten bin ich nicht auf die SUMMEWENN Funktion gekommen - Ein interressantes Konzept.
Antwortento top
#6
Zitat:Bei der ersten Tabelle handelt es sich um eine Output Datei
Wer ist der Auftraggeber für diese Output Datei? Du? Dann würde ich mir an deiner Stelle überlegen, ob du nicht einen veränderten Aufbau der Datei beauftragen kannst, evtl. schon in deiner finalen Form...
Viele Grüße,
Matthias

-------------------------------------------------------------------------------------------

Man muß nicht alles wissen, man muß nur wissen, wie man die Lösung findet.
Antwortento top
#7
Ja, dass hatte ich jetzt schon versucht, dass einfach Default 30 "leere" Spalten ausgegeben werden.
Ich versuche mal ob ich es damit Sortiert bekomme.
Antwortento top
#8
Hi

flexibel in D9.
Code:
=SUMMEWENN(BEREICH.VERSCHIEBEN($D3;;VERGLEICH("R1";$D$2:$BB$2;0)-1;;ZÄHLENWENN($D$2:$BB$2;"r*"));D$8;BEREICH.VERSCHIEBEN($D3;;;;ZÄHLENWENN($D$2:$BB$2;"F*")))
Wenn du den Dateninput selbst erstellst, solltest du aber eher dort ansetzen.

Gruß Elex
[-] Folgende(r) 1 Benutzer sagt Danke an Elex für diesen Beitrag:
  • hanso686
Antwortento top
#9
Wow danke, megagut jetzt beide Varianten zu haben. Ich werd das mal austesten danke, deine erste Lösung hat aber schon sehr gut in Kombination mit Veränderung der Inputdatei funktioniert.
Klasse!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste