Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

wenn
#1
Hallo 

einfache Frage, bin Anfänger

in A1 steht entweder eine Zahl und s, oder eine Zahl und H und ich brauche in B1 bei s die Zahl negativ ohne S, bei H in B1 eben die Zahl positiv und ohne H

Danke an die Könner
Antwortento top
#2
Code:
=WENN(RECHTS(A1;1)="s";--LINKS(A1;LÄNGE(A1)-1);LINKS(A1;LÄNGE(A1)-1))
Schöne Grüße
Berni
[-] Folgende(r) 1 Benutzer sagt Danke an MisterBurns für diesen Beitrag:
  • Django 48
Antwortento top
#3
Hallo, geht bestimmt auch eleganter..:

PHP-Code:
=LINKS(A1;SUCHEN(" ";A1))*WAHL(1+(RECHTS(A1;1)="s");1;-1
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#4
Danke danke

klappt 100%
Antwortento top
#5
Hallo, noch ein wenig kürzer..:

Arbeitsblatt mit dem Namen 'Tabelle2'
ABC
115 S-15-15
22,5 H2,52,5

ZelleFormel
B1=LINKS(A1;SUCHEN(" ";A1))*(-1+(RECHTS(A1;1)="h")*2)
C1=LINKS(A1;SUCHEN(" ";A1))*WAHL(1+(RECHTS(A1;1)="s");1;-1)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Django 48
Antwortento top
#6
Hola,

und bitte bitte bitte wähle mal aussagekräftige Betreffs.
Ich weiß, Django ist ein Freund weniger Worte....

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • EasY
Antwortento top
#7
Kann man mittels "User: django, (10) Themen" einwandfrei bestätigen.
Antwortento top
#8
vielen Dank

schöne Lösung
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste