Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wie kann die Funktion automatisch (mit Doppelklick) auf die weitere Zeilen übertragen
#1
Ich möchte die Werte nicht pro Zeile manuell bearbeiten müssen.
In meinem Beispiel habe ich eine Tabelle mit dem Namen ALLE, diese beinhaltet  Werte, die auf die weiteren Tabellenblätter (Fall1 – Fall3) automatisch angezeigt werden sollen.
Die Verweise sind über die Auswahl des Falles gesteuert. In jedem Tabellenblatt gibt es die Auswahl in der Zeile A1.
Und je nach dem welchen Fall ich aus dem Dropdown wähle, sollen die Werte pro Fall ausgegeben sein.
Fall1 Wert1-21
Fall2 Wert 22-42
Fall3 Wert 43-63
Aktuell habe ich aber Schwierigkeiten die Formel automatisch zu übertragen, in der ganzen Spalte sind die gleiche Werte angezeigt.
Ich habe schon alles Mögliches versucht, dabei ist die Lösung bestimmt ganz simpel, nur komme ich grade nicht drauf. Dodgy
Vielen, vielen Dank!


Angehängte Dateien
.xlsx   Verweis_mit_Bed.xlsx (Größe: 13,5 KB / Downloads: 3)
Antwortento top
#2
Hi,

nimm den SVERWEIS(), dann klappt's auch:

Arbeitsblatt mit dem Namen 'Fall1'
AB
2AttributeWerte
3Attribut1Wert1
4Attribut2Wert2
5Attribut3Wert3

ZelleFormel
B3=SVERWEIS($A3;ALLE!$A$1:$D$224;2;0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Für die beiden anderen Tabellenblätter musst du halt den Spaltenindex anpassen.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
oder

Code:
=SVERWEIS($A3;ALLE!$A$1:$D$224;VERGLEICH($A$1;ALLE!$A$1:$D$1;0);0)

oder

Code:
=WVERWEIS($A$1;ALLE!$A$1:$D$224;ZEILE()-ZEILE($B$2)+1;FALSCH)
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste