Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zellinhalt mit 2 Suchkriterien übernehmen?!? Formel gesucht!
#1
Hallo zusammen!
 
Ich benötige Eure Hilfe Huh
 
Ich habe im Anhang befindet sich zur Verdeutlichung eine Excelliste. Auf der ersten Tabelle befinden sich Daten (Umsätze, alle Werbeträger mit Auflagen und Kosten pro PLZ), die nach Postleitzahlen sortiert sind.
Auf der 2. und 3. Seite befindet sich ein Werbeträger. Die Postleitzahlen des Werbeträgers sind bekannt und bereits eingetragen.
Nun zur Aufgabe:
Nur Übersicht sollen nur die Zeilen übernommen werden, in dem ein Werbeträger vertreten ist. Auf dem 2. Tabellenblatt wäre das der „Werbeträger 1“. Die vertretenden PLZ sind bereits eingetragen und jetzt sollen die restlichen Daten aus dem ersten Tabellenbaltt übernommen werden.
Wer kann mir dafür die Formatierungen eintragen? 18 

Vielen Dank dafür  Angel


.xlsx   Excel Hilfe.xlsx (Größe: 27,49 KB / Downloads: 7)
Antwortento top
#2
Moin,

mit einer INDEX/VERGLEICH-Formel holst du als erstes die Nummer, danach kannst du mit einem SVERWEIS() dir den Rest auslesen.

Arbeitsblatt mit dem Namen 'Exceltabelle 2'
ABC
1Nr.PostleitzahlOrt
22926180Rastede
33426215Wiefelstede
43926349Jade
53826345Bockhorn
63726340Zetel
73626316Varel

ZelleFormel
A2=INDEX('Exceltabelle 1'!A:A;VERGLEICH(B2;'Exceltabelle 1'!$B$1:$B$48;0))
C2=SVERWEIS(A2;'Exceltabelle 1'!A:N;3;0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • dennis1793
Antwortento top
#3
Vielen Dank schonmal für die AntwortSmile

Magst du mir eine Zeile mit deiner Formatierung füllen? Für mich als "Excel-Laie" ist das zu viel  Undecided 

Danke Dir 15
Antwortento top
#4
Hallo Dennis,

du siehst meine Formeln(!!!) - nicht Formatierung; das ist etwas anderes. Lies dich über die OH in den SVERWEIS() ein und versuche erst einmal, selber klar zu kommen. Mit einer vorgefüllten Zeile dürfte der Lerneffekt nicht besonders groß sein und bei notwendigen Anpassungen stehst du sonst wieder auf dem Schlauch.

Du darfst dich aber selbstverständlich wieder melden, wenn du nicht klar kommst. Ein händisch eingetragenes Wunschergebnis in einer Zeile wäre dann aber sehr von Vorteil.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • dennis1793
Antwortento top
#5
Ich komme mit dem SVERWEIS nicht weiter. Die anderen Zellen konnte ich bereits ausfüllenSmile Magst du mir für O2 die Formel sagen?   20
Antwortento top
#6
Hi Dennis,

wie ich bereits geschrieben habe, solltest du dich wirklich zwingend damit auseinandersetzen. Du wirst bei jeder kleinen Änderung sonst wieder nachfragen müssen.

Arbeitsblatt mit dem Namen 'Exceltabelle 2'
ABCDEFGHIJKLMNOP
1Nr.PostleitzahlOrtGebietsstrukturEinwohnerHaushalteKaufkraft pro HaushaltKaufkraft pro Haushalt GesamtKaufkraft pro Haushalt IndexUmsatz Jan - OktWerbeeinsatzquoteUmsatz pro HaushaltWerbekosten pro HaushaltWerbekosten Gesamt PLZWerbeträger 1 Auflage 2018Werbeträger 1 Kosten Januar 2018
22926180RastedeAmmerland21623993847009,8467183392105,7310000000100,6238680000

ZelleFormel
A2=INDEX('Exceltabelle 1'!A:A;VERGLEICH(B2;'Exceltabelle 1'!$B$1:$B$48;0))
C2=SVERWEIS($A2;'Exceltabelle 1'!$A:$AB;SPALTE(C$1);0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Den Suchbereich habe ich in kompletten Spalten angegeben (A:AB). Wenn dein Excel langsam wird, solltest du den Bereich verkleinern - z.B. A1:AB1000. Du siehst auch die Formel etwas verändert. Den Spaltenindex habe ich flexibel gestaltet, so dass du die Formel nur einmal (in C2) eintragen musst und dann nach rechts und nach unten ziehen kannst.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • dennis1793
Antwortento top
#7
Vielen Dank für die Antwort. Ich sitze gerade nicht am PC und kann dieses bearbeiten. 
Ist die Formel so aufgebaut, dass nur die Spalten des Werbeträgers übernommen werden, die auch in der PLZ vorhanden sind und dann nicht alles genullt wird?

Danke und Gruß
Antwortento top
#8
Hallo Günter, vielen Dank für Deine Hilfe. 05

Habe das jetzt gerade mal am Rechner getestet. Wie sieht die Formel aus, wenn mehrere Werbeträger vorhanden sind? Ich bekomme andere Werte bei dem Werbeträger heraus, als auf dem 1. Blatt. Huh

Danke und Gruß
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste