Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Duplikate mit Statuse finden
#1
Hallo,

ich habe eine Tabelle mit ca. 3000 Zeilen
In diesen Zeilen sind unterschiedliche Artikel aufgeführt.
Wenn sich an einem Artikel was ändert dann wird dieser mit einem Änderungstand dokumentiert und der Status grün vergeben.
Der vorherige sollte jedoch rot werden. Verwaltungsprogramm ist kein Excel. Ich habe dies nur als Excel-Datei ausgespielt um hier Filtern zu können.

Bsp: 
Artikel        Änderungstand      Status
35412            00                  grün    (<--dieser müsste normalerweise rot sein)
35412             01                   grün

Bei diesem Fehler sollte dann in einer anderen Zelle der Wert 1 ausgegeben werden, wenn gleicher Artikel mit 2x Status grün versehen sind.

Könnt ihr mir bitte helfen?

Vielen Dank für eure Hilfe
Antwortento top
#2
Bitte zeige uns eine Beispieldatei!
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#3
Hallöchen,

hier mal was, wie man Spalte C korrekt füllen könnte, die Fehleranzeige auf Basis von Deiner Beispieldaten / -tabelle kommt gleich noch ...

Arbeitsblatt mit dem Namen 'Tabelle1'
ABC
1B0rot
2A0grün
3B1grün

ZelleFormel
C1{=WENN(B1<MAX(WENN($A$1:$A$5=A1;$B$1:$B$5;0));"rot";"grün")}
C2{=WENN(B2<MAX(WENN($A$1:$A$5=A2;$B$1:$B$5;0));"rot";"grün")}
C3{=WENN(B3<MAX(WENN($A$1:$A$5=A3;$B$1:$B$5;0));"rot";"grün")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#4
Hallöchen,

Du wolltest es so haben?

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
1B0grünFehler
2A0grün
3B1grün

ZelleFormel
D1{=WENN(B1<MAX(WENN($A$1:$A$5=A1;$B$1:$B$5;0));"Fehler";"")}
D2{=WENN(B2<MAX(WENN($A$1:$A$5=A2;$B$1:$B$5;0));"Fehler";"")}
D3{=WENN(B3<MAX(WENN($A$1:$A$5=A3;$B$1:$B$5;0));"Fehler";"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#5
Photo 
Hallo 

vielen Dank für die Antwort.
Irgendetwas mach ich glaube ich falsch.

ich habe ein Bild angehängt wie ich es benötigen würde. 
   
Ich benötige die Ausgabe in 0 und 1 um Anschließend zählen zu können.


Kann mir jemand weiterhelfen?

vielen Dank schon im Voraus für eure Hilfe.
Antwortento top
#6
Hallo Daniel,

hast du gesehen, dass es sich um eine Matrixformel handelt, die nicht mit einfachem Enter abgeschlossen wird, sondern mit STRG-UMSCHALT-ENTER
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#7
Hallöchen,

hier mal eine Erweiterung, Wenn Du auch auf "grün" prüfen willst, dann kann man beides per "UND" verknüpfen. Musst nur wieder Deine 0 und 1 "verarbeiten" Smile

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
1B0grünFehler
2A0rot
3B1grün
4A1grün

ZelleFormel
D1{=WENN(UND(B1<MAX(WENN($A$1:$A$5=A1;$B$1:$B$5;0));C1="grün");"Fehler";"")}
D2{=WENN(UND(B2<MAX(WENN($A$1:$A$5=A2;$B$1:$B$5;0));C2="grün");"Fehler";"")}
D3{=WENN(UND(B3<MAX(WENN($A$1:$A$5=A3;$B$1:$B$5;0));C3="grün");"Fehler";"")}
D4{=WENN(UND(B4<MAX(WENN($A$1:$A$5=A4;$B$1:$B$5;0));C4="grün");"Fehler";"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#8
Wink 
Vielen Dank 
es hat funktioniert 19 Thumbsupsmileyanim
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste