Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn Wert=True füge AX in die nächste freie Zeile ein, möglich ohne VBA?
#1
Hallo,

ich habe Checkboxen in einem Sheet und möchte wenn die Checkbox angeklickt wird, dass ein Wert in die nächste freie Zeile/Zelle in einem anderen Sheet zugewiesen wird. Was ich aktuell hinbekommen habe, ist mit =WENN(C4=WAHR;A4;"") dass der Wert in eine spezifische Zelle angegeben wird.

Da ich mehrere Checkboxen habe möchte ich dass am Ende eine Liste entsteht die keine Lücken aufweist. Aktuell würden alle Zeilen/Zellen leer sein, falls die dazugehörige Zelle nicht WAHR ist.

Ist es möglich, mein beschriebenes Ziel ohne VBA Code zu erreichen?
Antwortento top
#2
Hallo,

stell mal bitte eine abgespeckte und anonymisierte Beispieltabelle, die vom Aufbau her aber deinem Original gleichen muss, vor.  https://www.clever-excel-forum.de/thread-326.html
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Hallöchen,

rein von der Logik hast Du da ein Problem. Sobald Du auf die Checkbox klickst, ist die gerade noch freie Zelle mit WAHR belegt und die nächste freie Zelle ist, wie die Beschreibung schon vermuten lässt, die nächste Zelle. Du siehst also in der Checkbox keinen Haken bz. de rgerade eingefügte Haken ist wieder weg.

Um das mal zu testen, kannst Du mit dem Namensmanager einen Bereich benennen:

z.B.
Zuweisung
mit der Formel
=INDEX(Tabelle1!$A:$A;AGGREGAT(14;4;(Tabelle1!$A:$A<>"")*ZEILE(Tabelle1!$A:$A);1)+1)

Dann erstellst Du eine Checkbox und als Zellbezug nimmst Du Zuweisung.

Wenn Du dann Klickst, erscheint in Spalte A nacheinander eine Liste mit "WAHR"


   
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste