Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Suchen von Namen bzw Teile, Ausgabe der gefundenen Werte
#1
Hallo Gemeinde, 

ich bin am Verzweifeln. Dabei möchte ich wetten, dass die Lösung einfach ist. 

Folgendes Szenario: 

Wir haben ca 1500 Diensthandys in Gebrauch. Die Nummern sind in einer Excel-Datei gespeichert. Diese darf den Unternehmsserver nicht verlassen. 

Ich arbeite mit einer selbst gebastelten Exceldatei, welche bei Start diese Telefonliste importiert (und beim Schließen den Import  wieder löscht)

Bei der Masse an Namen sind natürlich Dopplungen normal. Das heißt, wenn ich "Müller" eingebe, will ich sämtliche Mitarbeiter angezeigt haben, welche Müller heißen. Das selbe gilt, wenn ich Vornamen eingebe, also ich bekomme alle Nachnamen, wenn ich "Manfred"eingebe. So weit, so gut ... das habe ich hinbekommen. 

Allerdings ist mir das zu umständlich, da ich immer den kompletten Wortlaut eingeben muss. Sinnvoller wäre, wenn ich nur "Mül" oder "Man" eingebe, und es werden mir alle aufgelistet, die "Mül" oder "Man" im Namen haben. Die importierte Datei hat für die Namen 3 Spalten, einmal den kompletten Namen (Vor- und Zuname mit Komma und Freizeichen getrennt) und jeweils eine Spalte für Vor- sowie Nachname. 

Das heißt, ich suche eine Formel (oder ein Makro), welche in der importierten Liste die Spalte mit den kompletten Namen durchsucht und mir unter dem Suchfeld alle Ergebnisse liefert.
Da ich mit dem Ergebnis einen SVERWEIS für die Telefonnummern machen, welche dann per Knopf und Click2Call angewählt wird, ist eine Lösung mittels Autofilter nicht möglich.

Ich habe mal zum Veranschaulichen das Suchgerüst meiner Datei nachgebaut und hochgeladen. 

Vielen Dank schonmal für Eure Hilfe.

LG


Angehängte Dateien
.xlsx   Arbeit_Suche_beispiel.xlsx (Größe: 38,07 KB / Downloads: 8)
Antwortento top
#2
Hola,

hier mal das Beispiel für die Suche nach dem Vornamen:

Code:
=WENNFEHLER(INDEX('Import-Liste'!$B$2:$B$20;AGGREGAT(15;6;ZEILE($A$2:$A$20)-1/(ISTZAHL(SUCHEN(Suche!$H$1;'Import-Liste'!$B$2:$B$20)));ZEILE(A1)));"")

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste