Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zeit Stempel mit WENN Formel
#1
Hallo
 
Habe ein Problem mit meinem Versuch einen Zeit Stempel zu setzten bei Änderung eines Eintrages.
Meine Formel:
 
" =WENN(H11="";"";WENN(G5<>"";G5;JETZT()-HEUTE()))"
Funktioniert soweit.
Mein Problem ist das ich diese Formel auch in den Angrenzenden Zeilen mit angepassten Zellbezügen
"=WENN(J11="";"";WENN(I5<>"";I5;JETZT()-HEUTE()))"
verwenden möchte. Er jedoch dann auch den Zeit Stempel der angrenzenden Zellen überschreibt.
Was mache ich falsch ??
Antwortento top
#2
Hi,

erkläre mal bitte genauer, was du damit bezweckst. In welcher Zelle steht deine Formel?
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Deine Formel bildet keine fixen Werte, sondern berechnet bei jeder Aktualisierung des Tabellenblattes neu.

Einen echten Zeitstempel bekommst du per VBA.
Antwortento top
#4
Zitat:Mein Problem ist das ich diese Formel auch in den Angrenzenden Zeilen mit angepassten Zellbezügen
"=WENN(J11="";"";WENN(I5<>"";I5;JETZT()-HEUTE()))"
verwenden möchte. Er jedoch dann auch den Zeit Stempel der angrenzenden Zellen überschreibt.

Die Formeln funktionieren, vorausgesetzt die iterative Berechnung in dem Optionen ist aktiviert sonnst entsteht ein Zirkelbezug
Gruß Holger
Antwortento top
#5
Hallo,

Zitat:Geschrieben von Cadmus - 20.11.2018, 20:01
Deine Formel bildet keine fixen Werte, sondern berechnet bei jeder Aktualisierung des Tabellenblattes neu. 

Einen echten Zeitstempel bekommst du per VBA.

Das wäre dann sowas in dieser Art

Zitat:Option Explicit

Sub Makro1()
    ActiveCell.FormulaR1C1 = "=TEXT(TODAY(),""TTMM"")"
End Sub


Sub Makro2()
'und so mit Verketten
    ActiveCell.FormulaR1C1 = "=TEXT(TODAY(),""TT."" & ""MM."" & ""JJJJ"")"
End Sub
________________________________________________________________________
wer aufgibt, ohne es versucht zu haben, gibt einfach nur auf!

Grüße aus Norderstedt, Peter
Antwortento top
#6
Zitat: schrieb:Geschrieben von Cadmus - 20.11.2018, 20:01
Deine Formel bildet keine fixen Werte, sondern berechnet bei jeder Aktualisierung des Tabellenblattes neu. 

Einen echten Zeitstempel bekommst du per VBA.
Hallo
Ich finde die Formellösung auch nicht besonders gut, aber funktionieren tut das sehr wohl.
Siehe oben
Gruß Holger
Antwortento top
#7
Hallo

Die Formel steht in Zelle H11 und J11 und soll abfragen ob in Zelle G5 oder I5 Werte geändert werden. Wobei es nur vier Werte gibt ("";0;1;2) die dort vorkommen können.
Es soll eine Kontroll Liste wedren. Wo eingetragen wir (i.O oder niO) die Liste wird immer wieder verwendet, deswegen kann man sie zurücksetzen auf "" oder "0" dann ist alles wieder leer.
Um die Zeit der Änderung fest zu halten wollte ich den Zeit Stempel einbauen. Damit man die Zeit nicht eintragen muss. Sie soll später als PDF abgespeichert werden und dann neu ausgefüllt werden.
Habe zuerst versucht die Zeit aus einem Feld als text einzufügen. Aber mit WENN bekomme ich das nicht hin.
Hoffe du hast es jetzt besser Verstanden.

Aber egal ob du eine Lösung findest. Danke das du dich für mein Problem Interesierst.

MfG
Antwortento top
#8
Danke für den Hinweis.
Werde morgen gleich nach der Einstellung suchen.

Danke

MfG
Antwortento top
#9
Zitat:Die Formel steht in Zelle H11 und J11 und soll abfragen ob in Zelle G5 oder I5 Werte geändert werden.

Zitat:=WENN(H11="";"";WENN(G5<>"";G5;JETZT()-HEUTE()))
Diese Formel macht es umgekehrt: sie müßte in G5 stehen und fragt H11 ab.
Gruß Holger
Antwortento top
#10
Hallo Käptn

Danke für deine Antwort.
Wie ich schon schrieb arbeite ich lieber mit Formeln. Aber wenn ihr mir sagt es gibt keinen anderen Weg, will ich ihn gehen.
Dazu benötige ich aber etwas mehr Hilfe. Ich kann VBAs aufzeichnen und zum Teil auch kürzen oder leicht anpassen. Betonung liegt auf "leicht" dazu muss ich aber den Code genau verstehen.
Das fällt mir leider nicht sehr leicht.
ActiveCell. = aktive Zelle (Bedeutet ?)List er alle aktiven Zelle auf veränderungen aus??
FormulaR1C1 = = aktives Blatt Zeile 1 Spalte 1 = A1 ??
dort komt das Datum als Text rein ??"=TEXT(TODAY(),""TTMM"")"

und was meinst du mit Verketten ?

Danke für dein Interesse und Hilfe.

MfG
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste