Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Excel in Kombination mit Laufwerk Ordner
#1
Guten Tag,

ich würde gerne eine Excel Datei erstellen die in Kombination mit einem Ordner funktioniert.

Ich möchte, wenn ich eine Datei in den Ordner einfüge, das die Excel Datei dies erkennt und dann beispielsweise ein X in der Tabelle erscheint.

Z.B.:                    Abgelegt

RECHNUNGXY           X

RECHNUNGZY            

RECHNUNGZX.          X

Hoffe es kann jemand helfen Smile.

MfG
Antwortento top
#2
Du könntest in einer Schleife alle x Minuten (Sekunden/Stunden...) per VBA prüfen lassen, ob in einem Ordner eine oder mehrere Dateien vorhanden sind und das "x" dann in deine Tabelle eintragen lassen. Ob Excel dazu das geeignete Programm ist (Ressourcen) musst du testen. Ansonsten mit "externen" Tools den/die Ordner prüfen und in Excel schreiben lassen.
Herzliche Grüße aus dem Rheinland
Lucky Joe

[Windows 10, Office 2016]
Antwortento top
#3
Hallöchen,

… oder so. Die Formel ziehst Du so weit nach unten, wie Du Dateien erwartest. Ab und Zu drückst Du F9, die Liste in Spalrte A wird aktualisiert und eventuell gibt es andere x in Spalte B.

Arbeitsblatt mit dem Namen 'Tabelle1'
ABC
11.xlsmx1.xlsm
220180826_Urlaubskalender_fuer_Forum (1).xlsm2.xlsm
3ArrayFormelKopieren.xlsx
4BeispielReiheGefiltert.xlsm

NameBezug
Ordnerinhalt=DATEIEN("G:\*.xls*")

ZelleFormel
A1=INDEX(Ordnerinhalt;ZEILE())
B1=WENN(ZÄHLENWENN($A$1:$A$4;C1)>0;"x";"")
A2=INDEX(Ordnerinhalt;ZEILE())
B2=WENN(ZÄHLENWENN($A$1:$A$4;C2)>0;"x";"")
A3=INDEX(Ordnerinhalt;ZEILE())
A4=INDEX(Ordnerinhalt;ZEILE())
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#4
Hallo Migo.

Ich habe Dir ein Makro entwickelt, welches alle 30 Sekunden aufgerufen wird, nachdem das excel geöffnet wurde.

Es prüft, ob im gleichen Verzeichnis die Dateien aus Spalte A mit der Endung .xslx vorhanden sind und füllt dann Spalte B mit Ja oder Nein. 

Rückfragen und Kritik gerne.

Peter


Angehängte Dateien
.xlsm   810 Forum 2018.11.21 Laufwerk prüfen.xlsm (Größe: 18,12 KB / Downloads: 1)
Antwortento top
#5
Noch eine kleine Korrektur.


Angehängte Dateien
.xlsm   810 Forum 2018.11.21 Laufwerk prüfen.xlsm (Größe: 18,1 KB / Downloads: 4)
Antwortento top
#6
Hallo Migo.

Jetzt musst Du nicht mehr nachsehen. Wenn die Datei einmal geöffnet wurde, erhältst Du eine E-Mail, sobald alle vorgegebenen Dateien in Spalte A gefunden wurden. 

Rückfragen gerne.

Peter


Angehängte Dateien
.xlsm   810 Forum 2018.11.21 Laufwerk prüfen.xlsm (Größe: 19,13 KB / Downloads: 1)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste