Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zellen für bestimmten Wert sperren, wenn in Spalte nicht ein Wert erfüllt ist
#1
Hallo Miteinander,

ich bin Neuling und habe ein Problem.
Ich habe einen Arbeitsplan, in welchen sich Arbeitnehmer in diesem Fall Zeile 12-27 mit verschiedenen Diensten (z.B. "F"; "TD", "VS", "So", "S") in Datumsspalten z.B. C eintragen können.
Jetzt möchte ich die Zellen C12-C27 für den Wert Spätdienst ("S") sperren, wenn nicht in dieser Spalte bereits zwei Mal "VS" eingetragen ist. Andere Dienste sollen eintragbar bleiben.
Das mit dem Gültigkeitsbereich habe ich jetzt schon ein bißchen ausprobiert, stoße aber klar an meine Grenzen.
Über Hilfe würde ich mich sehr freuen - wenn möglich auch mit Erläuterung.

Danke und Grüße

Benni
Antwortento top
#2
Hallo Benni,

erstelle auf einem zweiten Tabellenblatt eine Liste mit deinen Buchstaben, die so aussieht
Tabelle1

N
1F
2TD
3VS
4So
5
Formeln der Tabelle
ZelleFormel
N5=WENN(ZÄHLENWENN(Tabelle1!$C$12:$C$27;"VS")>=2;"S";"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Danach markierst du den Bereich C12:C27 und gibst beim Gültigkeitsbereich als Liste den Verweis auf diese Liste ein - Achtung, unbedingt die letzte Zeile mit der Wennformel mitnehmen.
Schöne Grüße
Berni
Antwortento top
#3
Hallo,

mit diesem Makro im Modul des Tabellenblattes würde es gehen:

Code:
Private Sub Worksheet_Change(ByVal Target As Range)
   If Application.WorksheetFunction.CountIf(Range("A:A"), "VS") <= 2 Then
       If Cells(Target.Row, 1) = "V" Then Cells(Target.Row, 1) = ""
   End If
End Sub
Viele Grüße
Klaus-Dieter
Antwortento top
#4
Hi

Gültigkeit für C12:C27
=oder(($C12<>"S");(ZÄHLENWENN($C$12:$C$27;"VS")>1))

Gruß Elex
Antwortento top
#5
Danke an alle für die Hilfe.
Jetzt habe ich verschiedene Lösungsansätze und kann selber ein bisschen probieren.
Danke!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste