Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Automatisch Daten aus verschiedenen Quellen zusammenstellen
#1
Hallo,

ich habe folgendes Problem bzw. suche nach einer Lösung für dieses Anliegen.
Ich habe ein Tabellenblatt1 mit folgendem Aufbau:
?mage



Ich hätte nun gerne in einem anderen Tabellenblatt folgendes gerne gelöst:
1) Ich möchte für jeden Tag (oben links- hier Montag) die Namen von allen Kindern aufgelistet haben, die am Montag in der Betreuung sind - als in Tabellenblatt1 bei Montag ein "ja" stehen haben. Alle Kinder mit "nein" bei Montag sollte nicht aufgelistet werden und das auch nicht in versteckten Zeilen (wenn z.B. über Filter gelöst)
2) Bei "Besonderes" hätte ich gerne die besuchten AGs aufgelistet.

?mage


Ist das möglich bzw. wie muss ich die Daten ändern, damit das klappen kann?

Danke für Eure Hilfe!
Antwortento top
#2
Hallo Markus,

bitte keine Bildchen, sondern eine Beispieldatei mit händisch eingetragenem Wunschergebnis.  https://www.clever-excel-forum.de/thread-326.html
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Das geht prima z.b. mit index(;aggregat();) dazu wäre ein Bsp. Datei von vorteil!
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#4
Hallo,

Danke für die schnelle Rückmeldung.
Hier ist die Beispieldatei.

Danke!


Angehängte Dateien
.xlsx   test.xlsx (Größe: 10,35 KB / Downloads: 5)
Antwortento top
#5
so..
Arbeitsblatt mit dem Namen 'Zusammen'
ABCDE
1Zusammenfassung Kinder in Betreuung
2
3MontagDienstagMittwochDonnerstagFreitag
4Aa, MarthaBb, FabianBb, FabianBb, FabianBb, Fabian

ZelleFormel
A4=WENNFEHLER(INDEX(Tabelle1!$A:$O;AGGREGAT(15;6;ZEILE(Tabelle1!I1:I300)/(Tabelle1!I1:I300="Ja");ZEILE(Zusammen!A1));3);"-")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Angehängte Dateien
.xlsx   test Betreuung.xlsx (Größe: 22,54 KB / Downloads: 6)
Eine Menge reden, aber nichts sagen können viele...
[-] Folgende(r) 1 Benutzer sagt Danke an Frogger1986 für diesen Beitrag:
  • markus123
Antwortento top
#6
Moin,

ich hab's so verstanden:

Arbeitsblatt mit dem Namen 'Montag auto'
ABCDEFGHI
1MontagName des KindesKlasseUnterschrift bei Anmeldung/ LernzeitentschuldigtUnterschrift bei AbmeldungUhrzeitAnwesend bei LernzeitBesonderes
2Hallo, mein Ziel ist es, dass hier alle Kinder ("gesamter Name") aufgelistet werden, die am Montag in der Betreuung sind, also im ersten Reiter bei Montag ein "Ja" stehen haben --> das gleiche möchte dann für die anderen Tage haben, sodass, ich die Tabs so ausdrucken kann, dass ich eine ansehnliche Tabelle habe, auf der man dann bei den anderen Spalte handschriftlich noch etwas eintragen kann (vielleicht so 20 Kinder pro Seite untereinander)Hier soll wenn möglich irgendwie stehen,
in welchen Ags die Kinder sind, aber dafür
muss die Daten vermutlich anders aufbereiten?
3
4MontagName des KindesKlasseUnterschrift bei Anmeldung/ LernzeitentschuldigtUnterschrift bei AbmeldungUhrzeitAnwesend bei LernzeitBesonderes
5JaAa, Martha5aSchach Hockey Kunst
6JaBb, Fabian6bFußball

ZelleFormel
A5=WENNFEHLER(SVERWEIS($B5;Tabelle1!$C$1:$Q$3;7;0);"")
B5=WENNFEHLER(INDEX(Tabelle1!C:C;AGGREGAT(15;6;ZEILE(Tabelle1!$C$2:$C$3)/(Tabelle1!$I$2:$I$3="ja");ZEILE(Tabelle1!A1)));"")
C5=WENNFEHLER(SVERWEIS($B5;Tabelle1!$C$1:$Q$3;5;0);"")
I5=WENNFEHLER(SVERWEIS($B5;Tabelle1!$C$1:$Q$3;12;0)&" "&SVERWEIS($B5;Tabelle1!$C$1:$Q$3;13;0)&" "&SVERWEIS($B5;Tabelle1!$C$1:$Q$3;14;0)&" "&SVERWEIS($B5;Tabelle1!$C$1:$Q$3;15;0);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • markus123
Antwortento top
#7
Hallo, ich würde das bei gegebener Datei (Struktur) formeltechnisch wahrscheinlich so lösen...:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCGHIJKLMNOPQ
1Schüler VornameSchüler NachnameGesamter NameKlasseGeburtsdatumMontagDienstagMittwochDonnerstagFreitagAGAG2Ag3AG4
2MarthaAaAa, Martha5a08.05.2008JaNeinNeinNeinNeinSchachHockeyKunst
3FabianBbBb, Fabian6b01.06.2008JaJaJaJaJaFußballHallenhalma

ZelleFormel
C2=B2&", "&A2
C3=B3&", "&A3
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Arbeitsblatt mit dem Namen 'Auto'
ABCDEFGHI
1FreitagName des KindesKlasseUnterschrift bei Anmeldung/ LernzeitentschuldigtUnterschrift bei AbmeldungUhrzeitAnwesend bei LernzeitBesonderes
22Bb, Fabian6bFußball  Hallenhalma

ZelleFormel
A2=WENNFEHLER(AGGREGAT(15;6;ZEILE($A$2:$A$7)-1/(INDEX(Tabelle1!$I$2:$M$10;;VERGLEICH($A$1;Tabelle1!$I$1:$M$1;0))="ja");ZEILE(A1));"")
B2=WENN($A2="";"";INDEX(Tabelle1!$C$2:$C$10;$A2))
C2=WENN($A2="";"";INDEX(Tabelle1!$G$2:$G$10;$A2))
I2=WENN(B2="";"";INDEX(Tabelle1!$N$2:$N$10&" "&Tabelle1!$O$2:$O$10&" "&Tabelle1!$P$2:$P$10&" "&Tabelle1!$Q$2:$Q$10;VERGLEICH(B2;Tabelle1!$C$2:$C$10;0)))
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • markus123
Antwortento top
#8
Hallo,

vielen Dank für die Rückmeldungen. Irgendwas scheint aber noch nicht zu stimmen oder ich mache etwas falsch, aber wenn ich die Tabelle1 erweitere, werden die Daten nicht gezogen. Könnt Ihr mir vielleicht helfen? Die Lösung von Jockel scheint bis dahin zu klappen.
Außerdem müsstet ihr mir noch verraten, was ich ändern muss, damit es dann auch mit den anderen Tagen in anderen Tabs klappt. Ich habe die Datei nochmal beigefügt.

Viele Grüße
Markus


Angehängte Dateien
.xlsx   test2.xlsx (Größe: 19,36 KB / Downloads: 8)
Antwortento top
#9
Hallo, ich denke du musst die Bereiche anpassen und realtive und absolute Bezüge einbauen...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • markus123
Antwortento top
#10
Hallo Jockel,

ich verstehe leider nicht, warum manche Infos gezogen werden und andere nicht. Ich würde mich echt freuen, wenn sich das nochmal jemand in der Datei ansehen könnte.
Danke.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste