Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SVerweis kein Treffer -> nach anderem Wert suchen!
#1
   

Hey, 

ich suche eine Formel für die Spalte E! (ich habe sie in dem Bild manuell ausgefüllt um zu verdeutlichen!)

Ich habe 3 Spalten ( A B C ) mit werten ... ich suche einen Sverweis welcher nach allen 3 werten also zb A1 B1 C1 in Spalte H sucht und dann den zugehörigen Wert aus Spalte I in Spalte E einträgt ... 

Es sollen NICHT alle 3 Kriterien erfüllt sein sondern quasi :

Suchen nach A1 -> Wenn keine Treffer -> suchen nach B1 -> Wenn keine Treffer -> suchen nach C1 -> wenn kein Treffer -> Leere Zelle

Vielen dank 

Jonah
Antwortento top
#2
Hi Jonah,

so?

Arbeitsblatt mit dem Namen 'Tabelle3'
ABCDEFGH
1abcabc1abc2AntonghiCäsar
2defdef1def2Bertadef2Berta
3ghighi1ghi2Cäsar

ZelleFormel
H1=WENNFEHLER(SVERWEIS(G1;$A$1:$E$3;5;0);WENNFEHLER(SVERWEIS(G1;$B$1:$E$3;4;0);WENNFEHLER(SVERWEIS(G1;$C$1:$E$3;3;0);"")))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Hey, 

Ich glaube das passt nicht so ganz ... 

in deinem Beispiel wird G1 gesucht in A1 B1 und C1 ... 

Aber ich suche eine Lösung wie die werte aus A B und C in G gesucht werden also umgekehrt ... 

Weil die werte Aus E nicht A B und C zugeordnet sind sondern G ... 


Schwer zu erklären ... Ich suche eine Lösung als wäre in deinem Beispiel H bereits gegeben und E nicht .... anstatt dass wie in deinem Beispiel E gegeben ist und H nicht ... 

versteht man das ? :D 

Jonah
Antwortento top
#4
Hi,

wie wär's mit einer kleinen Beispieldatei mit händisch eingetragenen Wunschergebnissen? https://www.clever-excel-forum.de/thread-326.html
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#5
Hey, 

Ich lade immer Bilder hoch aber iwie sieht man die nicht oder ?! 

ich lade jetzt nochmal eine CSV hoch ! Hoffe das klappt


.csv   beispiel.CSV (Größe: 138 Bytes / Downloads: 6)

Jonah
Antwortento top
#6
Also ich suche eine Formel für Die Spalte E alles andere ist gegeben !
Antwortento top
#7
Hey, 

dein Ansatz hat mich glaube ich zur Lösung geführt 

=WENNFEHLER(SVERWEIS(C1,I:J,2,FALSCH),WENNFEHLER(SVERWEIS(B1,I:J,2,FALSCH),WENNFEHLER(SVERWEIS(A1,I:J,2,FALSCH),"")))


es klappt soweit ich das sehe ... Haut das so hin ?

Jonah
Antwortento top
#8
Hallo Jonah,


Zitat:es klappt soweit ich das sehe ... Haut das so hin ?

wenn es klappt, was ich nicht glaube, ist's ja gut und ob's "hinhaut", kannst nur du beurteilen.

Zitat:Ich lade immer Bilder hoch aber iwie sieht man die nicht oder ?!

Doch! Die Bildchen sieht man. Bilder machen sich in einer Galerie gut; zum Helfen bei XL-Problemen sind sie in der Regel nicht tauglich. Aber das steht alles in dem Beitrag, der hinter dem von mir geposteten Link steht. Dazu müsste man ihn (den Beitrag!) aber (aufmerksam) lesen.

Zitat:ich lade jetzt nochmal eine CSV hoch !

Warum eine CSV? Warum nicht eine .xlsx?

Und weil ich schon das Thema "aufmerksam lesen" angesprochen habe:


Zitat:wie wär's mit einer kleinen Beispieldatei mit händisch eingetragenen Wunschergebnissen?

Das interessiert dich anscheinend auch nur peripher. Ich bin dann mal weg.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#9
(18.11.2018, 23:32)Jonah schrieb: Ich lade immer Bilder hoch, aber irgendwie sieht man die nicht, oder ? 

Die Anzahl Deiner Beiträge in diesem Forum liegt bei 16. Du solltest kapiert haben, was man hoch lädt und was nicht. Das gilt für alle Foren!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste