Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Werte aus mehreren Zeilen kopieren wenn Bedingung erfüllt
#1
Hallo zusammen,

im Anhang findet ihr eine Excelliste mit der Beschreibung.
Kurz gesagt möchte ich folgendes:

In Zeile B2 ist ein Dropdownmenue, wenn hier Test ausgewählt wird möchte ich Daten aus einem anderen Blatt kopieren die dann wie folgt ausehen:

Kunde | Beschreibung | Fehler
Test       Test1              5

Hoffe es ist einigermassen Verständlich.

LG


Angehängte Dateien
.xlsx   Test_Daten.xlsx (Größe: 16,95 KB / Downloads: 3)
Antwortento top
#2
Hola,

Code:
=WENNFEHLER(INDEX(Daten!A$2:A$9;AGGREGAT(15;6;ZEILE($A$2:$A$9)-1/(Daten!$A$2:$A$9=$C$4);ZEILE(A1)));"")

nach rechts und nach unten ziehen.

Gruß,
steve1da
Antwortento top
#3
BINGO---Perfekt!

Vielen lieben Dank.

LG
Antwortento top
#4
Sorry hatte was vergessen ;)
Siehe Excel. Das Datum sollte bei der Auswahl berücksichtigt werden, nur bei der Auswahl nicht in der Ausgabe.


Angehängte Dateien
.xlsx   Test_Daten.xlsx (Größe: 18,36 KB / Downloads: 2)
Antwortento top
#5
Hola,

da du leider nicht geschrieben hast, wie das Datum berücksichtigt werden soll und leider auch keinerlei Datumswerte in der Tabelle hast, habe ich geraten:

Code:
=WENNFEHLER(INDEX(Daten!A$2:A$9;AGGREGAT(15;6;ZEILE($A$2:$A$9)-1/((Daten!$A$2:$A$9=$C$4)*(Daten!$E$2:$E$9=$B$5));ZEILE(A1)));"")

Gruß,
steve1da
Antwortento top
#6
Sorry, hatte ich vergessen. Ich teste und melde mich wieder-vorab schon mal 1000 dank.
Antwortento top
#7
Okay, ich bin zu dämlich.
Siehe Excel im Anhang.

LG


Angehängte Dateien
.xlsx   Test - Copy.xlsx (Größe: 141,87 KB / Downloads: 4)
Antwortento top
#8
Hola,

du suchst das "Datum" in B28 - schau mal genau wo es steht Wink

Gruß,
steve1da
Antwortento top
#9
Ich sag doch - bin zu doof. Danke funktioniert!
Eine Frage noch, wieso dauert es manchmal so lange bis mein Dropdownmenü Werte hat?
Mach ich da einen Fehler?

Eins, das ist das letzt habe ich auch wieder vergessen. Die Daten sollen nur angezeigt werden wenn zusätzlich in Spalte F "Ja" steht

Jetzt habe ich kein Kriterium vergessen
Antwortento top
#10
Hola,

hast du da ein 2. Dropdown in C28? Irgendwie bekomme ich das nicht weg.

Code:
=WENNFEHLER(INDEX(Daten!A$2:Daten!A$500;AGGREGAT(15;6;ZEILE($A$2:$A$500)-1/((Daten!$A$2:$A$500=$C$28)*(Daten!$G$2:$G$500=$B$29)*(Daten!$F$2:$F$500="ja"));ZEILE(A1)));"")


Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • thomson1308
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste