Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Arbeitsmappen abgleichen
#1
Hallo liebe Community,

ich muss zwei excel tabellen vergleichen, die in etwa so aussehen:

Tabelle 1:

Tabelle 2:

Dateien bitte im Forum hochladen: https://www.clever-excel-forum.de/thread-326.html


Ich möchte nun, dass mir angezeigt wird, wann es Unterschiede es gibt (Bsp. Alter "Jürgen" oder fehlende Angabe). Das ganze darf natürlich keine einfache Suche sein, denn wenn man in Tabelle 2 nach "Max M." sucht, wird man ja nicht fündig. Ich möchte eher, dass jede Zeile in Tabelle 2 darauf untersucht wird, ob Sie Teile von jeder Zeile aus Tabelle 1 enthält. Man könnte ja beispielsweise einen Filter einbauen, der der Suchfunktion aufträgt nur bis zu einem Leerzeichen zu suchen. Also statt nach "Max M." in Tabelle 2 zu suchen nur nach "Max". Hoffe ihr versteht, worauf ich hinauswill. Freue mich auf eure Ratschläge.
Gruß,
Antwortento top
#2
Der Nachname ist durchaus wichtig um ein Unikat zu Finden, wenn du 2x einen Max verwaltest, wird hier Excel nicht wissen welchen du eigentlich möchtest!

zumal es auch schon in deinen Bildern 2 verschiedene Jürgen scheint zu geben, weil hier die Werte nicht übereinstimmen..
Eine Menge reden, aber nichts sagen können viele...
[-] Folgende(r) 1 Benutzer sagt Danke an Frogger1986 für diesen Beitrag:
  • Wunsch
Antwortento top
#3
In der Praxis sind es die gleichen "Jürgen", nur dass die Werte in Tabelle 1 nicht mehr aktuell sind und in Tabelle 2 die Nachnamen vergessen wurden.

 Es geht mir nur darum das Alter aus Tabelle 2 in Tabelle 1 einzupflegen und Unterschiede angezeigt zu bekommen.
Antwortento top
#4
Wenn die Namen so wie auf den Bildern sind dann so 

Arbeitsblatt mit dem Namen 'Tabelle1'
IJK
1NameAlter 1Alter2
2Max M.1010

ZelleFormel
J2=SVERWEIS(I2;A:B;2;0)
K2=SVERWEIS(LINKS(I2;LÄNGE(I2)-3);E:F;2;0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Angehängte Dateien
.xlsx   Alter.xlsx (Größe: 14,63 KB / Downloads: 0)
Eine Menge reden, aber nichts sagen können viele...
[-] Folgende(r) 1 Benutzer sagt Danke an Frogger1986 für diesen Beitrag:
  • Wunsch
Antwortento top
#5
oder dann wenn die Nachnamen ausgeschrieben in unterschiedlicher Länge sind

Arbeitsblatt mit dem Namen 'Tabelle1'
IJK
1NameAlter1Alter2
2Max M.1010

ZelleFormel
J2=SVERWEIS(I2;$A:$B;2;0)
K2=SVERWEIS(LINKS(I2;FINDEN(" ";I2;1)-1);$E:$F;2;0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Angehängte Dateien
.xlsx   Alter.xlsx (Größe: 15,85 KB / Downloads: 0)
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#6
Danke für deine Antwort, aber ich wollte auf etwas anderes hinaus. Bin wohl nicht der beste im erklären...ich versuch es trotzdem noch einmal und dieses mal auf eine andere Art.

Tabelle 1:

   

Tabelle 2:

   


Das gewünschte Ergebnis wäre es, beide Tabellen zu durchsuchen und Treffer farbig hervorzuheben. Quasi so:

Ergebnis Tabelle 1:

   

Ergebnis Tabelle 2:

   

Danach wäre es natürlich noch schön, wenn alle unmarkierten Eintrage ausgeblendet werden. Also so:

Eingeklappt Tabelle 1:

   

Eingeklappt Tabelle 2:

   


Ich hoffe dieses mal ist es ein wenig klarer, was ich meine :D

Gruß,
Antwortento top
#7
für mich ist jetzt nichts klarer... 

nach welchen Kriterien soll denn jetzt gesucht werden?? Das Alter? Die Person? ….
und bitte keine Bilder mehr ich hab keine lust die Datei immer nachzubauen! Lade die Datei hoch keine Bilder davon!
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#8
Im zweiten Beispiel nur nach der Person. Das Alter soll erstmal vollkommen außen vorgelassen werden.
Antwortento top
#9
wo ist die Beispielmappe?
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#10
Here you go: 
.xlsx   Test.xlsx (Größe: 9,39 KB / Downloads: 7)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste