Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Ermitteln der größten Anzahl der wie viele Male
#1
Hallo alle zusammen, 

ich habe Zahlen und Kombination von einer Zahl und dem Buchstaben (X) in folgenden Zellen (A1, C1, E1, G1), ich möchte 2 Ausgabe haben:

Erste Ausgabe:
zähle wieviele 1, wieviele 2, wieviele X, wieviele 1X, wieviele X2 in  (A1, C1, E1, G1) ----> in diesem Beispiel (einmal2, zweimal1X, dreimalX)

und als Ausgabe soll die erst größte Anzahl stehen (X)

Zweite Ausgabe:
zähle wieviele 1, wieviele 2, wieviele X, wieviele 1X, wieviele X2 in  (A1, C1, E1, G1) ----> in diesem Beispiel  (einmal2, zweimal1X, dreimalX) 
und als Ausgabe soll die zwei größte Anzahl stehen (1X)

Danke für jede konstruktive Hilfe.


Angehängte Dateien
.xlsx   wie viel Mal.xlsx (Größe: 9,49 KB / Downloads: 6)
Antwortento top
#2
so...

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHIJ
1X1X
22A1XAA1XKIXG12

ZelleFormel
I2=ZÄHLENWENN($A2:$H2;I$1)
J2=ZÄHLENWENN($A2:$H2;J$1)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#3
Hallo Frogger, 

danke für die schnelle  Antwort.
Das Ergebnis ist fast wie mein Vorhaben Smile
Die erste Ausgabe in (I2) es müsste (X) stehen, weil X 3 mal (A2 bis H2) erscheint  und damit die erst häufig erscheinende Zahl/Buchstabe
Die zweite Ausgabe in (J2) es müsste (1) stehen, weil 1 die zweit größte erscheinende Zahl/Buchstabe, die erscheint (A2 bis H2)
Antwortento top
#4
Das geht doch in diese Richtung:

http://www.excelformeln.de/formeln.html?welcher=66
Antwortento top
#5
In meinem Fall trifft es nicht zu, dass es in der gleichen Zelle um Kombinationen von Zaheln und Buchstaben(X) geht.
Trotzdem danke für die Hilfe Smile
Antwortento top
#6
(14.11.2018, 18:34)dindu schrieb: Erste Ausgabe:
zähle wieviele 1, wieviele 2, wieviele X, wieviele 1X, wieviele X2 in  (A1, C1, E1, G1) ----> in diesem Beispiel (einmal2, zweimal1X, dreimalX)
Ich zerbreche an der Logik.
Du hast vier Einträge zählst aber sechs Treffer.
Einerseits zählst du die X alleine und noch mal in Kombination mit 1 (1X), andererseits zählst du die 1 nur als 1 und nicht in Kombination mit X (1X).
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#7
Es gibt keine Logik im Fussball Smile
X und 1X als Ausgangsergebnis ist sehr unterschiedlich, deshalb getrennt in X und 1X (die kleiner Stufe des X)
Antwortento top
#8
Und ich bin kein bißchen weiser geworden.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#9
also, wenn du vorher gesagt hättest, dass das für Fußball ist...  20  

naja nichts desto Trotz.. hier mein Versuch... schau mal ob dir das passt..

Vorsicht es sind con I bis N Hilfsspalten vorhanden!


Angehängte Dateien
.xlsx   wie viel Mal (5).xlsx (Größe: 18,68 KB / Downloads: 4)
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#10
Hier sind die 2 Ausgaben manuel berechnet


Angehängte Dateien Thumbnail(s)
   
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste