Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

ausgewählte Datensätze aus Tabelle 1 in Tabelle 3 übernehmen
#1
Hallo,

ich habe eine Tabelle 1 mit ca. 800 zeilen und 15 Spalten, Spalte B beinhaltet ein Installationsdatum, Spalte generiert aus Spalte B eine Kalenderwoche, die nachfolgenden Spalten beinhalten Kundennummern, Namen, PLZ, Ort usw. Ich möchte alle Zeilen, deren Installationsdatum in der Zukunft liegt in eine neue Tabelle 3 übernehmen. Leere Zellen sollen ignoriert werden und es können Daten doppelt vorkommen (also 2 Installationen an einem Tag).
Das ganze sollte doch mit INDEX oder so funktionieren? kann mir da jemand weiterhelfen?

danke
Antwortento top
#2
Hi,

so?


Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEF
1DatumKWText1
215.05.201820bla15.11.201846ble
315.11.201846ble15.12.201850blo
415.03.201811bli15.11.201846blu
515.12.201850blo
615.11.201846blu

ZelleFormel
B2=ISOKALENDERWOCHE(A2)
D2=WENNFEHLER(INDEX(A$1:A$6;AGGREGAT(15;6;ZEILE($A$2:$A$6)/($A$2:$A$6>HEUTE());ZEILE(A1)));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

INDEX-Formel in D2 und nach rechts und nach unten ziehen; Spalte E auf Standard formatieren.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Ja, fast.
Spalten A und B sind vertauscht, Spalte C ist mehrfach vorhanden.
Deswegen sollen die neuen Datensätze in Tabelle 3 aufgelistet werden.
Trotzdem erstmal Danke für die schnelle Reaktion.
Antwortento top
#4
Tja, dann wirst du die Formel anpassen oder eine (abgespeckte!!) Beispieldatei hochladen müssen .
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#5
so sieht die Tabelle aus.
es sollen alle Zeilen die in Spalte B ein Datum größer als heute enthalten in das dritte Arbeitsblatt übernommen werden, alle leeren Zellen in Spalte B sollen ignoriert werden.


Angehängte Dateien
.xlsm   Beispiel.xlsm (Größe: 38,19 KB / Downloads: 11)
Antwortento top
#6
Hi,

dann so:

Arbeitsblatt mit dem Namen 'Tabelle3'
ABCDEFGHIJKLMN
1KWInstallDat.ZeitBestelldat.Servicenr.Kundennr.Tel.Nr.KundePLZOrtAngabenLieferstatusSMB-CBemerkung
24430.10.201812:00:00000001796PirnaA Egeliefertgeliefert0
34215.10.201811:30:00000001640Coswig b DresdenA Egeliefertgeliefert0
44218.10.201811:00:00000001796PirnaA Egeliefertgeliefert0
54216.10.201812:00:00000009122ChemnitzA Egeliefertgeliefert0
64324.10.201810:00:00000001773AltenbergA Egeliefertgeliefert0
74217.10.201811:30:00000008340SchwarzenbergA Egeliefertgeliefert0
8
9

ZelleFormel
A2=WENNFEHLER(INDEX(Tabelle1!A:A;AGGREGAT(15;6;ZEILE(Tabelle1!$A$2:$A$800)/(Tabelle1!$B$2:$B$800>HEUTE());ZEILE(Tabelle1!A1)));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Formel in A2 und wieder nach rechts und nach unten ziehen.

Nachtrag:

1. Excel ist eine Tabellenkalkulation und kein Malkasten. ;-)
2. Deine Kalenderwochenformel solltest du auf ISOKALENDERWOCHE() umstellen; so, wie du sie benutzt, kann es passieren, dass nicht alle KW korrekt berechnet werden. Frag auch mal Tante Gugl; die wird's dir sicherlich bestätigen.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#7
klappt soweit, vielen dank.
automatisch sortieren wäre wohl etwas übertrieben ? ;) na das ist auch so schnell gemacht.
mir wären weniger farben auch lieber, aber leider muss das so.
Antwortento top
#8
Hi,

sortieren sind maximal 3 Mausklicks:

1. gehe in irgendeine Zelle in Spalte B
2. Klick in der Menüleiste auf "Daten"
3. Klick das Icon A-Z an
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#9
@ Daniel, so könnte das Ergebnis aussehen, wenn man das mit Power Query aufbereitet... (eine automatische Sortierung ist auch mit drin - und kann nach Belieben angepasst werden)

Arbeitsblatt mit dem Namen 'Tabelle5'
ABCDEFGHIJKLMN
1KWInstallDat.ZeitBestelldat.Servicenr.Kundennr.Tel.Nr.KundePLZOrtAngabenLieferstatusSMB-CBemerkung
24430.10.201812:0001796PirnaA Egeliefertgeliefert
34324.10.201810:0001773AltenbergA Egeliefertgeliefert
44218.10.201811:0001796PirnaA Egeliefertgeliefert
54217.10.201811:3008340SchwarzenbergA Egeliefertgeliefert
64216.10.201812:0009122ChemnitzA Egeliefertgeliefert
74215.10.201811:3001640Coswig b DresdenA Egeliefertgeliefert
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#10
Du kannst die Tabelle auch per Power Query mit ein paar Klicks erstellen und gleich sortieren.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste