Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Werte einer Spalte zählen bei einem bestimmten Text in einer anderen
#1
Hallo,

bin neu hier im Forum und grübel schon seit einiger Zeit über folgendes Problem:

 Spalte A -- Spalte B -- Spalte C -- Spalte D
1 AB                                                    238
2 CD                                                    120
3 EF                                                     155
4 AB                                                       0
5 AB                                                     148

Ich möchte nun die Anzahl der Werte (Spalte D), ohne 0 oder ohne Inhalt mitgezählt, von AB (Spalte A) in einer anderen Zelle ausgeben.
Hier wären es z.B. für AB -> 2. gezählt

Kann mir hier jemand weiterhelfen?

Vilen Dank dafür!

Gruß
Antwortento top
#2
Hallo,

=ZÄHLENWENNS(A1:A6;"AB";D1:D6;"<>";D1:D6;">"&0)
VG Sabina

bei mir läuft Win 7 32-Bit - Office 2010 Pro Plus 32-Bit und Office 2016 Pro Plus 32-Bit
Wer auch weiter Hilfe erwartet, sollte sich nicht zu schade sein, ein kurzes Feedback zu geben.
Antwortento top
#3
Hi, so z.B.:

PHP-Code:
=ZÄHLENWENNS(D1:D5;">0";A1:A5;"AB"
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#4
Hi!

Vielen, vielen Dank! Habe beide Möglichkeiten ausprobiert -> beide funktionieren!!!
Da wäre ich nie drauf gekommen! Danke!

Grüße
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste