Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Bestellmenge berechnen
#1
Hallo zusammen,
habe wieder mal eine knifflige Frage:
Habe ihm Netz eine Formel gefunden (Zelle H11), die bei geraden Zahlen gut funktioniert, bei Kommazahlen in den Zellen B6 und D6 jedoch die Zahlen nicht aufrundet. Somit bekomme Ich immer zuwenig Platten heraus.
Kann sich jemand mal die Formel ansehen und vielleicht ergänzen, wäre Super. 19 
Der absolute Kick wäre wenn man auch noch die Abfrage mit einbauen könnte wie in Zelle H 12.

Vielen Dank im voraus.


Angehängte Dateien
.xlsx   Test11.xlsx (Größe: 14,36 KB / Downloads: 12)
Antwortento top
#2
Hallo,

du musst doch im Prinzip immer nur das Wort "Ganzzahl" aus der Formel rauslöschen, dann rechnet Excel exakt. Das Ganze noch mit AUFRUNDEN() verfeinert liefert dir die benötigte Plattenanzahl.

Code:
=AUFRUNDEN(MAX(((B6/P5)*(D6/Q5));((D6/P5)*(B6/Q5)));0)


Für deinen persönlichen Kick:

Code:
=WENN(E9="nein";AUFRUNDEN(MAX(((B6/P5)*(D6/Q5));((D6/P5)*(B6/Q5)));0);"")
Dazu sei aber gesagt, dass dein "nein" in Zelle N12 hinten ein Leerzeichen enthält. Dieses musst du entfernen, sonst klappt die Formel nicht.


Falls die Texte in A11 und A12 abhängig von den Eingaben in P5 und Q5 sein sollen:

Zitat:="Holztafel "&P5&"*"&Q5
Schöne Grüße
Berni
[-] Folgende(r) 1 Benutzer sagt Danke an MisterBurns für diesen Beitrag:
  • wavemaster
Antwortento top
#3
Hallo,

die Datenstruktur könnte man optimaler gestalten. Ich bin jetzt von Deiner ausgegangen.

In Deinem Beispiel  ist E9=18,86 m², demzufolge muss H11 oder H12 größer sein als 18,86 m²

Somit in in H11:
Code:
=MAX(AUFRUNDEN(B6/P5;0)*AUFRUNDEN(D6/Q5;0);AUFRUNDEN(D6/P5;0)*AUFRUNDEN(B6/Q5;0))*(E9="nein ")

und in H12:

Code:
=MAX(AUFRUNDEN(B6/P5;0)*AUFRUNDEN(D6/Q5;0);AUFRUNDEN(D6/P5;0)*AUFRUNDEN(B6/Q5;0))*(E9="ja ")*1,01

In E6 braucht es übrigens kein SUMME(), ausreichend ist hier: =B6*D6
Gruß Werner
.. , - ...
[-] Folgende(r) 1 Benutzer sagt Danke an neopa für diesen Beitrag:
  • wavemaster
Antwortento top
#4
Hallo neopa,
bei der deiner Formel kommt in H11 keine Summe.
und in H12 eine zu hohe summe heraus.

Huh
Antwortento top
#5
A1:B1: Fläche
C1:D1: Einzelplatte

=MIN(AUFRUNDEN(A1/C1;)*AUFRUNDEN(B1/D1;);AUFRUNDEN(B1/C1;)*AUFRUNDEN(A1/D1;))

Berni und neopa haben aus Versehen MAX statt MIN verwendet. Das Ergebnis ist 15, nicht 16 Platten. Einschränkung: Eine gewünschte Ausrichtung des Plattenmusters ist nicht möglich.

("Verschwendungs")-Fiktion ist hier übrigens, dass eine einzelne Platte nur unverwertbare Reste erzeugen kann, statt in ihren Einzelteilen mehrfach eingesetzt zu werden. Ist letzteres - beliebig! - der Fall, dann

=AUFRUNDEN(A18*B18/C18/D18;)

("Sparsamkeitsfiktion" = 13 Platten).

In der Realität gibt es Grenzen einer beliebig kleinen "Anstückelung". Diese lassen sich nicht so ohne weiteres berücksichtigen. Vermutlich würde ich als Bauherr dann einfach 13 oder 14 Platten kaufen. Die restliche 13. Platte hat noch 73,3% Fläche. Das ergibt aufs Ganze immerhin 5,6% Ausschuss (13-Ergebnis)/13. Bei 14 Platten: 12,4%.

Handelt es sich um Deckenplatten, würde ich nicht so weit stückeln (und folglich nicht so sehr sparen), wie etwa bei Dämmwolleplatten dahinter.

@neopa:
"Optimal" (optimus) heißt "bestens" (=Superlativ). "Optimaler" (die Form gibt es nicht, außer im Genus, da es sonst einen Komparativ des Superlativs gäbe) hieße dann ja "besser-stens" oder "bestens-er". Richtig wäre "melior" (lat. "besser").
[-] Folgende(r) 1 Benutzer sagt Danke an LCohen für diesen Beitrag:
  • wavemaster
Antwortento top
#6
Guten Morgen LCohen,
die Formel past jetzt soweit,
wie kann Ich jetzt noch die Ja nein Abfrage einbinden.

Bei mir kommt immer ein Fehler wenn Ich folgendes vor die Formel setze

=WENN(E22="nein"
;MIN(AUFRUNDEN(B19/P18;)*AUFRUNDEN(D19/D1q18;);AUFRUNDEN(B19/P18;)*AUFRUNDEN(B19/Q18;));0)

was mache ich falsch... Huh


Angehängte Dateien
.xlsx   Test11.xlsx (Größe: 14,43 KB / Downloads: 2)
Antwortento top
#7
Zitat:Bei mir kommt immer ein Fehler...
...was mache ich falsch?
Wenn du meinen Beitrag aufmerksam gelesen und nicht einfach ignoriert hättest, wüsstest du das... Also schau nochmal genau, was ich unterhalb der =WENN(... Formel geschrieben habe.
Abgesehen davon bringt die Formel keinen Fehler, sondern das korrekte Ergebnis 0 (zumindest bei mir in deiner letzten Testdatei).

Weiters: In der Formel sind mehrere Syntaxfehler. Die Semikola am Ende jeder Aufrunden-Klammer sind falsch, ebenso der Ausdruck "D19/D1q18"
=WENN(E22="nein";MIN(AUFRUNDEN(B19/P18;)*AUFRUNDEN(D19/D1q18;);AUFRUNDEN(B19/P18;)*AUFRUNDEN(B19/Q18;));0)
Schöne Grüße
Berni
[-] Folgende(r) 1 Benutzer sagt Danke an MisterBurns für diesen Beitrag:
  • wavemaster
Antwortento top
#8
Hi,

was will denn der Teil:
=WENN(E22="nein";MIN(AUFRUNDEN(B19/P18;)*AUFRUNDEN(D19/D1q18;);AUFRUNDEN(B19/P18;)*AUFRUNDEN(B19/Q18;));0)

Ich würde es ja so machen, angepasst auf Deine letzte Datei und entfernen der Leerzeichen bei ja und nein:
=WENN(E9="nein";MIN(AUFRUNDEN(B6/P5;)*AUFRUNDEN(D6/Q5;);AUFRUNDEN(D6/P5;)*AUFRUNDEN(B6/Q5;));0)
[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
  • wavemaster
Antwortento top
#9
Hi Berni,

(09.10.2018, 06:22)MisterBurns schrieb: Weiters: In der Formel sind mehrere Syntaxfehler. Die Semikola am Ende jeder Aufrunden-Klammer sind falsch

das sehe ich anders, die Semikola sind nötig, er könnte evtl. noch jeweils eine 0 dahintersetzen.
[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
  • wavemaster
Antwortento top
#10
Hi Rabe,

stimmt natürlich, falsch ist es nicht. Aber ohne nachfolgende Stellenangabe auf jeden Fall unnötig.
Schöne Grüße
Berni
[-] Folgende(r) 1 Benutzer sagt Danke an MisterBurns für diesen Beitrag:
  • wavemaster
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste