Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Index, KKLeinste & WENN
#1
Hallo zusammen,

ich habe folgende Tabelle und versuche mit meiner Formel mir die Personen ausgeben zu lassen, die ÜBER 70€ und UNTER 70% Auslastung haben. (siehe Spalte G)

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGH
1NameWert1Wert2PreisAuslastungAuswertung:Formel:
2Person 1783Test66,571,95%Person 2Person 1
3Person 28942Test179,5559,71%Person 3Person 3
4Person 324Test283,426,17%Person 4
5Person 42489Test470,8883%

ZelleFormel
H2{=WENNFEHLER(INDEX($A$2:$A$5;KKLEINSTE(WENN(($D2>70)*($E2<70%);ZEILE($2:$5));ZEILE($A1)));"")}
H3{=WENNFEHLER(INDEX($A$2:$A$5;KKLEINSTE(WENN(($D3>70)*($E3<70%);ZEILE($2:$5));ZEILE($A2)));"")}
H4{=WENNFEHLER(INDEX($A$2:$A$5;KKLEINSTE(WENN(($D4>70)*($E4<70%);ZEILE($2:$5));ZEILE($A3)));"")}
H5{=WENNFEHLER(INDEX($A$2:$A$5;KKLEINSTE(WENN(($D5>70)*($E5<70%);ZEILE($2:$5));ZEILE($A4)));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Verwendete Systemkomponenten: [Windows (32-bit) NT :.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg



Leider möchte meine Formel nicht so, wie ich will. Wie ihr in der letzten Spalte seht, bekomme ich andere Personen ausgegeben.

Kann jemand bitte helfen?

Gruss
Antwortento top
#2
Hallo

Du hast nur jeweils eine Zelle aus den Spalten D und E verwendet.


Code:
=INDEX(A:A;AGGREGAT(15;6;ZEILE($A$2:$A$5)/($D$2:$D$5>70)/($E$2:$E$5<70%);ZEILEN(H$2:H2)))
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
F2: =VERGLEICH(1;INDEX((D$99:INDEX(D:D;F1+1)>70)*(E$99:INDEX(E:E;F1+1)<0,7););)+F1 mit Format ;;
G2: =INDEX(A:A;$F2) - lässt sich für Wiedergabe aller Spalten A:E einfach nach rechts kopieren
Antwortento top
#4
Knaller Wink

Danke Dir!
Antwortento top
#5
Kann man auch irgendwie einen Filter berücksichtigen? Ähnlich wie "Teilergebnis" ?
Antwortento top
#6
Dafür autofiltere Deine Ausgangsdaten einfach. Dann greift TEILERGEBNIS.

Verwende SUMMENPRODUKT oder SUMMEWENNS/ZÄHLENWENNS statt TEILERGEBNIS ohne Filter.

=ZÄHLENWENNS(D:D;">70";E:E;"<0,7")
Antwortento top
#7
mit Teilergebnis klar, aber wie anzuwenden in der Formel

Code:
=INDEX(A:A;AGGREGAT(15;6;ZEILE($A$2:$A$5)/($D$2:$D$5>70)/($E$2:$E$5<70%);ZEILEN(H$2:H2)))
Antwortento top
#8
Drücke Dich mal ordentlich aus, bitte. Niemand ahnt, was Du jetzt willst. Am besten anhand Deines Beispiels das Wunschergebnis.
Antwortento top
#9
Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFG
1NameWert1Wert2PreisAuslastungAuswertung:
2Person 1783Nord66,571,95%Person 2
3Person 28942Süd79,5559,71%Person 3
4Person 324Nord83,426,17%Person 5
5Person 42489West70,8883%Person 8
6Person 5738Süd76,8755,63%
7Person 62942Nord55,9789,51%
8Person 753Ost73,8896,20%
9Person 89023Ost87,5119,10%
10Person 99442West56,4828,71%

ZelleFormel
G2=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($A$2:$A$10)/($D$2:$D$10>70)/($E$2:$E$10<70%);ZEILEN(G$2:G2)));"")
G3=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($A$2:$A$10)/($D$2:$D$10>70)/($E$2:$E$10<70%);ZEILEN(G$2:G3)));"")
G4=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($A$2:$A$10)/($D$2:$D$10>70)/($E$2:$E$10<70%);ZEILEN(G$2:G4)));"")
G5=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($A$2:$A$10)/($D$2:$D$10>70)/($E$2:$E$10<70%);ZEILEN(G$2:G5)));"")
G6=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($A$2:$A$10)/($D$2:$D$10>70)/($E$2:$E$10<70%);ZEILEN(G$2:G6)));"")
G7=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($A$2:$A$10)/($D$2:$D$10>70)/($E$2:$E$10<70%);ZEILEN(G$2:G7)));"")
G8=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($A$2:$A$10)/($D$2:$D$10>70)/($E$2:$E$10<70%);ZEILEN(G$2:G8)));"")
G9=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($A$2:$A$10)/($D$2:$D$10>70)/($E$2:$E$10<70%);ZEILEN(G$2:G9)));"")
G10=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($A$2:$A$10)/($D$2:$D$10>70)/($E$2:$E$10<70%);ZEILEN(G$2:G10)));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT :.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Ich möchte jetzt beispielsweise nach "SÜD" filtern und dann als Ergebnis nur Person 2 und Person 5 angezeigt bekommen.
Filter ich jetzt aber nach Süd, zeigt er mir trotzdem das selbe Ergebnis an. (In dem Beispiel nur Person 3, weil die anderen Zeilen durch den Filter gerade nicht sichbar sind. Getestet auf einem anderen Blatt. Und nach wie vor Person 2,3,5,8)

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFG
1NameWert1Wert2PreisAuslastungAuswertung:
3Person 28942Süd79,5559,71%Person 3
6Person 5738Süd76,8755,63%
7Person 62942Süd55,9789,51%

ZelleFormel
G3=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($A$2:$A$10)/($D$2:$D$10>70)/($E$2:$E$10<70%);ZEILEN(G$2:G3)));"")
G6=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($A$2:$A$10)/($D$2:$D$10>70)/($E$2:$E$10<70%);ZEILEN(G$2:G6)));"")
G7=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($A$2:$A$10)/($D$2:$D$10>70)/($E$2:$E$10<70%);ZEILEN(G$2:G7)));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT :.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Antwortento top
#10
(05.10.2018, 16:36)LCohen schrieb: Drücke Dich mal ordentlich aus, bitte. Niemand ahnt, was Du jetzt willst. Am besten anhand Deines Beispiels das Wunschergebnis.

Hallo, doch. Aus dem letzten thread. Der TE scheint sehr ungeduldig zu sein. Neuer thread genauso angefangen, wie der letzte und auch hier dann der ominöse  (optionale) Autofilter...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste