Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SVERWEIS hilft hier nicht weiter
#1
Hallo zusammen,

folgendes Szenario:

Code:
Name                   01.10.2018    02.10.2018    03.10.2018    04.10.2018

Person 1                    5            3            4              5
Person 2                    1            0            0              0
Person 3                    0            3            4              5
Person 4                    4            4            3              2

Nun möchte ich gerne eine Übersicht immer für den aktuellen Tag erstellen [=heute()], in der mir alle Namen aufgelistet werden die Heute 5 oder mehr haben:

Übersicht:
04.10.2018            Person 1
                            Person 3



Ich hoffe es ist verständlich. Freue mich auf Ideen.

VG
Jules
Antwortento top
#2
Hallo, so z. B. per Formel(n)..:

Arbeitsblatt mit dem Namen 'Tabelle2'
ABCDEFGHI
1Name                  01.10.201802.10.201803.10.201804.10.2018Übersicht
2Person 1534504.10.2018Person 1
3Person 21000Person 3
4Person 30345
5Person 44432

ZelleFormel
H2=HEUTE()
I2=WENNFEHLER(INDEX(A$2:A$5;AGGREGAT(15;6;ZEILE($A$2:$A$5)-1/(INDEX(B$2:E$5;;VERGLEICH(HEUTE();$B$1:$E$1;0))>4);ZEILE(A1)));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#3
Spalten (hier B:D) ausblenden und E:E >4 autofiltern
Antwortento top
#4
Hallo, das geht auch mit ohne Formeln (alternativ zum AutoFilter) mit Power Query (das könnte so aussehen) ..:

Arbeitsblatt mit dem Namen 'Tabelle2 (2)'
ABCDEFGHIJ
1Name01.10.201802.10.201803.10.201804.10.2018ÜbersichtNamen
2Person 1534503.10.2018Person 2
3Person 21050Person 3
4Person 30355
5Person 44432
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#5
Hi Jörg,

wie hast du letzteres gelöst?

Kannst du mir in der Formel noch sagen wozu ZEILE(A1) dient?
Ich schaffe es leider noch nicht die Formel in meiner Tabelle anzuwenden

Code:
=WENNFEHLER(INDEX(B$5:B$113;AGGREGAT(15;6;ZEILE($B$5:$B$113)-1/(INDEX(D$5:BM$113;;VERGLEICH(HEUTE();$D$2:$BM$2;0))>4);ZEILE(A1)));"")

Gruss
Antwortento top
#6
(04.10.2018, 13:27)jules schrieb: Hi Jörg,

wie hast du letzteres gelöst?

Gruss

Moin, mit Power Query...

Da deine Datei nicht vorliegt, habe ich eine g'zamm gebaut...
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#7
I see Wink

Danke schön!!
Antwortento top
#8
Hi Jörg,

doch noch mal eine Frage.
Habe nun deine Formel verwendet. Funktioniert prima.

Wenn ich jetzt hinter "Person1" (usw.) in einer weiteren Spalte gerne die Zahl angeben möchte, weiterhin nur bei denen über 5, zugehörig zur Person.
Kann man deine Formel dafür umfunktionieren / erweitern?

Grüße
Antwortento top
#9
Hallo, da deine Datei immer noch nicht da ist und deine Beschreibung für mich recht dürftig ist, sach ich einfach mal: Ja.

Hier mal zwei Möglichkeiten..:

oder..:
PHP-Code:
=SUMME(INDEX($B$2:$E$5*($A$2:$A$5=$I2)*(B$1:E$1=H$2);)) 


Arbeitsblatt mit dem Namen 'Tabelle2'
ABCDEFGHIJK
1Name                  01.10.201802.10.201803.10.201804.10.2018Übersicht
2Person 1534504.10.2018Person 155
3Person 21000Person 355
4Person 30345
5Person 44432

ZelleFormel
J2=WENNFEHLER(SVERWEIS(I2;$A$2:$E$5;VERGLEICH($H$2;$A$1:$E$1;0));"")
K2=WENNFEHLER(INDEX($B$2:$E$5;VERGLEICH(I2;$A$2:$A$5;0);VERGLEICH($H$2;$B$1:$E$1;0));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#10
Hi,

anbei ein Auszug der Datei.
Wie ich leider festgestellt habe, funktioniert es noch nicht  Undecided

Kannst du helfen?


Angehängte Dateien
.xlsx   TestDatei.xlsx (Größe: 27,85 KB / Downloads: 7)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste