Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Daten vergleichen und passend zuordnen
#1
Hi Zusammen,

ich habe folgendes Problem und hoffe ihr könnt mir helfen:
ich möchte eine Monats-Arbeitszeittabelle/Übersicht erstellen, die sich automatisch dem Schichtwechsel anpasst.
Sprich: Auf dem Hauptblatt möchte ich nur mein "Kommen" und "Gehen" eintragen. Auf dieser Hauptübersicht soll dann unter "SOLL" für den entsprechenden Tag der Sollwert aus einer anderen Tabelle für den Tag abgeglichen und eingetragen werden. Die Tabelle muss allerdings auch anhand des Datums erkennen, ob es sich um einen Tag der geraden oder ungeraden KW handelt, da sich die Werte der Geraden und ungeraden KW unterscheiden können.
Hoffe das ist nicht zu kompliziert ausgedrückt.

Ich versuche es anhand der Grafiken im Anhang etwas zu veranschaulichen.

Vielen Dank schon einmal für mögliche Hilfen.
(Ich habe natürlich bereits im Forum nach Lösungsansätzen gesucht, jedoch nichts für mich brauchbares gefunden)


Angehängte Dateien Thumbnail(s)
       
Antwortento top
#2
Hallo,

Zitat:(Ich habe natürlich bereits im Forum nach Lösungsansätzen gesucht, jedoch nichts für mich brauchbares gefunden)

wenn du gesucht hast, dann ist dir bestimmt das eine oder andere mal dieser (oder ein ähnlicher) Satz aufgefallen: Bilder helfen nix!!-Bitte Beispieldatei.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Hallöchen,

wie wär's mit einem SVERWEIS?

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
1Früh-Gerade40Früh-Gerade40
2Spät-Gerade40

ZelleFormel
E1=SVERWEIS($D$1;$A$1:$B$2;2;FALSCH)

ZelleGültigkeitstypOperatorWert1Wert2
D1Liste=$A$1:$A$2
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#4
Entschuldigung. Natürlich ist mir der Satz öfters untergekommen. Jedoch wollte ich erst einmal verdeutlichen worauf ich hinaus wollte.
Antwortento top
#5
(01.10.2018, 18:09)schaua schrieb: wie wär's mit einem SVERWEIS?
Danke schonmal für die schnelle Antwort.
Ich verstehe nur nicht ganz wie ich den SVERWEIS so baue/einsetze, das die Tabelle automatisch alles in die entsprechende Datumszeile schreibt.
Antwortento top
#6
Hi,

dann lad halt deine Beispieltabelle hoch. In Bildern können keine Formeln eingetragen und ausprobiert werden.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#7
(01.10.2018, 19:39)WillWissen schrieb: Hi,

dann lad halt deine Beispieltabelle hoch. In Bildern können keine Formeln eingetragen und ausprobiert werden.

Sorry für die späte Antwort.

Anbei meine Tabelle.

Ich möchte das Excel automatisch im Bereich "SOLL" für den jeweiligen Tag die Sollzeit aus dem Arbeitsblatt "Unterdaten" einfügt.
Dabei soll berücksichtigt werden ob es sich bei dem Tag um eine gerade oder ungerade Woche handelt und dementsprechend die Daten sucht und einfügt. Weiterhin soll die Mappe berücksichtigen welchen Schichtzyklus man unter C2 ausgewählt hat.
Bin mir nicht sicher ob das mit sovielen Bedinungen überhaupt realisierbar ist.

Danke für Eure Hilfe!!!


Angehängte Dateien
.xlsx   Kalender.xlsx (Größe: 17,48 KB / Downloads: 4)
Antwortento top
#8
Hallo, was soll denn bei ungeraden Wochen dorthin..? Deine KALENDERWOCHE() rechnet für Deutschland nur zufällig richtig...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#9
Hi,

ist es das, was du willst?

Arbeitsblatt mit dem Namen 'Oktober'
ABCDEF
4TagDatumKommenGehenPauseSOLL
5Mo01.10.20187:45
6Di02.10.20187:45
7Mi03.10.20187:45
8Do04.10.20187:45
9Fr05.10.20187:45
10Sa06.10.2018
11So07.10.2018
12Mo08.10.20187:45
13Di09.10.20187:45
14Mi10.10.20187:45
15Do11.10.20187:45
16Fr12.10.20186:15
17Sa13.10.2018
18So14.10.2018

ZelleFormel
A5=TEXT(B5;"TTT")
F5=WENNFEHLER(WENN(ISTGERADE(ISOKALENDERWOCHE(B5));SVERWEIS(A5;Arbeitszeiten;4;0);SVERWEIS(A5;Arbeitszeiten;7;0));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Damit der SVERWEIS() bzgl. des Wochentags greifen kann, musst du in Spalte A die Formel ändern - siehe Tabellenausschnitt.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#10
(08.10.2018, 16:40)Jockel schrieb: Hallo, was soll denn bei ungeraden Wochen dorthin..? Deine KALENDERWOCHE() rechnet für Deutschland nur zufällig richtig...

Wenn ich unter C2 den Schichtzyklus "Früh-gerade KW" auswähle, soll in alle geraden KW Tage die Soll Früh Zeit aus dem Arbeitsblatt Unterdaten F2-F6. In alle ungeraden KW Tage die Zeit aus Soll Spät I2-I6.
Wenn ich unter C2 Schichtzyklus "Spät-gerade KW" auswähle halt genau den entgegen gesetzten Fall.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste