Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Syntax für Zugriff auf eine andere Tabelle
#1
Hallo,

ich möchte innerhalb eines Excel-Dokument von dem ersten Blatt, abhängig vom Wochentag, auf andere Blätter (Montag bis Freitag) zugreifen.

Beispiel: feste Formel für Dienstag

=WENN($B$4="x";Dienstag!C2;"-")

Ich scheitere an der Wochentag-abhängigen Syntax.
Der Wochentag steht in einer Zelle, wenn ich diese in der vorstehenden Formel einsetze, erhalte ich Fehlermeldungen.

Hoffe es verständlich erklärt zu haben und Hilfe.

mfg
Antwortento top
#2
Hallo,

Zitat:Ich scheitere an der Wochentag-abhängigen Syntax.


meiner Ansicht nach scheiterst du eher am sinnvollen Aufbau einer Exceldatei. Gleichartige Daten gehören auf ein Tabellenblatt.
Viele Grüße
Klaus-Dieter
Antwortento top
#3
Hallo,

den Zellinhalt musst Du mit INDIREKT holen und dann die Verknüpfung zusammenbauen, z.B.

...INDIREKT(A1 & "!C2")...
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
  • winkidinki
Antwortento top
#4
Danke..genau das wars. 17 

Hilfreich im Gegensatz zu anderen Antworten.
Antwortento top
#5
Moin!
Naja, hilfreich war Klaus-Dieters Antwort durchaus.
Schließlich kann man in einer sehr großen Tabelle nach Wochentag filtern.
Für Dich wäre eher EIN Formular-Blatt sinnvoll, in dem Du mittels Zellendropdown den Wochentag einstellst und sich das Formular die entsprechenden Werte per SVERWEIS() oder INDEX() "holt".
INDIREKT() sollte man ohne Not nicht unbedingt einsetzen, da es sich um eine volatile Funktion handelt.
https://www.online-excel.de/excel//singsel.php?f=171

Vielleicht zeigst Du mal Deine Datei.
Dann gibt es neben hilfreichen sogar konkrete Tipps.  21

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste