Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Vergleich / Suchen mit mehrerer Ergebnissen
#1
Hallo zusammen,

ich habe in den Spalten E2 bis E316 Namenskürzel stehen.

In E319 habe ich z.B. ein bestimmtes Kürzel stehen, dieses soll nun in E2-E316 gesucht werden. Als Ergebnis soll in I316 die Zeile angegeben werden wo das Kürzel gefunden wurde.
Mit =VERGLEICH(E319;E1:E316;0) in I316 funktioniert das auch, aber leider nur für das erste Ergebnis welches gefunden wird.

Was kann ich tun damit in E319 alle gefundenen Zeilen, z.B. getrennt durch ein Komma angezeigt werden?

Vielen Dank!
Antwortento top
#2
Hallo,

zeig mal bitte eine Beispieltabelle. http://www.clever-excel-forum.de/Thread-...ng-stellen
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Hallöchen,

hier mal in mehreren Zellen, frei nach der Autofilter-Lösung von excelformeln.de. Die Formel in D1 eingeben und runter ziehen ...

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
11gesucht:54
226
33
45
56
65
77

ZelleFormel
D1{=WENNFEHLER(KKLEINSTE(WENN((A$1:A$99=$C$1);ZEILE($1:$99));ZEILE(A1));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#4
Hi,

aus dem Stegreif:


Code:
=wennfehler(Index(E:E;aggregat(15;6;Zeile(E$1:E$316)/(E$1:E$316=$E$319);Zeile(a1)));"")
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#5

.xlsx   Test.xlsx (Größe: 11,02 KB / Downloads: 5)
Guten Morgen und vielen Dank,

ich bin nicht so der Excelgott, könntet ihr bitte meine Beispieltabell an passen?

VG
Antwortento top
#6
Hi,


Zitat:ich bin nicht so der Excelgott


Muß man auch nicht sein, aber man sollte zumindest die Formelsyntax kennen und die Formeln auch auf die tatsächlichen Gegebenheiten anpassen:

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
23AB#NV

ZelleFormel
B23=VERGLEICH(E23;$C$1:$C$20;0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Was soll der Bezug auf E23, wenn da nichts steht?

Wo ist eine der vorgestellten Formeln?????
Dass VERGLEICH nur den ersten Eintrag findet, das hatten wir doch schon.



Code:
{=WENNFEHLER(KKLEINSTE(WENN((A$1:A$99=$C$1);ZEILE(1:99);Spalte(A1);"")}
=wennfehler(Index(E:E;aggregat(15;6;Zeile(E$1:E$316)/(E$1:E$316=$E$319);Spalte(a1)));"")


Meist hilft die Formelauswertung weiter!
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#7
Hallo,

hier mal mit meinem Vorschlag. Die Formel in B23 eingeben und nach rechts und nach unten ziehen.

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEF
22Vergleichen mit
23AB
24AC
25MM141819
26MT8910
27MH4
28DD
29XX
30FR
31MB

ZelleFormel
B23{=WENNFEHLER(KKLEINSTE(WENN(($C$1:$C$20=$A23);ZEILE($1:$20));SPALTE(A1));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#8
Hallo, und hier ohne AGGREGAT() und ohne CSE-Formel... ... irgendwo so ähnlich bei lupo1 aufgeschnappt..:

Arbeitsblatt mit dem Namen 'Tabelle1 (2)'
ABCD
22Vergleichen mit
23AB#NV#NV#NV
24AC#NV#NV#NV
25MM141819
26MT8910
27MH4#NV#NV
28DD#NV#NV#NV
29XX#NV#NV#NV
30FR#NV#NV#NV
31MB#NV#NV#NV

ZelleFormel
B23=VERGLEICH(1;INDEX(--($C$20:INDEX($C$1:$C$20;N(A23)+1)=$A23););)+N(A23)

Zellebedingte Formatierung...Format
B231: ISTNV(B23)abc
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • schauan
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste