Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wert nicht vorhanden bzw. liegt dazwischen (gequantelte ab-Werte)
#1
Hallo alle,

leider erhalte ich über den SVERWEIS keine Variable zurück, weil der Wert in der Matrix nicht auftaucht, logisch. Jedoch ist die Spalte aus der anderen Tabelle (Tabelle2) gewollt so aufgestellt. Ich muss herausfinden, wie ich die richtige Zelle ermittle, wenn der eingegebenen Wert zwischen den beiden Zellen liegt.

Beispiel:
Tabelle 1
Kilometer____Frachtkosten
600________ #NV
421________#NV

Tabelle2
Ab Kilometer___EUR
.
.
425__________740
.
600__________900

Tabelle1
Mein Ansatz: =SVERWEIS(A2 *Die Spalte Kilometer(Tabelle1)*; Tabelle2!A2:B200;1 *Spaltepreis in EUR in (Tabelle2); FALSCH)
Vielleicht in der Suchmatrix muss eine Bedingung stehen?

VG MintMate
Antwortento top
#2
Hi,

bevor du "fertig hast", denke daran, dass eine abgespeckte und anonymisierte Beispieltabelle vielmals das Vorhaben erhellt.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Hi, 

Zum Einen ist FALSCH im SVERWEIS hier falsch, zum Andern wäre hier wohl eher Index/Vergleich angesagt. 1 ist im SVERWEIS auch falsch, Du willst ja den Wert aus Spalte 2! Diese Anfragen gibt es aber schon zigmal. Suche mal nach Frachtkosten.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#4
Hi,

ungetestet, weil keine Beispieltabelle vorliegt: ändere den 4. Parameter in WAHR
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#5
Hi,

hab mal schnell ein Beispiel im Anhang hinterlegt.


Angehängte Dateien
.xlsx   beispiel.xlsx (Größe: 8,71 KB / Downloads: 4)
Antwortento top
#6
@WillWissen, die Parameteränderung zu WAHR hat funktioniert. Gibt es vielleicht sonst eine alternative Lösung? Aber dafür erstmal vielen Dank!
Antwortento top
#7
Hi,

die Formelwahl nach deinem Tabellenaufbau ist ok. Du hast aber (zumindest im Beispiel) den Bereich nicht absolut gesetzt. Beim Runterziehen der Formel passt irgendwann das Ergebnis nicht mehr.


Code:
=SVERWEIS(A2;Tabelle2!$A$2:$B$7;2; 1)
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#8
Hi, 

Sverweis(a3;Tabelle2! A:b;2;1)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#9
Danke!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste