Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Bestimmte Datensätze suchen und auflisten.
#1
Hallo,

ich bin neu hier und hab auch gleich eine Frage. ;)

Zu meiner Person:
Ich habe schon so einiges mit Excel angestellt, Zeitkarten für den Außendienst mit Berechnung des Bruttoeinkommens, Überstundenkonto und Resturlaub.
Jetzt arbeite ich an einer Kalkulation für Wartungsverträge.

Kann aber leider kein VBA =(

Ich habe in meiner Mappe eine Tabelle in der die Kalkulation stattfindet, 3 weitere Tabellen dienen rein der Ausgabe der Ergebnisse in verschiedenen Darstellungen.
In einer Tabelle sind Materialdaten die sich aus bisher drei weiteren Herstellertabellen das Mit. bezieht.

Jetzt kann ich in der Kalk. eine Artikelnummer eingeben und die Felder Bez. EK und VK werden bei einem Treffer automatisch ausgefüllt.

Jetzt gebe ich immer Maschinenbezogene Daten ein und hätte gern, wenn ich z. B. Auto 1 eintrage, dass alles relevante Wartungsmaterial aufgelistet wird.
Da komme ich nicht weiter.

Kann mir da jemand helfen.

Gruß Sven


Angehängte Dateien
.xlsx   Arbeitsmappe1.xlsx (Größe: 45,24 KB / Downloads: 9)
Antwortento top
#2
Hallo, und wie sähe denn dein Wunscheregbnis aus..?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • svena73
Antwortento top
#3
Hallo,

warum filterst du nicht einfach deine Ersatzteiltabelle?
Viele Grüße
Klaus-Dieter
[-] Folgende(r) 1 Benutzer sagt Danke an Klaus-Dieter für diesen Beitrag:
  • svena73
Antwortento top
#4
Hi

Was ich mir aus deinen Vorgaben zusammenreime ist.

Im Blatt Wartungsmaterial in C5 die Formel. Wenn das passt sehen wir weiter.
Code:
=WENNFEHLER(INDEX(Tabelle1[Nummer];VERGLEICH(1;((ZÄHLENWENN($C$4:C4;Tabelle1[Nummer])=0)*ISTZAHL(INDIREKT("Tabelle1["&$B$1&"]")));0););"")
Formeleingabe mit strg+shift+Enter abschliessen.

Gruß Elex
[-] Folgende(r) 1 Benutzer sagt Danke an Elex für diesen Beitrag:
  • svena73
Antwortento top
#5
(16.09.2018, 09:05)Elex schrieb: Hi

Was ich mir aus deinen Vorgaben zusammenreime ist.

Im Blatt Wartungsmaterial in C5 die Formel. Wenn das passt sehen wir weiter.
Code:
=WENNFEHLER(INDEX(Tabelle1[Nummer];VERGLEICH(1;((ZÄHLENWENN($C$4:C4;Tabelle1[Nummer])=0)*ISTZAHL(INDIREKT("Tabelle1["&$B$1&"]")));0););"")
Formeleingabe mit strg+shift+Enter abschliessen.

Gruß Elex
WOW!!!!!

Perfekt, VOLLTREFFER genauso sollte es funktionieren.

Im Anhang das Ergebnis.
100


Angehängte Dateien
.xlsx   Wartung.xlsx (Größe: 46,84 KB / Downloads: 5)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste