Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Artikelstamm: Online-Shop #needhelp
#1
Question 
Hallo liebe Mitglieder,

hier ist der neue und ich habe direkt ein großes Anliegen  Blush 
  • In Spalte H, I, J, K, L etc. soll nach den Anfangsbuchstaben "Art:" gesucht werden
  • Sobald "Art:" gefunden wird, soll er mit den Text dahinter ausgeben ("Art: Furnierkante")
  • Wenn er etwas findet, soll er mit das in Spalte Z auflisten.
   

Wenn er nichts findet, soll die Spalte Z trotzdem ein "leeres Feld" enthalten.
Die Daten dürfen also nicht zusammengeführt werden, weil:

Jede Zeile ist ein fester Link zum einem Produkt und somit muss "Art:" entsprechend auch zu dem Link passen. 
Ansonsten wird es ein grandioses Durcheinander. (Online-Shop)

Ich hoffe ihr wisst wie ich das meine. Danke für eure Hilfe und einen tollen Abend,
Mazy
Antwortento top
#2
Zitat:Ich hoffe ihr wisst wie ich das meine.
Ich bin nicht ganz sicher, ob ich weiß, was du meinst. Aber so wie ich es interpretiere, willst du den Text aus der jeweiligen Zelle, in der am Anfang "Art:" steht.
Was du allerdings mit

Zitat:Wenn er nichts findet, soll die Spalte Z trotzdem ein "leeres Feld" enthalten.
meinst. Was soll die Spalte in der betreffenden Zeile denn auch sonst enthalten als ein leeres Feld?

Ist die Formel die du suchst vielleicht

Code:
=RECHTS(VERWEIS("Art:*";H2:Y2);LÄNGE(VERWEIS("Art:*";H2:Y2))-5)
oder auch nur
Code:
=VERWEIS("Art:*";H2:Y2)
?

Es wäre übrigens wesentlich hilfreicher, wenn du eine Beispielmappe postest anstatt relativ sinnlose Bilder.
Schöne Grüße
Berni
Antwortento top
#3
Hallo Berni,
hier habe ich ein anderes Beispiel vorbereitet.


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 9,69 KB / Downloads: 5)
Antwortento top
#4
Alles klar, das sagt doch gleich ganz was anderes aus.
Ich habe unten die hoffentlich passenden Formeln eingefügt, für alle Zeilen deines Beispiels. Maßgeblich sind nur die Formeln in F3:H3, danach wiederholt sich alles nur, sprich die Formeln werden nach unten gezogen. Achte auf die Matrixformel in G3!

Tabelle1

FGH
3Farbe: Blau
4Art: AnanasFarbe: Grün
5123456Farbe: Rot
6Farbe: Gelb
77890Farbe: Lila
8Farbe: Schwarz
9Art: RasenmäherFarbe: Orange
10Art: Banane34561Farbe: Weiß
11Art: ApfelFarbe: Magenta
Formeln der Tabelle
ZelleFormel
F3=WENNNV(WVERWEIS("Art:*";$B3:$D3;1;FALSCH);"")
G3{=WENNFEHLER(INDIREKT(ADRESSE(ZEILE(A3);MIN(WENN(ISTZAHL(B3:D3);SPALTE(B3:D3)))));"")}
H3=WENNNV(WVERWEIS("Farbe:*";$B3:$D3;1;FALSCH);"")
F4=WENNNV(WVERWEIS("Art:*";$B4:$D4;1;FALSCH);"")
G4{=WENNFEHLER(INDIREKT(ADRESSE(ZEILE(A4);MIN(WENN(ISTZAHL(B4:D4);SPALTE(B4:D4)))));"")}
H4=WENNNV(WVERWEIS("Farbe:*";$B4:$D4;1;FALSCH);"")
F5=WENNNV(WVERWEIS("Art:*";$B5:$D5;1;FALSCH);"")
G5{=WENNFEHLER(INDIREKT(ADRESSE(ZEILE(A5);MIN(WENN(ISTZAHL(B5:D5);SPALTE(B5:D5)))));"")}
H5=WENNNV(WVERWEIS("Farbe:*";$B5:$D5;1;FALSCH);"")
F6=WENNNV(WVERWEIS("Art:*";$B6:$D6;1;FALSCH);"")
G6{=WENNFEHLER(INDIREKT(ADRESSE(ZEILE(A6);MIN(WENN(ISTZAHL(B6:D6);SPALTE(B6:D6)))));"")}
H6=WENNNV(WVERWEIS("Farbe:*";$B6:$D6;1;FALSCH);"")
F7=WENNNV(WVERWEIS("Art:*";$B7:$D7;1;FALSCH);"")
G7{=WENNFEHLER(INDIREKT(ADRESSE(ZEILE(A7);MIN(WENN(ISTZAHL(B7:D7);SPALTE(B7:D7)))));"")}
H7=WENNNV(WVERWEIS("Farbe:*";$B7:$D7;1;FALSCH);"")
F8=WENNNV(WVERWEIS("Art:*";$B8:$D8;1;FALSCH);"")
G8{=WENNFEHLER(INDIREKT(ADRESSE(ZEILE(A8);MIN(WENN(ISTZAHL(B8:D8);SPALTE(B8:D8)))));"")}
H8=WENNNV(WVERWEIS("Farbe:*";$B8:$D8;1;FALSCH);"")
F9=WENNNV(WVERWEIS("Art:*";$B9:$D9;1;FALSCH);"")
G9{=WENNFEHLER(INDIREKT(ADRESSE(ZEILE(A9);MIN(WENN(ISTZAHL(B9:D9);SPALTE(B9:D9)))));"")}
H9=WENNNV(WVERWEIS("Farbe:*";$B9:$D9;1;FALSCH);"")
F10=WENNNV(WVERWEIS("Art:*";$B10:$D10;1;FALSCH);"")
G10{=WENNFEHLER(INDIREKT(ADRESSE(ZEILE(A10);MIN(WENN(ISTZAHL(B10:D10);SPALTE(B10:D10)))));"")}
H10=WENNNV(WVERWEIS("Farbe:*";$B10:$D10;1;FALSCH);"")
F11=WENNNV(WVERWEIS("Art:*";$B11:$D11;1;FALSCH);"")
G11{=WENNFEHLER(INDIREKT(ADRESSE(ZEILE(A11);MIN(WENN(ISTZAHL(B11:D11);SPALTE(B11:D11)))));"")}
H11=WENNNV(WVERWEIS("Farbe:*";$B11:$D11;1;FALSCH);"")
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Schöne Grüße
Berni
Antwortento top
#5
WOW! ES funktioniert einwandfrei! - Vielen lieben und herzlichen Dank!
Antwortento top
#6
Moin Mazy,
eine kleine "Gehässigkeit" kann ich mir nun doch nicht verkneifen: Bist du in der (ehemaligen) D"D"R groß geworden? Denn dort gab es auch keine Bananen  05(Die fehlen in deinem Lösungswunsch).

OK, und noch ein Hinweis: Das lässt sich (insbesondere bei größeren Datenmengen) auch gut mit Power Query lösen.
Beste Grüße
  Günther

Excel-ist-sexy.de
  …schau doch mal rein!
Der Sicherheit meiner Daten wegen lade ich keine *.xlsm bzw. *.xlsb- Files mehr herunter! -> So geht's ohne!
Antwortento top
#7
Hallo Günther,

Zitat:Bist du in der (ehemaligen) D"D"R groß geworden? Denn dort gab es auch keine Bananen

stimmt nicht. Bananen gabs nicht immer (und auch nicht immer öfter - um mich mal an Klaus Taler anzulehnen Smile ) Bevorzugt um die Weihnachtszeit, da waren die Bananen und vor allem die Lebkuchen und Schokoweihnachtsmänner noch was besonderes. Inzwischen kann man sich ja schon Ende August an Stollen und Weihnachtsgebäck satt essen ... Da bin ich kein Freund von, aber Bananen jeden Tag ist nicht verkehrt, da hat die Einheit schon was gebracht 100
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste