Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Funktion Preisunterschied
#1
Moin,

ich bearbeite gerade eine Tabelle und möchte ein Feld einfügen, dass Preisunterschiede automatisch kennzeichnet. Später soll die bedingte Formatierung eingesetzt werden.
Momenten helfe ich mir mit einer wenn oder Funktion. Das ist aber viel zu aufwendig. Ich möchte das Zellen ohne Einträge nicht berücksichtigt werden und Zellen mit Einträgen sich gegenseitig auf einen Preisunterschied prüfen.

Mit folgender Formel prüfe ich ja nur Zelle D5 mit allen Einträgen. Ich möchte aber, dass sich alle Einträge miteinander prüfen. Dafür gibt es doch sicher eine viel bessere Funktion als meine oder?

Danke für eure Hilfe.

=WENN(ODER(D5=I5;D5="";I5="")*ODER(D5=N5;D5="";N5="")*ODER(D5=S5;D5="";S5="")*ODER(D5=X5;D5="";X5="")*ODER(D5=AC5;D5="";AC5="")*ODER(D5=AH5;D5="";AH5="")*ODER(D5=AM5;D5="";AM5="")*ODER(D5=AR5;D5="";AR5="")*ODER(D5=AW5;D5="";AW5="")*ODER(D5=BB5;D5="";BB5="")*ODER(D5=BG5;D5="";BG5="")*ODER(D5=BL5;D5="";BL5="")*ODER(D5=BQ5;D5="";BQ5="")*ODER(D5=BV5;D5="";BV5="")*ODER(D5=CA5;D5="";CA5="")*ODER(D5=CF5;D5="";CF5="")*ODER(D5=CK5;D5="";CK5="")*ODER(D5=CP5;D5="";CP5="")*ODER(D5=CU5;D5="";CU5="")*ODER(D5=CZ5;D5="";CZ5="")*ODER(D5=DE5;D5="";DE5="")*ODER(D5=DJ5;D5="";DJ5="")*ODER(D5=DO5;D5="";DO5="")*ODER(D5=DT5;D5="";DT5="")*ODER(D5=DY5;D5="";DY5="")*ODER(D5=ED5;D5="";ED5="")*ODER(D5=EI5;D5="";EI5="")*ODER(D5=EN5;D5="";EN5="")*ODER(D5=ES5;D5="";ES5="")*ODER(D5=EX5;D5="";EX5="")*ODER(D5=FC5;D5="";FC5="");"OK";"Prüfung")
Antwortento top
#2
Moin!
Erstelle mal ein Beispiel mit 5 Spalten und erkläre vor allem folgendes etwas genauer:
Zitat:und Zellen mit Einträgen sich gegenseitig auf einen Preisunterschied prüfen

Zumindest ich habe da Verständnisprobleme.

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#3
Danke für deine Unterstützung. Ich habe ein Beispiel angehängt. 

Dort ist auch mein Problem zu erkennen. Papier 100 wird noch richtig geprüft. Papier 200 nicht, da die Formel ja nur ausgehend von B2 prüft.
Ich möchte ja, dass ich alle Einträge prüfe. Wie dann im Beispiel C3 und D3. Dafür würde ich bei meiner originalen Tabelle eine ewig lange wenn oder Funktion benötigen.

Merci.


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 9,25 KB / Downloads: 4)
Antwortento top
#4
Ich weiß immer noch nicht, was Du konkret vorhast.
Reicht es Dir nicht, das Minimum der Zeile zu markieren?
(meinethalben auch das Maximum oder alle Händler die ober/unterhalb des Durchschnitts oder Medians liegen)
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
[-] Folgende(r) 1 Benutzer sagt Danke an RPP63 für diesen Beitrag:
  • Drainee
Antwortento top
#5
Moin

Abseits der Verständnisprobleme für dein aktuelles Problem solltest du dein Modell ändern:
Du hast in der o.g. Formel Spaltensprünge. Schlecht für Auswertungen da man nicht einen gesamten Bereich abfragen kann.
Deine Tabelle geht mindestes bis zur 159. Spalte!
Kreuztabellen sind generell unpassend für Auswertungen.

Also, stelle dein Modell also auf eine Datensatzliste um.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • Drainee
Antwortento top
#6
Wink 
Einfach gesagt: Ich möchte wissen ob Händler A,B,C,D,F,.... den gleichen Preis für ein Produkt berechnen. 
Gibt es eine Abweichung soll dies durch "Prüfung" angezeigt werden. 

Du hast mir den passenden Hinweis gegeben. Danke dir. Ich habe viel zu kompliziert gedacht und Excel ist ne Weile her.

Lösung: =WENN(MIN(B3:J3)=MAX(B3:J3);"OK";"Prüfung")
Antwortento top
#7
(14.09.2018, 07:05)shift-del schrieb: Moin

Abseits der Verständnisprobleme für dein aktuelles Problem solltest du dein Modell ändern:
Du hast in der o.g. Formel Spaltensprünge. Schlecht für Auswertungen da man nicht einen gesamten Bereich abfragen kann.
Deine Tabelle geht mindestes bis zur 159. Spalte!
Kreuztabellen sind generell unpassend für Auswertungen.

Also, stelle dein Modell also auf eine Datensatzliste um.

Daran habe ich bereits auch schon ein paar Mal gedacht. Ich werde es wohl auch umsetzen. Das wird einfach zu viel Aufwand. 
Lieber die anderen Daten in einem neuen sheet oder abseits der Preise verarbeiten. Danke auch dir.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste