Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Problem mit Sverweis und zwei Suchkriterien
#1
Hallo,

ich habe in einem Arbeitsblatt zwei Tabellen:

Tabelle_1 ES_Auswahl - hier sind alle möglichen Eigenschaften mit den entsprechenden IDs aufgeführt
Tabelle_2 ES_Auswahl_to_Artikel - hier wird einem Artikel ein ES-Wert zugeordnet - jetzt soll dieser mit einem Sverweis herausbekommen welche Wert_ID die Eigenschaft hat.

Ich habe zwei Möglicheiten gefunden - beide funktionieren leider nicht - ich verstehe nicht wieso - oder wo der Fehler liegt.

Möglichkeit 1:
mit einem INDEX

Möglichkeit 2:
Sverweis mit &

kann mir jemand mal erklären was ich hier falsch mache? 

Ich bitte um Rückmeldung.
DANKE


Angehängte Dateien
.xlsx   sverweis_problem.xlsx (Größe: 59,39 KB / Downloads: 5)
Antwortento top
#2
Hallo, was soll denn rauskommen..? Ich habe für E3 7 raus..? Was soll in F3?
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#3
Hallo

Es waren ein paar @ zu viel.

Code:
{=(INDEX(ES_Auswahl[ES-Auswahl-ID];VERGLEICH([@[ES-Name]]&[@[ES-Auswahl-Wert]];ES_Auswahl[ES-Name]&ES_Auswahl[ES-Auswahl-Wert];0)))}
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • n8lauscher
Antwortento top
#4
Ja vielen DANK!

die "@" fügt Excel automatisch ein.
Ich wäre nie darauf gekommen, dass diese falsch sein könnten...
naja wie auch immer jetzt klappt es ja....

Aber es gibt noch ein Problem....

guck dir mal Zeile 480 an...:
Das Feld aus ES-Auswahl ist sehr lang... also der Inhalt.... daher kann dieser nicht korrekt zugeordnet werden.
Gibt es hier noch eine Möglichkeit?
Antwortento top
#5
(12.09.2018, 23:18)Jockel schrieb: Hallo, was soll denn rauskommen..? Ich habe für E3 7 raus..? Was soll in F3?

ich habe hier zwei Möglichkeiten gefunden mit denen ich das lösen könnte.
Bei beiden soll natürlich 7 rauskommen.

für E3 habe ich ja jetzt bereits die Lösung - hatte ein paar "@" zu viel.
Antwortento top
#6
Hallo, es gibt mindestens eine dritte (mit ohne CSE-Abschluss)
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#7
@Jockel
verketten würde mir da noch einfallen?
Antwortento top
#8
@all

wo bekomme ich Infos über das "@" Zeichen bezüglich intelligenter Tabellen.
Mir ist bisher noch nicht klar - wann ich das @ verwendet und wann nicht - bzw. wofür es überhaupt da ist... ;)
Antwortento top
#9
(13.09.2018, 12:26)n8lauscher schrieb: die "@" fügt Excel automatisch ein.
Ja, aber nur wenn du eine Zelle bei der Formelerstellung markiert hast. Wenn du alle Zellen in einer Spalte markierst dann passiert das nicht.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#10
aber ich versteh noch nicht den Unterschied..

wo ist der Unterschied zwischen:

Code:
=KLEIN([@[ES-Name]])

und

Code:
=KLEIN([ES-Name])
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste