Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summe von einem fixen Datum - 90Tage
#1
Hallo zusammen,

zerbreche mir gerade den Kopf. Ich benötige in der Zelle T2 die Summe aus der Spalte N die in dem Zeitraum vom Datum aus "B2 abzüglich 90 Tage" stattgefunden hat. Sprich innerhalb von 90 Tagen rückwirkend B2.
In der Zelle T3 dann vom Datum von B3-90Tagen usw....

Wer kann mir helfen

Gruß Marco


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hallo
versuche es mal so:
=SUMMEWENNS(N:N;B:B;"<="&B2;B:B;">="&B2-90)
alternativ
=SUMMENPRODUKT((B:B<=B2)*(B:B>=(B2-90))*(B:B<>"")*N:N)

Gruß Holger
Antwortento top
#3
.... kurzer Nachtrag:
B:B und N:N : Ganze Spalten in der Formel benötigen unter Umständen doch einiges an Rechenleistung
Ich würde mir dazu Überlegen die Matrix auf einen maximal möglichen Bereich zu begrenzen.
Beispiel
$B$2:$B$1000 und $N$2:$N$1000

LG
Antwortento top
#4
Moin!
Nur eine zusätzliche Anmerkung, bin mir sicher, dass Holger dies auch genau so meinte:
SUMMEWENNS() verarbeitet problemlos ganze Spalten und nutzt automatisch nur den UsedRange.
Bei SUMMENPRODUKT(), einer uralten aber genialen Funktion, ist dies nicht der Fall.
Daher gilt der letzte Beitrag nur für SUMMENPRODUKT()

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#5
Für "Nostalgiker" gibt es hier eine blitzschnelle Alternative mit DBSUMME():

ABCDE
1DatumWertDatumDatum
201.01.20187<=43352>=43262
301.02.2018109.09.201811.06.2018
401.03.20185
501.04.2018813
601.05.20181
701.06.20183
801.07.20183
901.08.20181
1001.09.20189
1101.10.20189
1201.11.20189
1301.12.20183

ZelleFormel
D2="<="&D3
E2=">="&E3
E3=D3-90
D5=DBSUMME(A:B;2;D1:E2)
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#6
(09.09.2018, 09:58)RPP63 schrieb: Für "Nostalgiker" gibt es hier eine blitzschnelle Alternative mit DBSUMME():

......]

Hi, prima! Gefällt mir gut, ich bin auch ein DB-Formel-Fan!   19


wie muss die Formel aussehen wenn man den jeweils berechnenden Datumsbereich bedingt farbig formatieren möchte? (angenommen in Spalte A eine Liste mit mindest 1x jeder Tag)
Ich hab's probiert, aber bekomme es nicht hin. Blush

Danke mal !

jack
Antwortento top
#7
Hallo zusammen,

danke für die schnelle und Zahlreiche Hilfe. Ich habe die Formel von echo genommen "Summenprodukt" die andere hat leider nicht funktioniert. Die Matrix hatte ich schon gleich mit eingearbeitet, da in der unteren Hälfte Daten stehen die nicht für die Berechnung geeignet sind. Funktioniert prima.

Muss aber auch sagen, dass ich die Formel nicht verstehen, aber so lange sie funktioniert  Blush

Danke an alle

Gruß Marco
Antwortento top
#8
Na denn: Willkommen im Klub, Jack!  19
Arbeitest Du bei "Die Bahn"?  05
Formel der bedingten Form. für Spalte A:
=UND(A1<=HEUTE();A1>=HEUTE()-90)

@Biker:
Wenn SUMMEWENN() bei Dir nicht funktioniert, solltest Du mal eine Beispieldatei hochlaben!
Schließlich ist dies die Funktion, die es gerade "Neulingen" einfacher macht.

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#9
(09.09.2018, 18:52)RPP63 schrieb: Na denn: Willkommen im Klub, Jack!  19
Arbeitest Du bei "Die Bahn"?  05
Formel der bedingten Form. für Spalte A:
=UND(A1<=HEUTE();A1>=HEUTE()-90)

.................................................]

Gruß Ralf

Danke! 18    ich werde probieren das umzustricken so dass es nicht nur mit HEUTE geht, sondern auch mit einem frei einzugebendem "Startdatum" .  Wenn ich's nicht hinbekomme, melde ich mich noch mal. ;)

jack
Antwortento top
#10
Hi,

hab die Formel "Summewenns" eben noch mal probiert. Funktioniert doch, vielleicht habe irgendwie beim ersten Mal einen Fehler reingebracht  Huh 19

Danke
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste