Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Sverweis/ WEnn Funktions Problem
#1
Moin Moin,
ich habe ein kleines Excel Problem bzw. stehe aktuell auf dem Schlauch. Ich habe im Anhang die dazugehörige Excel Tabelle beigefügt.
Mein Problem ist nun folgendes: Ich habe in der ersten Spalte das fortlaufende Datum vom 01.01.2014-31.08.2018. In der dritten Spalte sind die Kurse des S&P500-Index wiederzufinden mit dem dazuzgehörigen Datum. Dadurch, dass die Kurse des Indexes nur von Mo-Fr verfügbar sind, kann ich die Werte nicht einfach per Copy Past in die Zweite Spalte "S&P500" eintragen.
Ich möchte nun, dass Excel immer dann wenn die beiden Tage übereinstimmen (z.b der 06.01.2014) das der dazuzgehörige Wert dort eingetragen wird. Somit müsste beispielweise der 05 und 06.01 leer bleiben, weil es für diesen Tag keinen Kurs gibt und am 06.01 soll dann der dazugehörige Kurs in die Spalte eingetragen werden ( dort stimmen die beiden Tage ja überein).
Habe es schon mit Sverweis und Wenn Funktion probiert, alleridings ohne Erfolg. Vielleicht kann mir jemand bei dem Problem behilflich sein.

Schöne Grüße
Finn


Angehängte Dateien
.xlsx   Excel Problem.xlsx (Größe: 41,17 KB / Downloads: 3)
Antwortento top
#2
Hi Finn,

hab' ich dich richtig verstanden?

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
1DatumS&P500DatumSchlusskurs
201.01.201402.01.20141831,9799
302.01.20141831,979903.01.20141831,3699
403.01.20141831,369906.01.20141826,77
504.01.201407.01.20141837,88
605.01.201408.01.20141837,4899
706.01.20141826,7709.01.20141838,13
807.01.20141837,8810.01.20141842,3699
908.01.20141837,489913.01.20141819,1999
1009.01.20141838,1314.01.20141838,88
1110.01.20141842,369915.01.20141848,38
1211.01.201416.01.20141845,89
1312.01.201417.01.20141838,6999
1413.01.20141819,199921.01.20141843,8
1514.01.20141838,8822.01.20141844,8599
1615.01.20141848,3823.01.20141828,4599
1716.01.20141845,8924.01.20141790,29
1817.01.20141838,699927.01.20141781,56
1918.01.201428.01.20141792,5
2019.01.201429.01.20141774,1999
2120.01.201430.01.20141794,1899
2221.01.20141843,831.01.20141782,5899
2322.01.20141844,859903.02.20141741,89
2423.01.20141828,459904.02.20141755,1999
2524.01.20141790,2905.02.20141751,64
2625.01.201406.02.20141773,43
2726.01.201407.02.20141797,02
2827.01.20141781,5610.02.20141799,8399

ZelleFormel
B2=WENNFEHLER(INDEX(D:D;VERGLEICH(A2;$C$1:$C$2000;0));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Finn_2802
Antwortento top
#3
Hallo Günter,
genau das ist die Lösung für mein Problem! Vielen Dank für die schnelle Hilfe!

Schöne Grüße
Finn
Antwortento top
#4
Hi,


Code:
=WENNFEHLER(SVERWEIS(A2;C:D;2;0);"")
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Finn_2802
Antwortento top
#5
Hallo Opa Edgar,
auch dein Code klappt! Vielen Dank auch dir für deine Hilfe!

Schöne Grüße
Finn
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste