Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summe über von Excel ausrechnen lassen
#1
Hallo liebe Leser(innen),

wie kann ich ein Summe über von Excel berechnen lassen, ganz allgemein:

z.B. diese:

                             [Bild: image3595.png]

Vielen Dank!

Matthias
Antwortento top
#2
Hi,

Arbeitsblatt mit dem Namen 'Tabelle2'
BCD
7181689,21875
832181689,21875
912
1020
1119
125
133
1425
1517
1613
1719
1822
194
206
2115
2219
2317
246
256
264
2725
2811
2910
3010
314
3222
336
342
3519
3616
3721
381

ZelleFormel
D7=SUMMENPRODUKT((C7:C38-MITTELWERT(C7:C38))^2)
D8=SUMMENPRODUKT((INDEX($C$7:$C$38;B7):INDEX($C$7:$C$38;B8)-MITTELWERT(INDEX($C$7:$C$38;B7):INDEX($C$7:$C$38;B8)))^2)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • ht_2012
Antwortento top
#3
Vielen Dank!, funktioniert!


gut, okay, in diesem Fall macht das die Funktion:

SUMQUADABW
'Summe der quadrierten Abweichungen von Datenpunkten von deren Stichprobenmittelwert'.


Aber angenommen ich hätte eine andere Summen-Formel mit einer Laufvariablen. Wie kann ich diese Summenberechnung dann umsetzen?
Antwortento top
#4
Hi,


Code:
Wie kann ich diese Summenberechnung dann umsetzen?

anhand der vorhanden Formel ausprobieren oder zeigen. Solche Dinge gibt es nicht für jeden beliebigen Fall als Standardformel.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#5
wie wäre es damit:

            [Bild: image3598.png]

Der Faktor ai muss einer tabelle entnommen werden, in der n horizontal steht (2, 3, 4, ...) und ai vertikal aufsteigend nach unten (1, 2, 3, ...).
Der Term in der Klammer bedeutet der größte minus des kleinsten, der 2. größte minus den 2. kleinsten, ...
m ist n halbe, wenn n gerade und (n-1)halbe wenn n ungerade.
Antwortento top
#6
Hi,


wenn Du dazu noch eine Tabelle lieferst, kann man mal schauen, ich suche mir keine Xe aus.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#7
Angry
geloescht.
Antwortento top
#8
(07.09.2018, 11:01)ht_2012 schrieb: wie wäre es damit:

            [Bild: image3598.png]

Der Faktor ai muss einer tabelle entnommen werden, in der n horizontal steht (2, 3, 4, ...) und ai vertikal aufsteigend nach unten (1, 2, 3, ...).
Der Term in der Klammer bedeutet der größte minus des kleinsten, der 2. größte minus den 2. kleinsten, ...
m ist n halbe, wenn n gerade und (n-1)halbe wenn n ungerade.

Hallo,

hier eine Tabelle für die Formel von oben:

Vielen Dank!
Matthias





Arbeitsblatt mit dem Namen 'Tabelle4'
BCDEFGHIJ
2x
3sortiertabsteigend
42,003,60n8
52,403,30x02,86
62,403,30
72,703,20SS2,24
83,202,70
93,302,40m4
103,302,40
113,602,00
12
13n=2345678
14a10,70710,70710,68720,66460,64130,62330,6052
15a20,16770,24130,28050,30310,3164
16a30,08750,14010,1743
17a40,0561

ZelleFormel
F4=ANZAHL(B:B)
F5=MITTELWERT(B4:B11)
F7=SUMQUADABW(B$4:B$11)
F9=WENN(ISTGERADE(F$4);F$4/2;(F$4-1)/2)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg



Antwortento top
#9
Hallo ht_2012.

Wen Du keine Scheu hast, zwei Zwischenspalten zu verwenden, empfehle ich Dir folgenden Ansatz:

In F1 steht die Anzahl.

In Spalte C bildest Du die Differenz zwischen dem hinteren und vorderen Wert aus Spalte B mit          WENN(INDIREKT("B"&7+$F$1-ZEILE())-B4<0;0;INDIREKT("B"&7+$F$1-ZEILE())-B4)

In Spalte D holst Du Dir die Werte ai passend hoch mit        WAHL($F$1;0;D18;E18;F18;G18;H18;I18;J18)

Und jetzt ist das Ergebnis    SUMMENPRODUKT(C4:C7;D4:D7).

Offen ist für mich noch, was Du mit dem mittleren Wert bei ungerader Anzahl machen willst, weil hierfür kein Multiplikator unten vorgesehen ist.

Ich hänge ein Beispiel dran, habe aber nicht viel getestet.

Ich hoffe, es hilft Dir.

Peter


Angehängte Dateien
.xlsx   109-Forum 2018.09.18 Summenformel.xlsx (Größe: 12,29 KB / Downloads: 1)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste