Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

fehler in der Erstellung beim Schichtplaner
#1
Ein schönes Hallo an alle,

seit meinem letzten Post bin ich mit dem Schichtplaner schon ein gutes Stück weiter gekommen. Leider häng ich gerade wieder einmal fest und mein Kopf raucht schon vor lauter Fragezeichen darin. Huh 

Zu dem eigentlichen Problem (Datei im Anhang):

Im Feld T10:AX.... werden die einzelnen Schichten per leicht Verschachtelter WENN-Funktion in Kombi mit Sverweis und Vergleich aus der Datenbank ausgelesen, nachdem in z.b. in G10 die Zahl 1 eingegeben wird. Hat der Monat z.b. nur 30 Tage hat gibt er mir aktuell den fehler "Falsch" in Spalte AX10+ heraus. Davor gab es den Fehler #NV, weshalb die gesamte berechnung der Monatlichen Arbeitszeit bei 30 Tagen/Monat fehlschlug.

Versucht habe ich schon die Formel umzubauen, die Fehler per Wennfehler, Wennnv und über Ist-Funktionen abzufangen, damit die zellen Leer bleiben.

Für Fragen stehe ich euch gerne zur Verfügung und ein Danke im Voraus für euren Support


Gruß
Viktor

p.s. Beim Blattschutz ist kein PW Vorhanden


Angehängte Dateien
.xlsx   Diensteinsatzplan_entwicklung.xlsx (Größe: 369,03 KB / Downloads: 3)
Antwortento top
#2
so?

Arbeitsblatt mit dem Namen 'Januar 2018'
ST
10Ma 10

ZelleFormel
S10=WENN($A10=0;"";$A10)
T10=WENN($G10>=1;WENNFEHLER(SVERWEIS($G10;'#1 Datenbank'!$S$4:$BI$1000;VERGLEICH(T$4;'#1 Datenbank'!$S$3:$BI$3;0);FALSCH);"");"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#3
Ist schon besser.

So eine Ähnliche Formel hatte ich allerdings auch schon in einem Hilfsbereich um das Ganze zu testen. Habe dann per WENN-Formel die Nullen für den Arbeitsbereich ausgeblendet und die Aktuelle Formel in der Mappe eingebaut. Ab da ging das Schlamassel Los. Fehler #NV, dann Falsch usw.

Versuche deshalb eine Formel einzubetten, die mir zwar den richtigen ablauf einbaut jedoch ohne die ganzen fehler oder nullen auszugeben.
Antwortento top
#4
Die Null blendest du unter Einstellungen Extras aus!

Oder Benuzerdefinierte Formatierung [=0]" "
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#5
Ist auf jeden Fall auch eine Option.

Leider möchte unser Personalrat, das in jeder abteilung mit dem gleichen Programm der Dienstplan erstellt wird.
Somit etliche PC's/Abteilungen und Anwender mit mehr oder weniger Kenntnissen, wie auch notwendige anzeigen von Nullen zwecks buchhaltung/abrechnungen.

Also leider eine Sache der Notwendigkeit und auch Bequemlichkeit.

Werds auf jeden Fall weiterversuchen. Wenn nötig kommt wieder ein Hilfsbereich dazu.
Antwortento top
#6
Das Ausblenden bezieht sich nur auf die aktuelle Datei bzw. aktuelle Tabellenblatt!

Oder eben Benuzerdefinierte Formatierung [=0]" "
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#7
wusste gar nicht, das die einstellung dann zurückgesetzt wird. wieder was dazugelernt.

bedingte formatierung wäre auch eine Option.

Danke auf jeden fall schon mal für die heutige Hilfe
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste