Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Schwierigkeiten bei der Zählenwenns-Funktion
#1
Hallo!

Ich versuche eine Formel zu entwickeln, mit der die Anzahl der Spiele, die am 1. Spieltag gegen einen bestimmten Gegner absolviert wurden, angezeigt werden.
Ich habe schon diverses versucht, bekomme aber immer nur 0-Werte oder Fehler heraus, meistens aber 0-Werte.

Also, konkret möchte ich angezeigt bekommen, gegen wen am 1. (2., 3., usw.) Spieltag wie oft gespielt wurde.
Sagenwirmal am 1. wurde gegen den FC Bayern München gespielt, soll Excel mir in den Spalte L in Zelle 19 den Wert anzeigen, wie oft gegen diese Mannschaft am 1. Spieltag gespielt hat. In den nächsten Spalten sollte die Formel so angeglichen werden, daß Excel mir jedesmal den Summenwert für den 2., 3., 4. usw. Spieltag anzeigt.
Diesen Vorgang sollte Excel auch mir für alle anderen aufgeführten Mannschaften anzeigen.

In meiner beigefügten Liste sind 2 verschiedene Formeln enthalten (Spalte L, dort speziell in Zelle 2 und 3, der Rest ist wie in Zelle 2), die beide 0-Werte anzeigen.
Auch habe ich die Leerzellen mittlerweile mit einem "x" gefüllt; diese Änderung hat aber auch nichts gebracht. Ich bin ratlos...  39 

Hat jemand eine Idee, was ich falsch gemacht habe und zeigt mir die richtige Version?
Ist womöglich die Zählenwenns-Funktion hier die falsche?

Das wäre super!


.xlsx   Spieltagsanalyse.xlsx (Größe: 190,87 KB / Downloads: 4)
Antwortento top
#2
Hi Al,

1. deine Formel ist falsch
2. woher bekommt Excel die Info, wann der erste Spieltag ist?
3. beim Öffnen deiner Datei meckert Excel eine fehlende Verknüpfung an

Vllt. solltest du eine neue Beispieldatei hochladen. Zum einen braucht's keine knapp 1400 Datensätze; hier würden allemal 50-100 reichen. Dann solltest du händisch ein paar Wunschergebnisse eintragen
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Hallo, Günter!

zu 1. das weiß ich leider....da liegt ja der Hase im Pfeffer
zu 2. die sind in Spalte B
zu 3. das liegt daran, daß ich Werte für die Spalten B-G aus einem anderen (nicht beigefügten) Tabellenblatt gezogen habe.

Trotzdem, hast du eine Idee, was 1. angeht?
Antwortento top
#4
Hi,

sollen wir raten, was in den anderen Tabellen steht?
Sollen wir raten, was x bedeutet?
Was soll bei Dynamo Dresden unter 1 als Ergebnis stehen?
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#5
i. O., wenn es so ist, daß ihr alle sehen wollt, was in dem vermißten Tabellenblatt steht...bitte schön!

Jetzt sollten sich zumindest die Fehlermeldungen erledigt haben....

das "x" wurde von mir nur eingefügt, weil ich dort normalerweise nichts stehen hatte und eine Fehlerquelle vermeiden wollte...hat aber nix gebracht


Angehängte Dateien
.xlsx   Fußballstatistiken Bayer 04 Leverkusena.xlsx (Größe: 420,15 KB / Downloads: 1)
Antwortento top
#6
Ich rate mal:
Code:
=WENN($C2="x";ZÄHLENWENNS($B$2:$B$1365;L$1;$D$2:$D$1365;$D2);ZÄHLENWENNS($B$2:$B$1365;L$1;$C$2:$C$1365;$C2))
Gruß
Michael
[-] Folgende(r) 1 Benutzer sagt Danke an Der Steuerfuzzi für diesen Beitrag:
  • Al Swearengen
Antwortento top
#7
Hi Al,

mein Vorschlag:

Arbeitsblatt mit dem Namen 'Spieltagsanalyse'
ABCDEFGHIJKLMNOPQRSTUVWXYZ
1ST:daheim:auswärts:S-U-NTore +Tore -123456789101112131415
21xFC Bayern MünchenN13FC Bayern München534233213245
32Hertha BSCxs211. FC Kaiserslautern211122435131
43xMSV DuisburgN051. FC Köln1361411243
541. FC Kaiserslauternxs311. FC Nürnberg31231121411
65xEintracht FrankfurtN031. FC Saarbrücken11
761. FC Kölnxu111. FSV Mainz 05212121211
87xWerder BremenU11Alemannia Aachen1

ZelleFormel
L2=ZÄHLENWENNS($C$1:$C$1500;$K2;$B$1:$B$1500;L$1)+ZÄHLENWENNS($D$1:$D$1500;$K2;$B$1:$B$1500;L$1)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Formel nach dem Eintrag in L2 nach rechts und nach unten ziehen

Nachtrag:

Damit die zwangsläufig auftauchenden Nullen nicht stören (wird für mich einfach zu unübersichtlich) kannst du diese mit dem benutzerdefinierten Zahlenformat
Code:
0;;
ausblenden.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Al Swearengen
Antwortento top
#8
Hallo Günter!

DAS ist sie! Und, wie ich sehe, ist zählenwenns doch die richtig vermutete Vorgehensweise. Meine Version war eben einfach nur falsch, weil zu kurz....oder so.

Auf jeden Fall ist das genau das, was ich suchte!

DANKE SEHR dafür!  18
Antwortento top
#9
Off topic!

Hast du dir eigentlich den letzten Beitrag von mir in deiner vorherigen Anfrage angesehen?
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste