Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Kunden die nicht angeschrieben wurden, per VBA markieren oder löschen
#1
Guten Abend,

ich wollte hier mal nachfragen, ob jemand kurz helfen kann.
Ich habe viele Kunden angeschrieben. Die angeschriebenen Kunden (auch mit ohne ) stehen in einer Excel Liste.
Ich möchte jetzt Kunden die nicht angeschrieben wurden in dieser Liste markieren oder Löschen.

Es würde mich sehr freuen wenn mir jemand helfen könnte.

Freundliche Grüße
Van
Antwortento top
#2
Hallo van,

da brauchst du kein VBA - filtere einfach nach den nicht angeschriebenen Kunden, eventuell durch eine "x"-Markierung in einer Hilfsspalte. Dann kannst du die gefilterten Zeilen markieren und löschen.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Zitat:Die angeschriebenen Kunden (auch mit ohne )

Was soll das denn heißen?
Wie Günter schon geschrieben hat, ist VBA hier vollkommen unnötig. Aber egal ob VBA oder Autofilterlösung: Du schreibst überhaupt nicht, wie die angeschriebenen von den nicht angeschriebenen Kunden unterschieden werden können. Wenn du eine Lösung willst, wirst du schon ein paar mehr Infos rausrücken müssen.
Schöne Grüße
Berni
Antwortento top
#4
Guten Abend,

sorry für die späte Rückmeldung.

Im Mai haben wir alle Kunden wegen der DSGVO angeschrieben. Die angeschriebenen Kunden stehen in der Liste DSGVO_Adresse.xls. Aus dieser Liste wurde manuell Kunden gelöscht, so dass ein automatischer Abgleich nicht möglich ist.

Ich möchte jetzt die Kunden die nicht angeschrieben wurden, in der Liste DSGVO_Rückmeldungen.xls markieren.

Wie geht das in Excel?

Freundliche Grüße

Van
Antwortento top
#5
Hi,

so wird das nichts. Deine zweite Erklärung ist nicht erhellender als deine erste. Betrachte das Ganze bitte einmal mit den Augen eines Außenstehenden. Du weißt, wie deine Listen aufgebaut sind; wir nicht. Du weißt, wie die bereits angeschriebenen Kunden gekennzeichnet sind; wir nicht.


Zitat:Ich möchte jetzt die Kunden die nicht angeschrieben wurden, in der Liste DSGVO_Rückmeldungen.xls markieren.

Und wie sind die gekennzeichnet?

Am besten wäre es, wenn du eine anonymisierte und bis auf etwa 20 Datensätzen abgespeckte Beispieldatei hochladen würdest. http://www.clever-excel-forum.de/Thread-...ng-stellen. Der Aufbau deiner Beispieldatei muss zwingende deinem Original gleichen.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Frogger1986
Antwortento top
#6
Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
1Kunde angeschriebenKunden alleMarkierung
2Williwilli1
3Ottobald0
4TrudeOtto1
5kar0
6Ger0
7Trude1

ZelleFormel
D2=ZÄHLENWENN($A$1:$A$10;C2)
D3=ZÄHLENWENN($A$1:$A$10;C3)
D4=ZÄHLENWENN($A$1:$A$10;C4)
D5=ZÄHLENWENN($A$1:$A$10;C5)
D6=ZÄHLENWENN($A$1:$A$10;C6)
D7=ZÄHLENWENN($A$1:$A$10;C7)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#7
Hi André,

[Bild: Crystal_ball.png]
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#8
anbei  findet Ihr die beide Listen im Anhang.
Die angeschriebenen Kunden stehen in der Liste DSGVO_Adresse_Verträge.
Ich möchte jetzt die Kunden die nicht angeschrieben wurden, in der Liste DSGVO_Rückmeldungen markieren. In der Spalte D steht das Datum der Rückmeldung.

Vielen Dank an euch im Voraus!


.xlsx   DSGVO_Rückmeldungen20180903.xlsx (Größe: 32,69 KB / Downloads: 4)

.xlsx   DSGVO_Adressen_Verträge_GKE.xlsx (Größe: 10,55 KB / Downloads: 3)
Antwortento top
#9
so... (ich habe beide Tabellen in eine Datei, geht aber auch wenn die Tabellen Verknüpft werden)


Arbeitsblatt mit dem Namen 'Adressen Verträge'
ABCDEF
1Kunden-Nr.SuchnameName 1Name 2
210001trinkkontor PFB; Bitburg;trinkkontor GmbH

ZelleFormel
F2=WENNFEHLER(WENN(UND(SVERWEIS(A2;Rückmeldungen!B:D;3;0)<=HEUTE();SVERWEIS(A2;Rückmeldungen!B:D;3;0)>0);"Rückmeldung erhalten!";"");"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg


Angehängte Dateien
.xlsx   Rückmeldungen.xlsx (Größe: 34,67 KB / Downloads: 4)
Eine Menge reden, aber nichts sagen können viele...
[-] Folgende(r) 1 Benutzer sagt Danke an Frogger1986 für diesen Beitrag:
  • van
Antwortento top
#10
Hallöchen Crystal_Ball_Günter Smile & Frogger,

wie zwei Tabellen zum Vergleich, ob Daten enthalten sind, verknüpft werden können sieht man ja, oh welch Wunder, an der vom TE im Beispiel verwendeten Funktion ZÄHLENWENN. Im Sinne vom Forenmotto "Hilfe zur Selbsthilfe" hat eine allgemeine Darstellung weder eine Glaskugel noch eine Beispieldatei zur Grundlage. Ob der TE daraus ableitend sein Problem lösen kann oder nicht, oder ob es weiterer Hilfen oder auch einer Beispieldatei bedarf, sieht man an eventuellen weiteren Fragen.

Der TE verwendet die Funktion ZÄHLENWENN in Spalte E der Tabelle "Rückmeldung" - die Markierung sollte laut Aufgabenstellung in der Tabelle Rückmeldung erfolgen und nicht in der Tabelle Aufträge:
Zitat:Ich möchte jetzt die Kunden die nicht angeschrieben wurden, in der Liste DSGVO_Rückmeldungen markieren.
Nicht in der Auftragstabelle enthaltene Kunden erhalten eine 0, angeschriebene eine 1. Ob die 1 stört oder nicht sei dahingestellt - da hat doch der Günter nach Blick in seine Kugel  in #2 schon was mit x und Autofilter geschrieben, bei mir sind's halt Zahlen ...

Was das Datum für eine Rolle spielen soll, erschließt sich mir momentan nicht. In der Tabelle Rückmeldungen haben alle Einträge ein Datum <= heute.
Auch die Art der Markierung ist immer noch nicht beschrieben - von "Rückmeldung erhalten!" steht nirgends etwas. Günter- hast Du etwa nicht genug Glaskugeln zum verteilen 15 ?

Die Frage wäre jetzt, falls sich der Dateiname auf den Inhalt bezieht, wie Rückmeldungen erfolgen konnten, wenn die Kunden nicht angeschrieben wurden.
Zitat:Die angeschriebenen Kunden stehen in der Liste DSGVO_Adresse_Verträge.
Die Funktion in Spalte E gibt ja die Kunden wieder, die bei den angeschriebenen fehlen.

Aus meiner Sicht beantwortet die Markierung in der Tabelle Rückmeldung die Frage, welche Kunden aus der Liste der angeschriebenen Kunden gelöscht wurden.
Zitat:Liste DSGVO_Adresse.xls. Aus dieser Liste wurde manuell Kunden gelöscht

Eine Markierung in der Liste der Aufträge würde die Frage beantworten, von welchen angeschriebenen Kunden eine Rückmeldung erfolgt.
Zitat:Die angeschriebenen Kunden stehen in der Liste DSGVO_Adresse.xls.

Die Frage
Zitat:Ich möchte jetzt die Kunden die nicht angeschrieben wurden...
lässt sich nur mit einer Liste aller Kunden beantworten. Laut bisherigen Beschreibungen der Dateien liegt eine solche Liste jedoch nicht vor.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste