Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Daten aus mehreren Tabellen zusammenfassen und Rest löschen
#1
Hallo werte Community,

ich habe hier drei Tabellen als drei xls-Dateien,

in jeder der drei Tabellen ist eine Kundenliste mit der jeweiligen Kundennummer und der Umsatz 2018, dazu a) Umsatz 2017 b) Umsatz 2016 c) Umsatz 2015.
Dies soll eine eigene Tabelle sein, mit Kundennummer, Umsatz 2018, U2017, U2016, U2015.

Ich habe also die Daten aus der 2016er und 2015er Tabelle in die 2017er Tabelle kopiert und gefiltert. Jetzt habe ich natürlich Dupletten und müsste die Zahlen der Duplette von 2015 in das leere 2015-Feld der ursprünglichen 2018er Zeile eintragen, danach die Duplette löschen. Kann ich das irgendwie vereinfachen? Mit Konsolidieren z.B.? Danke für die Hinweise.
Antwortento top
#2
wenn du die Dateien miteinander öffnest und mit Zählenwenn() abgleichst kannst du in Kombination mit dem Autofilter die daten, die doppelt sind, filtern und auf einmal löschen!
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#3
ich muss halt erst aus den Dupletten die Zahlen für 2016 und 2015 in die leeren Zellen des 2017er Datensatz nehmen. Sieht jetzt so aus etwa:

Name              Umsatz 2018          Umsatz 2017        Umsatz 2016      Umsatz 2015
Meier GmbH     100000 €                15000 Euro
Meier GmbH     100000 €                                          17000 Euro
Meier GmbH     100000 €                                                                  12000 Euro


Also muss Zeile 2 und 3 raus, aber die Werte 17000 und 12000 müssen in die erste Zeile.
Antwortento top
#4
Mach eine neue Spalte mit 2017 und Addiere die Zahlen auf eine Spalte!

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEF
1Name
2Umsatz 2018Umsatz 2017Umsatz 2017Umsatz 2016Umsatz 2015
3Meier GmbH1000001500015000
4Meier GmbH1000001700017000
5Meier GmbH1000001200012000
6Meier GmbH1000000

ZelleFormel
C3=SUMME(D3:F3)
C4=SUMME(D4:F4)
C5=SUMME(D5:F5)
C6=SUMME(D6:F6)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#5
ich will bloß noch eine Zeile pro Firma haben, der Rest soll gelöscht werden. Sind knapp 2000 Firmen, ich brauch diesen AutomatismusSmile Danke dass du mir hilfst!
Antwortento top
#6
d.h. es müssen die Umsätze der Firmen addiert werden in den Jahren und in einer Zeile dargestellt werden?
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#7
Name              Umsatz 2018          Umsatz 2017        Umsatz 2016      Umsatz 2015

Meier GmbH     100000 €                15000 Euro           17000 Euro        12000 Euro

So solls am Ende aussehen. Muss gar nichts addiert werden :)
Antwortento top
#8
Also dann so....


Arbeitsblatt mit dem Namen 'Tabelle1'
HIJKLM
2GesammtumsatzUmsatz 2018Umsatz 2017Umsatz 2016Umsatz 2015Umsatz 2014
3Meier GmbH90000015000170001200001300000

ZelleFormel
I3=SUMMEWENN($A:$A;$H$3;B:B)
J3=SUMMEWENN($A:$A;$H$3;C:C)
K3=SUMMEWENN($A:$A;$H$3;D:D)
L3=SUMMEWENN($A:$A;$H$3;E:E)
M3=SUMMEWENN($A:$A;$H$3;F:F)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#9
Moin,
falls du eine 2010-Pro Version hast, kannst du Power Query als Add-On installieren. Damit sollte es auch bei mehreren Tausend Firmennamen kein Problem sein.
Wenn du es genau wissen willst, liefere 3 kleine (anonymisierte) Mustermappen und das Rätselraten hat vermutlich ein Ende.

Mit den Daten aus #3 klappt es auf jeden Fall.
Beste Grüße
  Günther

Excel-ist-sexy.de
  …schau doch mal rein!
Der Sicherheit meiner Daten wegen lade ich keine *.xlsm bzw. *.xlsb- Files mehr herunter! -> So geht's ohne!
Antwortento top
#10
Habe ich leider nicht, bin nur Azubi in einer mittelständigen Firma, da kann ich aufgrund fehlender Admin-Rechte auch kein Addon dazuholen.

Frogger ich denke deine Lösung gibt mir keine Antwort auf meine Frage. Ich will einfach die Tabellen in eine zusammenbringen, ich will keine Verweise, nur die Formatierung soll geändert bzw. Dupletten gelöscht werden.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste