Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Einige Fragen
#1
Guten Abend zusammen,

bin neu hier im Forum und habe schon die Suchfunktion genutzt.

Ich bin dabei eine Rechnungsvorlage in Excel zu erstellen und stoße an meine Grenzen.
Vorab, bin blutiger Anfänger, also bitte so schreiben das es verständlich ist.

1) Sollte eine Rechnung so viele Positionen haben das es die Zeile 45 überschreitet, das dann automatisch ein Übertrag (alle Positionen gezählt werden) gebildet wird und Summe, MwSt und G-Summe ans Ende der nächsten Seite rutschen, wie schaffe ich das?

2) Auch hier geht es um die Rechnungspositionen: Wenn angenommen vier Positionen belegt sind, sollen sich diese abwechselnd Färben, weiß, grau, weiß, grau,  färben, wenn kein Inhalt da ist dann natürlich weiß bleiben...

vielen Dank vorab für eure Antworten

Gruß
Martin
Antwortento top
#2
Hallo,

einfacher Ansatz:

1) Füge auf dem Zweiten Blatt zur Summe der Einzelpositionen das zweiten Blattes die Summe des ersten Blattes hinzu. Hast Du auf dem zweiten Blatt keine Positionen, steht dort die gleiche Zahl wie auf dem ersten Blatt.

2)Kennst Du Dich mit bedingter Formatierung aus? Du musst zwei Sachen prüfen, im Prinzip: =UND(A1<>"";REST(ZEILE();2)=0) --> statt A1 die Zelle, die Maß der Dinge ist Smile
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#3
Vielen Dank.

Zu 1.:

Die Chance steht gut das ich mich sehr ungeschickt ausgedrückt habe Big Grin 

Habe ein Bild hinzugefügt;

Also. sollte es so viele Positionen geben das diese bis zu Zeile 42 reichen, sollen dann die Zeilen 46, 47 und 48 verschwinden und an das Ende der nächsten Seite verschoben werden.

Bis jetzt sind die Zeilen 46,47,48, relativ, da es ja sein kann das ich mehrere Zeilen in einer Zelle habe und somit die Tabelle verschiebe. Deshalb habe ich die drei Zellen markiert und einen Namen definiert, jetzt musste man nur noch, unabhängig von Zellennummer, den vordefinierten Bereich fixieren, sodass es unabhängig von Anzahl der Zellen, immer unten ist.


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#4
Hallo,

und warum stellst du nicht deine Datei hier ein? Mit einem "Bildchen" kann niemand etwas anfangen.

Mal als Lösungsansatz:
Auf Seite 1 deiner Rechnungsvorlage, Zelle A46, folgende Formel:
=WENN(A45="";"Summe:";"Zwischensumme:")

Die Zwischensumme dann auf Blatt 2 der Rechnungsvorlage übernehmen.

Gruß Werner
Antwortento top
#5
du hast recht, hier die Datei.

Bin wirklich Laie und stoße an meine Grenzen..

vg martin


Angehängte Dateien
.xlsx   re - Kopie.xlsx (Größe: 28,39 KB / Downloads: 8)
Antwortento top
#6
Hier eine VBA-Lösung... Bitte Lade die Datei runter, öffne die Datei und Klicke den Reiter "Ansicht" oben in der Menüleiste! Dort findest du ganz rechts "Makros" , wenn du darauf klickst öffnet sich eine liste dort wählst du "Makros Anzeigen" im Folgenden Fenster markierts du "Modul1.Summe" und wählst rechts "Optionen" im Folgenden Fenster gibst du eine Tastenkombination ein die für dich vorteilhaft ist (Die du nicht regelmäßig für etwas anderes Verwendest)! Ctrl = "Strg" auf deiner Tastatur! Nun wählst du in Spalte "A" die Zelle in der "Summe" stehen soll ( nur einmal anklicken ) und drückst die Tastenkombination! Und Hokuspokus....

Und für alle anderen ( die sich damit auskennen ) hier der VBA- Code:



Code:
Sub Summe()

ActiveSheet.Range(ActiveCell, ActiveCell.Offset(0, 5)).Borders(xlEdgeTop).LineStyle = xlContinuous
ActiveCell.Value = "Summe"
ActiveCell.Offset(1, 0).Value = "MwSt 19%"
ActiveCell.Offset(2, 0).Value = "Summe gesammt"
ActiveCell.Offset(2, 0).Font.Bold = True

ActiveCell.Offset(0, 5).FormulaLocal = "=SUMME(F20:F" & ActiveCell.Row - 1 & ")"
ActiveCell.Offset(1, 5).NumberFormat = "#,0.00 ?"
ActiveCell.Offset(1, 5).FormulaLocal = "=F" & ActiveCell.Row & "/100*19"
ActiveCell.Offset(1, 5).NumberFormat = "#,0.00 ?"
ActiveCell.Offset(2, 5).FormulaLocal = "=SUMME(F" & ActiveCell.Row & ":F" & ActiveCell.Row + 1 & ")"
ActiveCell.Offset(2, 5).NumberFormat = "#,0.00 ?"


End Sub


Angehängte Dateien
.xlsm   re - Kopie (3).xlsm (Größe: 40,54 KB / Downloads: 4)
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#7
(02.09.2018, 15:50)Frogger1986 schrieb: Hier eine VBA-Lösung... Bitte Lade die Datei runter, öffne die Datei und Klicke den Reiter "Ansicht" oben in der Menüleiste! Dort findest du ganz rechts "Makros" , wenn du darauf klickst öffnet sich eine liste dort wählst du "Makros Anzeigen" im Folgenden Fenster markierts du "Modul1.Summe" und wählst rechts "Optionen" im Folgenden Fenster gibst du eine Tastenkombination ein die für dich vorteilhaft ist (Die du nicht regelmäßig für etwas anderes Verwendest)! Ctrl = "Strg" auf deiner Tastatur! Nun wählst du in Spalte "A" die Zelle in der "Summe" stehen soll ( nur einmal anklicken ) und drückst die Tastenkombination! Und Hokuspokus....

Und für alle anderen ( die sich damit auskennen ) hier der VBA- Code:



Code:
Sub Summe()

ActiveSheet.Range(ActiveCell, ActiveCell.Offset(0, 5)).Borders(xlEdgeTop).LineStyle = xlContinuous
ActiveCell.Value = "Summe"
ActiveCell.Offset(1, 0).Value = "MwSt 19%"
ActiveCell.Offset(2, 0).Value = "Summe gesammt"
ActiveCell.Offset(2, 0).Font.Bold = True

ActiveCell.Offset(0, 5).FormulaLocal = "=SUMME(F20:F" & ActiveCell.Row - 1 & ")"
ActiveCell.Offset(1, 5).NumberFormat = "#,0.00 ?"
ActiveCell.Offset(1, 5).FormulaLocal = "=F" & ActiveCell.Row & "/100*19"
ActiveCell.Offset(1, 5).NumberFormat = "#,0.00 ?"
ActiveCell.Offset(2, 5).FormulaLocal = "=SUMME(F" & ActiveCell.Row & ":F" & ActiveCell.Row + 1 & ")"
ActiveCell.Offset(2, 5).NumberFormat = "#,0.00 ?"


End Sub
Vielen Dank!
Antwortento top
#8
Bitteschön...
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#9
Hallo captain,

Du brauchst nicht die ganze Nachricht zu zitieren. Wenn Du Dich bei einem speziellen Helfer bedanken willst reicht es, ihn nur anzusprechen. Unter den Beiträgen kannst Du Dich übrigens auch bei den Helfern bedanken Smile
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste