Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Urlaubstage innerhalb von Betriebsferien
#1
Hallo Ihr in NAH und FERN,
habe ein Problem und benötige Hilfe.

Ich habe 2 Tabellenblätter, "Mitarbeiter-Urlaub" & "Betriebsurlaub"

in beiden befinden sich Tabellen mit den Überschriften "von" und "bis", in dem Tabellenblatt "Mitarbeiter-Urlaub" folgt noch die Spalte "Innerhalb der Betriebsferien".

Wenn ich nun den Mitarbeiter-Urlaub eingebe, soll überprüft werden, ob sich Daten des Mitarbeiter-Urlaubs innerhalb des Betriebsurlaubs befinden.

Kann jemand helfen ?

LG. Herzenslicht
Antwortento top
#2
Hi,

eine kleine Beispieltabelle würde beim Helfen helfen. Wink http://www.clever-excel-forum.de/Thread-...ng-stellen
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Hallo
du brauchst doch nur die Tage berechnen die innerhalb der Betriebsferien fallen
Das Ergebnis kannst du dann in einer Wenn()-Formel einfügen und auswerten.

Beispiel:

BU Beginn Urlaub
EU Ende Urlaub
BB Beginn Betriebsurlaub
EB Ende Betriebsurlaub


=MAX(0;MIN(EU+1;EB+1)-MAX(BU;BB))
Antwortento top
#4
Hallöchen,

oder so:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
1Betriebsurlaub:Mein UrlaubIst im WU
2Beginn30. JunBeginn25. JunDrin
3Ende21. JulEnde14. Jul

ZelleFormel
E2=WENN(ODER(UND(D2<=B2;D3<=B2);(UND(D2>=B3;D3>=B3)));"Draußen";"Drin")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#5
Vielen Dank für die Antworten.

Wenn es neben einander steht ist es mir klar.
Dann gibt es zahlreiche Möglichkeiten.

Aber wenn es in unterschiedlichen Tabellen und unterschiedlichen Zeilen steht, wie dann ?
Es müssten ja dann die Tabellen durchsucht werden.

Anbei die Datei.

LG. HERZENSLICHT


Angehängte Dateien
.xlsx   MITARBEITER-ANWESENHEIT.xlsx (Größe: 48,2 KB / Downloads: 4)
Antwortento top
#6
Hallo, man könnte mit meiner Formel einfach die Summe der Tage berechnen (für jeden Teil-Betriebsurlaub ein Ergebnis)

Für Betriebsurlaub Anfang_1 bis 4 und Einde_1 bis 4 habe ich Namen vergeben.
Gruß Holger


Angehängte Dateien
.xlsx   MITARBEITER-ANWESENHEIT.xlsx (Größe: 51,13 KB / Downloads: 11)
[-] Folgende(r) 1 Benutzer sagt Danke an echo für diesen Beitrag:
  • Herzenslicht
Antwortento top
#7
Hallöchen,

Du kannst das mit verschiedenen Tabellen einfach dadurch ausprobieren und erreichen, indem Du erst mal zumindest beispielhaft was auf einer Tabelle anlegst und die relevanten Daten dann auf der einen Tabelle ausschneidest und in die andere einfügst. Da passen sich die Fomeln automatisch an. Hab ich mal gemacht und Excel liefert mir dann das:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
1Mein UrlaubIst im WU
2Beginn25. JunDrin
3Ende14. Jul

ZelleFormel
E2=WENN(ODER(UND(D2<=Tabelle2!B2;D3<=Tabelle2!B2);(UND(D2>=Tabelle2!B3;D3>=Tabelle2!B3)));"Draußen";"Drin")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#8

.xlsx   180901 Ueberschneidungen von Zeiten mehrfach.xlsx (Größe: 10,03 KB / Downloads: 10)
Antwortento top
#9
VIELEN DANK für die zahlreichen Antworten.
Ein ganz besonderes DANKESCHÖN an ECHO.
Das war für mich die Hilfe, nach der ich gesucht haben.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste