Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Automatische Auswahl und Addierung einer Tabelle nach Zelleninhalt
#1
Hallo zusammen,
 
ich habe eine etwas kniffligere Frage (jedenfalls erscheint sie mir knifflig) und hoffe, man kann mir hier helfen. Leider habe ich nirgendwo sonst etwas gefunden, das mir helfen kann. Was unter anderem darauf zurückzuführen ist, dass ich nicht weiß, wonach genau ich suchen sollte. Falls da also jemand einen Link für mich hätte, der mir weiterhilft, wäre ich dafür auch sehr dankbar!
Aber jetzt zum eigentlichen Problem:
 
Ich untersuche für eine empirische Studie die Zwischenrufe im Bundestag. Dafür habe ich eine recht umfangreiche Tabelle angelegt (Stand jetzt: 1054 Zeilen, Spalten bis CT). Diese Tabelle ist so aufgeteilt (siehe Beispielstabelle im Anhang), dass horizontal jeweils eine Sitzung behandelt wird. Dabei steht am Anfang eine Tabelle mit der automatischen Summe aller Zwischenrufe dieser Sitzung, aufgeschlüsselt nach Fraktion des Zwischenrufers sowie Fraktion des Sprechers, bei dem dazwischengerufen wurde. Danach geht es weiter mit den einzelnen Themen, die in der Sitzung behandelt wurden. Wiederum aufgeschlüsselt nach Zwischenrufer und Sprecher. Dabei sind auch die Initiatoren der jeweiligen Debatte mit angegeben.
Vertikal geht es dann mit der nächsten Sitzung weiter.
Was ich nun gerne möchte, ist eine Möglichkeit, dass Excel mir eine Aufstellung der Zwischenrufe nach Initiator erstellt. Soll heißen, ich wähle (in einem Drop-Down-Menü oder ähnlichem) aus, dass ich nur die Zahlen von Debatten angezeigt haben will, die von den Grünen eingebracht werden. Excel sollte dann die jeweiligen Tabellen durchsuchen und mir nur die ausgeben, die mit Initiator: Grüne bezeichnet sind.
 
Ich hoffe, ich habe das einigermaßen verständlich erläutert und es gibt dafür überhaupt eine Funktion J
 
Bei Fragen einfach Fragen!
 
 
P.S: Die Daten, die noch in der Beispielstabelle stehen, sind alle öffentlich in den Plenarprotokollen einzusehen, daher habe ich sie nicht gelöscht


Angehängte Dateien
.xlsx   20180604Auswertungstabelle.xlsx (Größe: 29,26 KB / Downloads: 9)
Antwortento top
#2
Hinweis auf fehlende Tabelle gelöscht.
Gruß
Michael
Antwortento top
#3
Hallo

In der Beispielmappe ist kein einziger Zwischenruf eingetragen.
Außerdem ist die Struktur für'n A***.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#4
Hallöchen,

Du könntest das so lösen. In irgendeine Zelle gibst Du mit Hilfe der Datenprüfung Deine Auswahl ein - die Liste der auszuwählenden Initiatoren schreibst Du irgendwo anders hin - und daneben ist dann die Formel für die Auswertung. Die Bereiche musst Du eventuell noch anpassen, dabei auf die eine Spalte Versatz achten.

Übrigens, L34+L35+...+L39 ginge einfacher mit =SUMME(L34:L39)

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
18Alterspräsident2
19
20
21
22
23Alterspräsident
24Grüne

ZelleFormel
B18=SUMMENPRODUKT((J1:AAA100="Initiator:")*(ISTZAHL(FINDEN(A18;K1:AAB100))))

ZelleGültigkeitstypOperatorWert1Wert2
A18Liste=$A$23:$A$24
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
  • smogpaster
Antwortento top
#5
Hi schauan,

danke, ich probiere das malSmile

Liebe Grüße
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste