Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summe bilden mit wenn, dann ... ?
#1
Hallo liebe Fachmänner, ich habe ein Problem und weiß nicht wie ich es lösen könnte. Vielleicht könnt ihr mir helfen.

Ich benötige zwei Summen. Die Spalte B zu addieren ist ja kein Problem.

Schwierig wird es bei der Spalte A. Hier sollen nur die Beträge summiert werden, bei denen in Spalte B eine Summe steht (größer 0).

-          Also z.B. wenn B3 größer 0, dann Summe von A3 addieren. Und dies dann von A2 bis A3000 und B2 bis B3000.


Im Beispiel müsste also bei A2 bis A6 30€ rauskommen und bei B2 bis B6 250€.

Hat jemand eine Idee?
Danke schon mal vorab für eure Bemühungen.

Viele Grüße der ahnungslose Andy  Huh


?mage
Antwortento top
#2
Hallo,

du brauchst dafür die Summewennformel:
Code:
=SUMMEWENN(B1:B4;">"&0;A1:A4)

Wenn du das nächste Mal kein Bild, sondern die Datei postest, kriegst du auch die passende Formel von mir. Aber ich denke, du kannst diese auf deinen Aufbau anpassen.
Viele Grüße,
Matthias

-------------------------------------------------------------------------------------------

Man muß nicht alles wissen, man muß nur wissen, wie man die Lösung findet.
[-] Folgende(r) 1 Benutzer sagt Danke an Matthias84 für diesen Beitrag:
  • Andy16515
Antwortento top
#3
Thumbs Up 
Hallo Matthias84,

das funktioniert. Du bist genial.


VIELEN DANK !!!  23
Antwortento top
#4
Jetzt noch eine Frage für mich, weil ich nun überlege einen großen Umbau zu starten.

Kann man die Formel

Code:
=SUMMEWENN(B1:B4;">"&0;A1:A4)

noch ein Arument - in dem Fall eine Datumseinschränkung - ergänzen?

Zum Beispiel errechnet er nur die Summen aus A2 bis A10 wenn in C2 bis C10 der Monat "März" steht?


?mage

Danke für die Hilfe !!
Antwortento top
#5
(31.08.2018, 10:23)Matthias84 schrieb: Hallo,

...
Wenn du das nächste Mal kein Bild, sondern die Datei postest, kriegst du auch die passende Formel von mir...


... von mir auch ...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#6
Hi Matthias,

eine Möglichkeit:

Arbeitsblatt mit dem Namen 'Tabelle6'
ABC
1ErstattungForderungMärz
2
3510März
4220März
510Mai
61520März
720März
8
920270

ZelleFormel
A9=SUMMEWENNS($A$3:$A$7;$B$3:$B$7;">"&0;$C$3:$C$7;C1)
B9=SUMME(B3:B7)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Du solltest lediglich die (gelb markierte) Hilfszelle einfügen. Damit bleibt die Formel flexibel.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Andy16515
Antwortento top
#7
Hallo, oder (mal wieder mit INDEX() - als Alternative...)

Code:
=SUMME(INDEX(A3:A7*(B3:B7>0)*(C3:C7=C1);))
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Andy16515
Antwortento top
#8
Thumbs Down 
Perfekt - vielen Dank.

Jetzt hab ich richtig viel Arbeit 23 28
Antwortento top
#9
Thumbs Up 
Funktioniert ebenfalls perfekt - Vielen Dank   23 28
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste