Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Richtige Excel Formel Summewenn oder Summeprodukt?
#1
Hallo zusammen,
ich benötige Hilfe bei der Verformelung einer Excel-Tabelle. Folgende Ausgangssituation: Ich habe in der Spalte A einen Bedingungswert (hier soll das Jahr 2018 gefunden werden), in Spalte B eine weitere Bedingung (hier soll der Wert "leer" gefunden werden) und in Spalte C die dritte Bedingung (hier soll die Zahl 32 gefunden werden). Sind alle drei Bedingungen erfüllt, sollen die Werte aus Spalte D addiert werden und die Formel die Summe ausgeben.
Folgende Formel habe ich getestet, allerdings erhalte ich als Wert 0:
=SUMMENPRODUKT((Sheet1!A2:A1691="2018") * (Sheet1!B2:B1691="") * (Sheet1!C2:C1691="32") * (Sheet1!D2:D1691))

Wer kann mir helfen? Das Thema ist leider ziemlich dringend.
Antwortento top
#2
Hallo,

ungetestet (und ich gehe davon aus, dass in Spalte A ein Datum in der Form TT.MM.JJJ steht):

=SUMMENPRODUKT((JAHR(Sheet1!A2:A1691)=2018)*(Sheet1!B2:B1691="")*(Sheet1!C2:C1691=32)*(Sheet1!D2:D1691))

Nachtrag: Und wenn in Spalte A kein 'richtiges' Datum steht:

=SUMMENPRODUKT((Sheet1!A2:A1691=2018)*(Sheet1!B2:B1691="")*(Sheet1!C2:C1691=32)*(Sheet1!D2:D1691))

Zitat:Das Thema ist leider ziemlich dringend.


Das denkt jeder von seinem Problem.
Gruß
Peter
Antwortento top
#3
Hola,

wenn du die Zahlen in "" setzt, sucht Excel nach TEXT nicht nach ZAHL.

Gruß,
steve1da
Antwortento top
#4
Hi,

und wenn es noch so dringend ist, eine Mustertabelle würde die Bearbeitung erleichtern!


Code:
=SUMMENPRODUKT((Sheet1!A2:A1691=2018) * (Sheet1!B2:B1691="") * (Sheet1!C2:C1691=32) ;Sheet1!D2:D1691)
=SUMMEwenns(Sheet1!D2:D1691;Sheet1!A2:A1691;2018;Sheet1!B2:B1691;"";Sheet1!C2:C1691;32)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#5
Super! Danke! Klappt!

Habe jetzt diese Formel: =SUMMEwenns(Sheet1!D2:D1691;Sheet1!A2:A1691;2018;Sheet1!B2:B1691;"";Sheet1!C2:C1691;32)

Was muss eingeben, wenn anstatt des Jahres 2018, hier ein nur Werte mit einem Datum >=01.08.2018 berücksichtigt werden sollen?
Antwortento top
#6
Hola,


Code:
=SUMMEwenns(Sheet1!D2:D1691;Sheet1!A2:A1691;">="&G1;Sheet1!B2:B1691;"";Sheet1!C2:C1691;32)

In G1 steht der 01.08.2018.

Gruß,
steve1da
Antwortento top
#7
Hi,

oder so:


Code:
=SUMMEwenns(Sheet1!D2:D1691;Sheet1!A2:A1691;">="&--"1.8";Sheet1!B2:B1691;"";Sheet1!C2:C1691;32)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#8
Danke! Aber dann kommt Wert 0 obwohl Werte vorhanden sind.

Folgende Formel nutze ich:

=SUMMEwenns(Sheet1!D2:D1691;Sheet1!A2:A1691;">="&G1;Sheet1!B2:B1691;"";Sheet1!C2:C1691;32)
Antwortento top
#9
Hola,

eine Beispieldatei (kein Bild) könnte hier weiterhelfen.

Gruß,
steve1da
Antwortento top
#10
Schon erledigt. Hatte einen Tippfehler.

Was schreibe ich in die Formel, wenn die Summe errechnet werden soll, wenn in der Spalte B anstatt des Wertes "leer" hier ein beliebiger Wert vorhanden sein soll?
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste