Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Werte aus Tabelle löschen durch Abgleich
#1
Hey Leute,

ich habe eine Tabelle die wie folgt aufgebaut ist:

Geschäftsnummer:   Wert1:   Wert2: .......
10                          50          75
15                          20          10
17                          80          25
usw....


Nun sind in der Tabelle aber leider einige Datensätze die dort nicht hinein gehören.

Ich habe nun eine Zweite Tabelle die genau so aufgebaut ist.
Dort steht nun z.B. die Geschäftsnummer 15. Das bedeutet, dass der Datensatz (Zeile) mit der Geschäftsnummer 15 entfernt werden muss.

Es müssen knapp 300 Datensätze entfernt werden. Da ich das nicht manuell machen möchte suche ich nun einen Weg die Datensätze automatisch löschen zu lassen.

Am liebsten wäre es mir, wenn nicht nur die Daten gelöscht werden, sondern die komplette Zeile entfernt wird.

Hat jemand eine Ahnung wie das geht?
Antwortento top
#2
Hi Max,

ich würde mit ZÄHLENWENN() neben deinen Daten in einer Hilfsspalte z.B ein "x" eintragen lassen, nach diesem filtern und die gefilterten Zeilen mit STRG--(minus) entfernen.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • StrammerMax
Antwortento top
#3
Hallo,

mach eine Hilfsspalte mit
Code:
=WENN(ISTNV(SVERWEIS(A2;Tabelle2!$A$2:$A$300;1;0));"";"x")

Die filterst du dann mit dem Autofilter und löschst die Zeilen.
Schöne Grüße
Berni
[-] Folgende(r) 1 Benutzer sagt Danke an MisterBurns für diesen Beitrag:
  • StrammerMax
Antwortento top
#4
Danke, perfektSmile
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste