Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zelleninhalt zurückgeben
#1
Hallo
Ich möchte in einer Tabelle schauen welche Punkte bestimmte Koordinaten besitzen und dann den Namen aus Spalte 1 zurück geben.
Z.B. möchte ich wissen welche Zeile jeweils die Koordinaten (1/1) und besitzt. Dazu soll mir Bravo und Foxtrot in einer Zelle ausgegeben werden.
Außerdem ist wichtig, dass (5/1) und (1/5) nicht verwechselt werden.

Man könnte ein extra Feld einrichten indem man die Koordinaten eingibt und mit der unteren Tabelle vergleicht.

Vielen Lieben Dank bereits im Voraus.
?mage


Angehängte Dateien
.xlsx   Forum.xlsx (Größe: 8,43 KB / Downloads: 6)
Antwortento top
#2
Ist doch eigentlich eine klassische Aufgabe für den Autofilter.
Und muss dann wirklich in einer einzelnen Zelle "Bravo, Foxtrott" stehen? Wenn ja, was versprichst du dir davon?
Oder reicht es, wenn die untereinander/nebeneinander in jeweils einer einzelnen Zelle stehen?
Schöne Grüße
Berni
[-] Folgende(r) 1 Benutzer sagt Danke an MisterBurns für diesen Beitrag:
  • Excelsior940
Antwortento top
#3
Hola,

warum muss das alles in einer Zelle ausgegeben werden?

Code:
=WENNFEHLER(INDEX($A$2:$A$7;AGGREGAT(15;6;ZEILE($A$2:$A$7)-1/(($B$2:$B$7=1)*($C$2:$C$7=1));ZEILE(A1)));"")

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Excelsior940
Antwortento top
#4
Vielen Lieben Dank euch beiden für eure Antworten.

Ich kann verstehen, dass die Anwendung etwas überflüssig wirkt.
Dies findet in einer betrieblichen Excel Tabelle Anwendung deren Inhalt ich euch nicht erklären kann und somit wird auch das Verständnis dafür fehlen.

@steve1da

Super! Das ist es wonach ich gesucht habe. Allerdings wird da immer nur das erste zutreffende Ergebnis in der Tabelle ausgegeben.
Also nur Bravo und nicht mehr Foxtrot.
Kann man da eine Art schleife durchlaufen lassen?
Wie kann man mehrere Ergebnisse ausgeben? Am besten sogar in einer anderen Zelle.
Antwortento top
#5
Hola,


Zitat:Wie kann man mehrere Ergebnisse ausgeben? Am besten sogar in einer anderen Zelle.

kopier die Formel mal nach unten Wink

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Excelsior940
Antwortento top
#6
(30.08.2018, 07:59)steve1da schrieb: kopier die Formel mal nach unten Wink

Gruß,
steve1da

aber dann steht wieder Bravo drin und nicht Foxtrot.
Das Tool sucht quasi von oben nach unten die Tabelle durch und nimmt immer das erste.
Aber es kann manchmal mehrere geben.
Antwortento top
#7
Hola,

wenn du die Formel nach unten ziehst erscheint zuerst Bravo und dann Foxtrott. Zumindest bei mir.
Du hast wahrscheinlich in beiden Zellen die gleiche Formel drin stehen.

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Excelsior940
Antwortento top
#8
JUHUU
Es geht
Dankeschön
Antwortento top
#9
(29.08.2018, 14:05)steve1da schrieb:
Code:
=WENNFEHLER(INDEX($A$2:$A$7;AGGREGAT(15;6;ZEILE($A$2:$A$7)-1/(($B$2:$B$7=1)*($C$2:$C$7=1));ZEILE(A1)));"")

Gruß,
steve1da

Für was stehen die 15 und 6? nach dem ersten AGGREGAT
Antwortento top
#10
Hola,

15 steht für KKLEINSTE(), die 6 bedeutet das Fehlerwerte ignoriert werden.

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste