Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Einfache Tabellen Ausgabe mit zwei Eingabewerten
#1
Guten Morgen liebes Forum.

Ich hab leider wenig Erfahrung mit Excel und wollte hier mal nachfragen, ob mir jemand kurz helfen kann.  

Kontext:

Wir messen Temperatur und Dichte in einem Reaktor und müssen damit dann unter Eingabe der beiden Werte den Konzentrationsanteil des Gemisches ausgeben. 

Ich soll nun ein Excel Sheet erstellen in dem ich zwei Eingabewerte habe (Dichte, Temperatur) und damit dann eine Ausgabe (Konzentration) aus einer im Sheet vorhandenen Tabelle ausgeben soll. Die Eingabewerte müssen, wenn Sie nicht exakt mit denen aus der Tabelle übereinstimmen sollten, linear interpoliert werden. Sodass auch der Ausgabewert dementsprechend interpoliert ist. Also sozusagen eine "doppelte Interpolation".
(interpoliert = den Wert ausgeben der zwischen zwei aufgetragenen Werten liegt mit Hilfe einer Geraden)

Die Tabelle aus der ausgelesen werden soll ist so aufgebaut, dass die Temperatur ("x-Achse") von 20 bis 35 in 5er Schritten und die Konzentration ("Y-Achse") von 1% bis 100% in 1er Schritten läuft. Die Konzentration ist abhängig von beiden Faktoren und ist dementsprechend in der "Mitte" als Inhalt der Tabelle. 

Die Tabelle die ich in Excel übertragen habe ich unten eingefügt.
[Bild: Property01.htm]
http://www.separationprocesses.com/Cours...erty01.htm)

Hoffentlich kann mir wer helfen  Undecided

Freundliche Grüße,
Driz


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hi,

eine Tabelle/Datei wäre hilfreicher als ein Bild! Mit Musteraufgabe/ -lösung!
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Driz
Antwortento top
#3
Hi,

das, was du als ScrShot eingestellt hast, lade bitte als .xlsx hoch. Trage dazu bitte ein Beispiel mit Wunschergebnis ein.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Driz
Antwortento top
#4
Danke schon mal für die schnellen Antworten.

ich hab die Excel-Datei mit der Tabelle und in der ich arbeite angefügt.

Beispiel Ergebnisse/Musterergebnisse sind in der zweiten Exceldatei angegeben.

freundliche Grüße,

Driz


Angehängte Dateien
.xlsx   Kopie von Water-EtOH Temp,Density, Conc(1626).xlsx (Größe: 15,55 KB / Downloads: 2)
.xlsx   Kopie von density composition temperature data(1631).xlsx (Größe: 12,21 KB / Downloads: 2)
Antwortento top
#5
Hi,

das ist mit einer einfachen Formel nicht zu lösen, möglicherweise mit diesem Aufbau gar nicht. Allerdings habe ich gerade nicht die Zeit, mich intensiv damit zu befassen. Problem ist, dass die Interpolation der Temperatur von Zeile zu Zeile auf anderen Differenzen aufbaut. Deine Musterlösung scheint mir auch falsch zu sein, 4% sollten es sein!

Vielleicht so:


Code:
=AGGREGAT(15;6;ZEILE(INDEX($C$7:$F$7;VERGLEICH(KÜRZEN(K9;-1);$C$6:$F$6;0)):INDEX($C$107:$F$107;MIN(4;VERGLEICH(KÜRZEN(K9;-1);$C$6:$F$6;0)+1)))/(INDEX($C$7:$F$7;VERGLEICH(KÜRZEN(K9;-1);$C$6:$F$6;0)):INDEX($C$107:$F$107;MIN(4;VERGLEICH(KÜRZEN(K9;-1);$C$6:$F$6;0)+1))<$K$10);1)-7


Musst Du mal testen.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Driz
Antwortento top
#6
Hi Opa Edgar,

Hab mich leider auch vertan.

Die richtigen Musterdateien/Lösungen sind in der zweiten Excel Datei hinterlegt. 

Der Code funktioniert fast. Das Ergebnis geht in die richtige Richtung liegt aber ca einen Prozent daneben.

Danke, dass du dich damit trotzdem beschäftigt hast.

Grüße Driz.


Angehängte Dateien
.xlsx   Water-EtOH Temp, Den,Conc.xlsx (Größe: 16,02 KB / Downloads: 1)
.xlsx   Versuchsergebnisse_Musterlösung.xlsx (Größe: 12,13 KB / Downloads: 1)
Antwortento top
#7
Hi,

ich denke, die Formel von mir ist zwar relativ genau, hat aber noch kleine Fehler (ca. 1%), die ich so auf die Schnelle nicht ausmerzen kann. Auf 0,5% genau geht so gar nicht.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Driz
Antwortento top
#8
Hi,

etwas genauer, aber immer noch mit Abweichungen:


Code:
=VERGLEICH(B19%/10+(SVERWEIS(VERGLEICH(B19%/10;INDEX(Tabelle1!$C$7:$F$107;;(KÜRZEN(C19/5;0)*5-15)/5);-1)-1;Tabelle1!$B:$F;(KÜRZEN(C19/5;0)*5-15)/5;0)-SVERWEIS(VERGLEICH(B19%/10;INDEX(Tabelle1!$C$7:$F$107;;(KÜRZEN(C19/5;0)*5-15)/5);-1);Tabelle1!$B:$F;(KÜRZEN(C19/5;0)*5-15)/5+1;0))/5*(C19-KÜRZEN(C19/5;0)*5);INDEX(Tabelle1!$C$7:$F$107;;(KÜRZEN(C19/5;0)*5-15)/5);-1)
Arbeitsblatt mit dem Namen 'Sheet1'
ABCDEFGHIJKLMNOPQR
1983827,230,812976,3312992,230,8 0,80,83164 10,97897 0,80,9952
20 30,82473 30,97573 30,99194
21 0,8283060,001106 0,9769480,000648 0,9927220,000522
22 8383 1212 22

ZelleFormel
A19=VERGLEICH(B19%/10+(SVERWEIS(VERGLEICH(B19%/10;INDEX(Tabelle1!$C$7:$F$107;;(KÜRZEN(C19/5;0)*5-15)/5);-1)-1;Tabelle1!$B:$F;(KÜRZEN(C19/5;0)*5-15)/5;0)-SVERWEIS(VERGLEICH(B19%/10;INDEX(Tabelle1!$C$7:$F$107;;(KÜRZEN(C19/5;0)*5-15)/5);-1);Tabelle1!$B:$F;(KÜRZEN(C19/5;0)*5-15)/5+1;0))/5*(C19-KÜRZEN(C19/5;0)*5);INDEX(Tabelle1!$C$7:$F$107;;(KÜRZEN(C19/5;0)*5-15)/5);-1)
K19=C19-KÜRZEN(C19/5;0)*5
L19=SVERWEIS(VERGLEICH(B19%/10;INDEX(Tabelle1!$C$7:$F$107;;(KÜRZEN(C19/5;0)*5-15)/5);-1)-1;Tabelle1!$B:$F;(KÜRZEN(C19/5;0)*5-15)/5;0)
K20=(KÜRZEN(C19/5;0)*5-15)/5
L20=SVERWEIS(VERGLEICH(B19%/10;INDEX(Tabelle1!$C$7:$F$107;;(KÜRZEN(C19/5;0)*5-15)/5);-1);Tabelle1!$B:$F;(KÜRZEN(C19/5;0)*5-15)/5+1;0)
K21=B19%/10+L21
L21=(L19-L20)/5*K19
K22=VERGLEICH(K21;INDEX(Tabelle1!$C$7:$F$107;;K20);-1)
L22=VERGLEICH(B19%/10+(SVERWEIS(VERGLEICH(B19%/10;INDEX(Tabelle1!$C$7:$F$107;;(KÜRZEN(C19/5;0)*5-15)/5);-1)-1;Tabelle1!$B:$F;(KÜRZEN(C19/5;0)*5-15)/5;0)-SVERWEIS(VERGLEICH(B19%/10;INDEX(Tabelle1!$C$7:$F$107;;(KÜRZEN(C19/5;0)*5-15)/5);-1);Tabelle1!$B:$F;(KÜRZEN(C19/5;0)*5-15)/5+1;0))/5*(C19-KÜRZEN(C19/5;0)*5);INDEX(Tabelle1!$C$7:$F$107;;(KÜRZEN(C19/5;0)*5-15)/5);-1)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Driz
Antwortento top
#9
Danke Opa Edgar, dass Sie ihre Zeit nochmal geopfert haben. 

Sie meinten am Anfang dieses Threads, dass es eventuell mit dieser Formatierung/Layout nicht möglich ist einen genauen Wert zu erzielen. Wie müsste man es denn verändern, damit es möglich ist?
Antwortento top
#10
Hi,

im Forum ist das Du angesagt.

Eine Interpolation bei veränderlichen Differenz, sowohl horizontal als auch vertikal ist äußerst problematisch. Mit normalen Formeln dürfte das wohl eher nicht möglich sein. Ich weiß nicht ob der Aufwand für eine Lösung noch in einem vertretbaren Rahmen liegt.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste