Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wieso rechnet Excel falsch ???
#1
Hallo zusammen,
ich habe ein kleines aber für mich nicht nachvollziehbares Problem.
Es schein so, dass Excel falsch rechnet. Ich weiß natürlich das das nicht wirklich geht und der Fehler sicherlich irgendwo anders liegt.
Jedoch kann ich es nicht nachvollziehen warum Excel in einer Berechnung ein "falsches" Ergebnis liefert.
In meinem Fall gibt Excel die Summe 314,70 Euro anstatt 314,64 Euro aus ???
Kann mir vielleicht einer von euch Profis sagen woran das liegen könnte?
Ich hänge die Beispieldatei  mal an. Es geht dort im Registerblatt "Mai 19" um die Zelle W29.

Vielen Dank
jokerjo1000


Angehängte Dateien
.xlsx   Testdatei.xlsx (Größe: 46,95 KB / Downloads: 12)
Antwortento top
#2
Hallo

Das Zahlenformat wirkt sich nur auf die Anzeige der Zahl aus und nicht auf den Inhalt.
Verwende eine der Funktionen zum Runden.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Leider weiß ich nicht was genau du damit meinst?
Ich habe es schon mit unterscihiedlichen Formaaten und Dezimalstellen probiert, jedoch ohne Erfolg.

Trotzdem erst einmal vielen Dank.
Antwortento top
#4
Hallo,

ändere die Formel in AC49 (und evtl. in anderen Zellen) so ab:

=RUNDEN(AC46*24;2)
Gruß
Peter
Antwortento top
#5
Hi Jo,

schau dir mal das Beispiel an; vllt. verstehst du dann, was shift-del gemeint hat:

Arbeitsblatt mit dem Namen 'Tabelle2'
ABCDEFG
1EndeAnfangStdStd-LohnLohnohne Formatgerundet
216:3008:0008:3015,50 €5,49 €5,4895833335,49
30,68750,3333333330,35415,55,49 €5,4895833335,49
416,588,515,5131,75 €131,75131,75

ZelleFormatWert
A2hh:mm0,6875
B2hh:mm0,333333333333333
C2hh:mm0,354166666666667
D2_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_-15,5
E2_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_-5,4896
E3_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_-5,4896
E4_-* #.##0,00 €_-;-* #.##0,00 €_-;_-* "-"?? €_-;_-@_-131,75

ZelleFormel
E2=C2*D2
F2=E2
G2=RUNDEN(C2*D2;2)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#6
Ich habe es wohl jetzt verstanden und probiere es mal aus.

Danke danke !!!
Antwortento top
#7
Photo 
(16.06.2018, 14:22)jokerjo1000 schrieb: Ich habe es wohl jetzt verstanden und probiere es mal aus.

Danke danke !!!

Hi,  Excel rechnet genauer als dein Taschrechner. Excel rechnet mit mehreren Stellen hinter dem Komma, dein Taschenrechner nur mit den 2 Stellen hinter dem Komma.


Taschenrechner            Excel
  16,63                          16,6333333
*18,92                         *18,9200000

 
314,64                       314,7026660


jack Blush
Antwortento top
#8
Hallo,

das Beispiel ist aber etwas unglücklich gewählt. Smile

Zitat:Taschenrechner Excel
16,63 16,6333333


Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
17 Dez.Stellen2 Dez.Stellen2 Dez.Stellen
2
316,6316,6316,63
418,9218,9218,92
5314,6396000314,64314,64
6-314,64-314,64-314,64
7-0,0004000-0,000,00

ZelleFormel
A5=A3*A4
C5=C3*C4
E5=RUNDEN(E3*E4;2)
A7=A5+A6
C7=C5+C6
E7=E5+E6

Spalte A: Formatiert als Zahl mit 7 Dez.Stellen
Spalte C und E: Formatiert als Zahl mit 2 Dez.Stellen
Der Wert in Zeile 6 wurde händisch eingegeben.

Excel rechnet intern mit 15 Stellen, auch wenn das Format nur mit 2 Dezimalstellen angegeben wurde - das ist gut zu erkennen am Ergebnis in C7.

Das Problem umgehen kann man eigentlich nur mit der Funktion Runden().

Es gibt in XL zwar noch in den Optionen die Einstellung "Genauigkeit wie angezeigt", allerdings halte ich das auch nicht unbedingt für eine gute Idee. Bei dem folgenden Beispiel ist 'Genauigkeit wie angezeigt' eingestellt.

Arbeitsblatt mit dem Namen 'Tabelle2'
ABC
13,333,33
26,666,66
39,9910,0
43,333,34

ZelleFormatWert
C30,010

ZelleFormel
A3=SUMME(A1:A2)
C3=SUMME(C1:C2)
A4=A3-A2
C4=C3-C2

In Spalte A ist das Ergebnis wie erwartet. Die Zelle C3 wurde formatiert mit einer Dezimalstelle.
Gruß
Peter
Antwortento top
#9
(17.06.2018, 01:03)happy-jack schrieb: Excel rechnet genauer als dein Taschrechner.

Moin!
Kommt drauf an.
"Mein", besser gesagt der Windows-"Taschen"-Rechner rechnet erheblich genauer als Excel.
Pi wird mit 32 Stellen angezeigt:

   

Im übrigen wird die Rechengenauigkeit von Excel absichtlich heruntergefahren!
Ansonsten würden auch schnellste Rechner bei den heutzutage möglichen riesigen Kalkulationsmodellen gehörig in die Knie gehen.

Two Cents,
Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#10
Versuche mal die Geschichte vom Schachbrett und dem Reis mit Excel auszurechnen.
Funktioniert nur über den Umweg mittels VBA (Ausgabe als TEXT)
Function Schachbrett() As String
Dim tmpPotenz As Variant
tmpPotenz = CDec(2 ^ 32)
Schachbrett = Format(CStr(CDec(tmpPotenz * tmpPotenz) - 1), "###,###,###,###,###,###,###")
End Function

A
1falsche Zahl
218.446.744.073.709.600.000
3
4korrekte Zahl
518.446.744.073.709.551.615

ZelleFormel
A2=2^64-1
A5=schachbrett()

Der Windows-Rechner hingegen schüttelt sich noch nicht mal und liefert eine Zahl, mit der man weiterrechnen kann:

   

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste