Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zeitspannen zählen
#1
Hallo liebe Gemeinschaft,

ich richte mich heute mal wieder mit einer Frage an euch. Nach unzähligen Versuchen schaffe ich es einfach nicht, die entsprechende Formel zu "bauen".

In Spalte C erscheinen laufend neue Zeitspannen aufgrund von neuen Buchungen. In Spalte A dazu die Kundenerstellung und in Spalte B das Datum der Buchung.

Diese Zeitspannen würde ich gern in Spalte F entsprechend zählen.

Erstes Beispiel: Es hat 104 Tage gedauert von der Kundenerstellung bis zur Buchung - Folglich soll dieser Kunde in Spalte F Zeile 5 gezählt werden.

Im Anhang meine Test-Version. Ich hoffe, dass sie aussagekräftig genug ist.

Ich bedanke mich rechtherzlich und wünsche allen noch einen schönen Abend!

Nick


Angehängte Dateien
.xlsx   Test.xlsx (Größe: 10,33 KB / Downloads: 11)
Antwortento top
#2
Wieviel tage hat denn dein Monat??

30
31
30,41

??

Das ist im ganzen gesehen eine wackelige Aussage..

aber ich habs ma so gelöst..


Angehängte Dateien
.xlsx   Test (1).xlsx (Größe: 17,26 KB / Downloads: 8)
Eine Menge reden, aber nichts sagen können viele...
[-] Folgende(r) 1 Benutzer sagt Danke an Frogger1986 für diesen Beitrag:
  • NickL
Antwortento top
#3

Hi Nick, nur am Rande, hier hättest du das gleiche Ergebnis mit
Code:
=B2-A2
bekommen.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • NickL
Antwortento top
#4


Ein Monat beträgt hier in der Formel 30 Tage
ABCDEFG
1ErstellungBuchungZeitspanneZeitspanneAnzahlAnteil
201.01.201815.04.2018104< 1 Monat114,3%
303.03.201804.03.20181< 2 Monaten114,3%
409.02.201816.03.201835< 3 Monaten114,3%
507.01.201824.05.2018137< 4 Monaten228,6%
603.03.201805.08.2018155< 5 Monaten114,3%
702.07.201802.09.201862< 6 Monaten114,3%
802.02.201805.05.201892< 7 Monaten00
9< 8 Monaten00
10< 9 Monaten00
11< 10 Monaten00
12< 11 Monaten00
13< 12 Monaten00
14Gesamt7

ZelleFormel
C2=TAGE(B2;A2)
F2=ZÄHLENWENNS($C$2:$C$8;">=" & (ZEILE()-2)*30;$C$2:$C$8;"<" & (ZEILE()-1)*30)
G2=F2/$F$14
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.03] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Willie
[-] Folgende(r) 1 Benutzer sagt Danke an Willie017 für diesen Beitrag:
  • NickL
Antwortento top
#5
(14.06.2018, 19:01)Frogger1986 schrieb: Wieviel tage hat denn dein Monat??
....
Das ist im ganzen gesehen eine wackelige Aussage...
Das steht doch in der Datei...!
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • NickL
Antwortento top
#6
Hallo liebe Gemeinschaft,

ich bin wie immer mehr als begeistert, wirklich! Vielen lieben Dank! Ich kann mit allen Varianten arbeiten.

Ob es 30 oder 31 Tage sind, das ist nicht so wild. Ich mache mir Gedanken dazu und ändere eure Lösungen dann eventuell minimal ab.

@Frogger1986: Danke, läuft genauso wie ich es mir vorgestellt habe.

@Günter: Vielen Dank, ich habe mich da strikt an die Erläuterung in der Formel gehalten.

@Willie: Vielen Dank, auch genauso wie ich es braucheSmile

@Jörg: Danke Jörg hat sich geklärtSmile

Bin begeistert..

Viele Grüße

Nick
Antwortento top
#7
Moin!
Warum nicht per Datedif(Erstellung;Buchung;"m")?
Dann brauchst Du keine Tagesdifferenz!
Bei den dann errechneten Monaten reicht ein einfaches Zählenwenn()

Tabelle1

ABCDEFG
1ErstellungBuchungZeitspanneMonateMonSortAnzahlAnteil
201.01.201815.04.201810430114,29   %
303.03.201804.03.2018101114,29   %
409.02.201816.03.20183512114,29   %
507.01.201824.05.201813743228,57   %
603.03.201805.08.201815554114,29   %
702.07.201802.09.20186225114,29   %
802.02.201805.05.20189236000,00   %
9Gesamt7
Formeln der Tabelle
ZelleFormel
D2=DATEDIF(A2;B2;"m")
F2=ZÄHLENWENN(D:D;E2)
G2=F2/$F$9
 


Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
[-] Folgende(r) 1 Benutzer sagt Danke an RPP63 für diesen Beitrag:
  • NickL
Antwortento top
#8
Hallo Ralf,

optimal, danke! Deine Ausführung eignet sich sehr gut für meine laufende Auswertung.

Vielen Dank und einen schönen AbendSmile

Nick
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste