Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zählenwenn und Fragezeichen
#1
Hallo Zusammen,

ich habe folgendes Problem: Es gibt eine Liste mit Firmennamen, die folgende Firmennamen beinhaltet:

Nürnberg
N?rnberg

Wenn ich versuche die Liste ohne Duplikate zu erstellen / Dank für A2 =WENN(ZÄHLENWENN(B$1:B2;B2)=1;MAX(A$1:A1)+1;""))

erkennt Excel N?rnberg als Nürnberg automatisch, wobei es sich um zwei verschiedene Firmennamen handelt.

Meine Frage ist das Folgende: Wie kann ich "Zählenwenn" dazu zu zwigen, beide Firmen als unterschiedliche Firmen zu erkennen und nicht wie die gleiche Firma?

Vielen Dank für Eure Ideen im Voraus.
Antwortento top
#2
Hola,

und was steht jetzt genau wo?

Ich tippe mal, du hast die Formel hier her?

http://www.excelformeln.de/formeln.html?welcher=194

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • ammaliante
Antwortento top
#3
Hallo,

dein Problem dürfte das Fragezeichen sein, das wird von XL hier als Wildcard erkannt.

Vielleicht hilft es dir wenn du mit Summenprodukt() statt mit Zählenwenn arbeitest, das scheint ein wenig sensibler zu sein:

Arbeitsblatt mit dem Namen 'Tabelle1'
 BC
1Nürnberg 
2N?rnberg1
3Nürnberg3
4Nürnberg 

ZelleFormel
C2=SUMMENPRODUKT(--(B1:B4=B2))
C3=SUMMENPRODUKT(--(B1:B4=B3))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
  • ammaliante
Antwortento top
#4
Ersetze das ? durch "UE" habs eben getestet das funktioniert...

Gruss Oliver
Antwortento top
#5
Hola,

Zitat:Ersetze das ? durch "UE" habs eben getestet das funktioniert...

und wenns nicht Nürnberg sondern K?ln ist?

Gruß,
steve1da
Antwortento top
#6
(21.01.2015, 15:24)steve1da schrieb: Hola,

und was steht jetzt genau wo?

Ich tippe mal, du hast die Formel hier her?

http://www.excelformeln.de/formeln.html?welcher=194

Gruß,
steve1da

Die Liste sieht folgenderweise aus:

NR Stadt
1 Nürnberg
2 München
Nürnberg
3 Berlin
N?rnberg
4 Kassel
Kassel
München



In der Zelle A2 steht =WENN(ZÄHLENWENN(B$1:B2;B2)=1;MAX(A$1:A1)+1;"")
In der Zelle A3 steht =WENN(ZÄHLENWENN(B$1:B3;B3)=1;MAX(A$1:A2)+1;"")

etc.
Huh

Und N?rnberg muss Nr. 4 sein, und Kassel - Nr. 5...
Herzlichen Dank nochmal für die Antwort
Antwortento top
#7
Hallo,

Peter hat Dir doch die Lösung gezeigt:

Arbeitsblatt mit dem Namen 'Tabelle5'
 AB
2NRStadt
31Nürnberg
42München
5 Nürnberg
63Berlin
74N?rnberg
85Kassel
9 Kassel
10 München
11  

ZelleFormel
A3=WENN(SUMMENPRODUKT(--($B$2:B3=B3))=1;MAX(A$2:A2)+1;"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß Atilla
[-] Folgende(r) 1 Benutzer sagt Danke an atilla für diesen Beitrag:
  • ammaliante
Antwortento top
#8
(22.01.2015, 10:56)atilla schrieb: Hallo,

Peter hat Dir doch die Lösung gezeigt:

Arbeitsblatt mit dem Namen 'Tabelle5'
 AB
2NRStadt
31Nürnberg
42München
5 Nürnberg
63Berlin
74N?rnberg
85Kassel
9 Kassel
10 München
11  

ZelleFormel
A3=WENN(SUMMENPRODUKT(--($B$2:B3=B3))=1;MAX(A$2:A2)+1;"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Ja, alles funktioniert perfekt, Dankeschön!
Antwortento top
#9
(21.01.2015, 15:32)Peter schrieb: Hallo,

dein Problem dürfte das Fragezeichen sein, das wird von XL hier als Wildcard erkannt.

Vielleicht hilft es dir wenn du mit Summenprodukt() statt mit Zählenwenn arbeitest, das scheint ein wenig sensibler zu sein:

Arbeitsblatt mit dem Namen 'Tabelle1'
 BC
1Nürnberg 
2N?rnberg1
3Nürnberg3
4Nürnberg 

ZelleFormel
C2=SUMMENPRODUKT(--(B1:B4=B2))
C3=SUMMENPRODUKT(--(B1:B4=B3))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Vielen herzlichen Dank!19
Antwortento top
#10
Hi ammaliante,

hier ein gut gemeinter Tipp:
dies hier ist kein Chat, in dem immer wieder der komplette Beitrag zitiert werden muß. Der Beitrag steht direkt drüber, es reicht, wenn nur der relevante Teil zitiert wird.
Vor allem die Anrede und den Gruß zu zitieren ist unnötig.

Es ist auch üblich einen Beitrag mit einer Anrede zu beginnen und mit einem Gruß zu beenden, das macht die Diskussion viel freundlicher. Wir chatten hier nicht.
[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
  • ammaliante
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste