Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn Funktion
#1
Hallo,

habe wieder eine kleine Frage und komme zur Zeit nicht drauf.
In einer Tabelle soll wenn in A2 etwas drin steht in B2 rot reingeschrieben werden
A3; in B3 grün
A4;in B4 blau
A5;in B5 gelb
A6 in B6 grau
A7 in B7 weiß
A8 in B8 Violett.

Wer kann helfen?
Für Profis eine Kleinigkeit.

Gruß

Bernd
Antwortento top
#2
Hallo,

du könntest eine Bedingte Formatierung verwenden.

B2 markieren - Bedingte Formatierung - Neue Regel - Formel zur Ermittlung - =A2<>"" - Formatieren und das gewünschte Format wählen.

Das wiederholst du für B3 bis B8.
Gruß
Peter
Antwortento top
#3
Danke Peter,

soweit i.O. aber es sollte in Feld 2 das Wort rot geschrieben werden.
Und dann in der Formatierung rot ausgefüllt mit weißem Text rot
usw.

Bernd
Antwortento top
#4
Hallo,

wenn da das Wort 'Rot' in der Zelle stehen soll (das habe ich so aus dem ersten Posting nicht herausgelesen) dann könntest du in B2 zusätzlich noch die Formel

=Wenn(A2<>"";"Rot";"")

einfügen.
Gruß
Peter
Antwortento top
#5
Hallo,

ich stelle mich zu däm.... an bekomme es nicht hin.
Kannst du ein Muster posten?

Bernd
Antwortento top
#6
Hallo,

vielleicht habe ich dein Vorhaben auch noch nicht verstanden.

Bei mir sieht das so aus, wobei ich für die Bedingte Formatierung jetzt einfach eine gelbe Hintergrundfarbe genommen habe:

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
2  
3TestRot

ZelleFormel
B2=WENN(A2<>"";"Rot";"")
B3=WENN(A3<>"";"Rot";"")

Zellebedingte Formatierung...Format
B21: =A2<>""abc
B31: =A3<>""abc
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Peter
Antwortento top
#7
(06.01.2015, 17:45)Bernd schrieb: Hallo,

ich stelle mich zu däm.... an bekomme es nicht hin.
Kannst du ein Muster posten?

Bernd

Hallo Bernd, das ist der falsche Ansatz, schick Du doch bitte (d)ein Muster... ... da sähe man wo es hakt...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#8
Hallo

jetzt habe ich es hat nur ein kleiner Tritt gefehlt.

Danke und schönen Abend.

Bernd


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 9,99 KB / Downloads: 8)
Antwortento top
#9
Hallo Bernd, du verbrätst hier 5 (in Worten fünf) bedingte Formatierungen... ... Wenn Du das anders herum angehst, kommst Du mit einer aus... - die bed. Formatierung aus Spalte B wird hier nicht richtig dargestellt..., dafür meine in Spalte C

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
2xRotRot
31grüngrün
41blaublau
51gelbgelb
61graugrau
71weißweiß
81violettviolett

ZelleFormel
B2=WENN($A2<>"";"Rot";"")
C2=WENN(A2<>"";"Rot";"")

Zellebedingte Formatierung...Format
B21: Zellwert ist gleich ="grau"abc
B22: Zellwert ist gleich ="gelb"abc
B23: Zellwert ist gleich ="blau"abc
B24: Zellwert ist gleich ="grün"abc
B25: Zellwert ist gleich ="rot"abc
C21: =$A2=""abc
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#10
Hallo Danke für die weitere Idee,
aber die 7 Farben sind in der Reihenfolge vorhanden.
Trage ich in A2-A4 nichts ein bleiben B2-B4 leer und es sind nur die letzten 4 Farben
ersichtlich.
Kann sein das es anders auch geht,aber ich muss es zum Verstehen in einer Tabelle sehen.

Bernd
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste