Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

zwei Zellen in einer Matrix abfragen
#1
Hallo Leute,

ich habe hier ein kleines Problem und benötige das Schwarmwissen.

Habe eine Tabelle mit über 20000 Zeilen. 
Mehrere Spalten, 2 davon sind der Vorname und Nachname.
Diese beiden Zellen möchte ich gemeinsam in einer Matrix abfragen und den Wert aus der 3. Spalte der Matrix in meiner Tabelle ausgeben.

Mit dem SVERWEIS lässt sich leider nur eine Zelle abfragen.
Kennt jemand von euch eine Kombi wie ich doch noch zu meinem Zeil komme ohne ein Makro zu schreiben.

das war mein Versuch es mit dem SVERWEIS zu lösen.

=SVERWEIS(B1+A1;USERID_NAME.xls!$A$2:$C$599;3;0)   = Fehler

=SVERWEIS(B1;USERID_NAME.xls!$A$2:$C$599;3;0)  = funktioniert, aber keine genauen Treffer

beste Grüße
Peter
Antwortento top
#2
Hola,

https://www.herber.de/excelformeln/pages...effer.html

Gruß,
steve1da
Antwortento top
#3
Hi,

mein Vorschlag mit einer eingeschobenen Hilfsspalte (einfach ausblenden):

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFG
1PanPeterPeter PanWert1Suche:Anna NassWert3
2GansGustavGustav GansWert2
3NassAnnaAnna NassWert3

ZelleFormel
C1=B1&" "&A1
G1=SVERWEIS(F1;$C$1:$D$3;2;0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#4
(14.05.2020, 13:22)WillWissen schrieb: Hi,

mein Vorschlag mit einer eingeschobenen Hilfsspalte (einfach ausblenden):
...


Moin Günter, mit ohne Hilfsspalte geht..:

PHP-Code:
=INDEX($D$1:$D$3;VERGLEICH(F1;INDEX($B$1:$B$3&" "&$A$1:$A$3;);0)) 

Hi Peter, warum machst du das nicht mit Power Query..?
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#5
Hi Jörg,

klar, Brett vorm Kopf. Blush
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#6
So nun will ich mich erst mal bedanken für eure Beiträge.

habe mir letztendlich eine zusätzliche Spalten angelegt wo ich Vor und Nachname zusammenführe und dann klappte es.

mit Power Query schau ich mir definitiv noch an.
Vielen Dank
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste