Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

zählen wenn, die letzte Zeile funktioniert nie
#1
Hallo,

ich habe folgendes Thema. Wenn in Spalte B ein Wert steht und in Spalte J nicht, dann zähle.
Das klappt auch soweit, bis auf die letzte Zeile. Und es ist egal ob es Zeile 5 oder 945 oder... ist. Es betrift immer die letze Zeile.

Das ist die Formel, die aber nicht von mir ist und es keinen Zugriff auf den Ersteller gibt.

=ZÄHLENWENN(INDIREKT("$J$8:$J$"&ZÄHLENWENN($B$8:$B$64624;"<>")+6;WAHR);"")

Weiß auch nicht für was das +6 steht.

Hoffe Ihr könnt helfen.

Danke
Antwortento top
#2
Moin

Verwende ZÄHLENWENNS().
Das mit +6 kann ich dir auch nicht erklären.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • datenmaus
Antwortento top
#3
heje excelfreunde,

einfach mal den Formelauswerter bemühen oder die Formel zerpflücken oder Du hast "7" leere Zeilen (J8, B8) und keine 6, also ersetze die 6 durch 7...vorausgesetzt,
die Tabelle ist lückenlos ( keine Leerzeile dazwischen)....
Vielen Dank
--Janosch
                                                     
Excel 2007 (SP3), 2010 (SP2), Win 10 Pro                              
Antwortento top
#4
(13.07.2020, 14:51)radagast schrieb: heje excelfreunde,

einfach mal den Formelauswerter bemühen oder die Formel zerpflücken oder Du hast "7" leere Zeilen (J8, B8) und keine 6, also ersetze die 6 durch 7...
Hallo,

wenn ich das so mache wie du geschrieben hast, also aus 6 mach 7 klappt es wieder.
Aber was ich nicht verstehe, es sind ja gar keine leere Zeilen vorhanden.
Antwortento top
#5
heje excelfreunde, datenmaus,

BSP:  Beginn Zelle B8 mit A und fülle bis Zelle B22 auf, das sind 15 Elemente. Daraus ergibt sich J8:J15 mit der 6 folgt J8:J21 mit der 7 eben J8:22.
in diesem Fall muss (n-1)*Zeilen hinzugefügt werden. Mit "n" gleich die erste befüllte Zeile, hier die 8....
Vielen Dank
--Janosch
                                                     
Excel 2007 (SP3), 2010 (SP2), Win 10 Pro                              
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste