Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

wer hat heute urlaub bzw. in Zukunft
#1
hallo,viele bunte Eier wünsch ich euch :)
ich brauche eure Hilfe zur Formelfindung.
ich brauche 2 Formel. Für heute Datum und für die Zukunftdatum
Die Datei ist selbsterklärend.

Danke


Angehängte Dateien
.xlsx   wer hat heute urlaub.xlsx (Größe: 9,03 KB / Downloads: 16)
Antworten Top
#2
Hi,

ZÄHLENWENN
SUMMENPRODUKT
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#3
Hallo

Hier eine mögliche PQ Lösung.
Außerdem Leerzeilen und Leerspalten haben in keiner Liste etwas zu suchen.


Angehängte Dateien
.xlsx   wer hat heute urlaub.xlsx (Größe: 17,41 KB / Downloads: 14)
Viele Grüße
PIVPQ
Antworten Top
#4
sorry,bin eben kein PQ Fetischist.Kurz gesagt...0 Ahnung :))
Und somit kann ich mit deine Lösung nix anfangen.
Ich geb zu,das ich die Testdatei zusammmengeklascht habe :)
ohne darauf zu achten,ob Leerzeilen vorhanden sind.
Selbst wenn ich die Leerzeilen lösche finde,
ich keine Lösung aus dem I-Net in Bezug auf Boskos Schlagwörter
um mir etl. die Formeln zusammen bastel zu können.

Danke
Antworten Top
#5
Hi,

hier mal was zum Lesen:

https://excelhero.de/funktionen/excel-su...-funktion/
https://www.ionos.de/digitalguide/online...-funktion/
https://www.online-excel.de/excel/singsel.php?f=53
https://www.projektmagazin.de/artikel/ex...menprodukt
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#6
Hi,

in G8 und J8 stehen die Datümer (1.4.2024 bzw. 21.4.2024).

G9:
=WENNFEHLER(INDEX($B$3:$E$3;AGGREGAT(15;6;SPALTE($A:$D)/(INDEX($B$8:$E$33;VERGLEICH(G$9;$A$8:$A$33;);)="u");ZEILEN($1:1)));"")

Formel nach J9 kopieren.
Beide Formeln dann runterziehen.
Ist jetzt erstmal auf die 4 Mitarbeiter ausgelegt. Sind es mehr, musst Du die Bereiche bei SPALTE($A:$D) sowie INDEX($B$3:$E$3... entsprechend erweitern.
Antworten Top
#7
@Boris
Danke,
auf Index Aggregat + Vergleich muss man kommen :(
Nur mit Index + Vergleich konnte es in meinen Versuchen nicht klappen.
Antworten Top
#8
Zitat:Nur mit Index + Vergleich konnte es in meinen Versuchen nicht klappen.

Ja. Da es halt mehrere Treffer ("u") gibt, muss man zunächst die richtige Zeile (anhand des Datums) finden und dann nacheinander alle "u" den entsprechenden Mitarbeitern zuordnen.
In Deiner Excelversion ist das mit AGGREGAT die einfachste Lösung.
In der neuesten Excelversion gibt es dafür andere Möglichkeiten.
Antworten Top
#9
Hallo,
die Formel in G9 passt so nicht.
Sie sollte so aussehen:  =WENNFEHLER(INDEX($B$3:$E$3;AGGREGAT(15;6;SPALTE($A:$D)/(INDEX($B$8:$E$33;VERGLEICH(G$8;$A$8:$A$33;);)="u");ZEILEN($1:1)));"")
Aus G$9 muss G$8 werden, sonst funktioniert der Vergleich nicht.

MfG Günter
Antworten Top
#10
Zitat:die Formel in G9 passt so nicht.

Das war ein Verschreiber meinerseits,


Zitat:in G8 und J8 stehen die Datümer (1.4.2024 bzw. 21.4.2024).

Sie stehen natürlich in Zeile 9.

Und die Formel gehört dann natürlich nicht in G9 sondern G10 Smile
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste